summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe13cabcffd..361c02c51e91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,16 +7,15 @@ pkgbase = darkradiant-git
license = GPL
license = LGPL
license = BSD
- makedepends = automake
- makedepends = libtool
- depends = wxgtk
+ makedepends = cmake
+ depends = wxgtk2
depends = ftgl
depends = glew
- depends = boost
- depends = boost-libs
depends = freealut
- depends = webkitgtk2
- depends = pybind11
+ depends = libvorbis
+ depends = python
+ depends = libsigc++
+ depends = eigen
provides = darkradiant
conflicts = darkradiant
source = DarkRadiant::git+https://github.com/codereader/DarkRadiant.git
diff --git a/PKGBUILD b/PKGBUILD
index 71724d3396ed..6f9863a33f1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=darkradiant-git
pkgrel=1
pkgdesc="Editor for The Dark Mod and Doom 3 (idTech4) based games"
-makedepends=(automake libtool)
-depends=(wxgtk ftgl glew boost boost-libs freealut webkitgtk2 pybind11)
+makedepends=(cmake)
+depends=(wxgtk2 ftgl glew freealut libvorbis python libsigc++ eigen)
conflicts=(darkradiant)
provides=(darkradiant)
arch=(x86_64)
@@ -20,8 +20,8 @@ pkgver(){
prepare(){
cd "$srcdir/DarkRadiant"
- ./autogen.sh
- ./configure
+ git submodule update --init --recursive
+ cmake .
}
build(){