summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD58
-rw-r--r--deque.patch57
3 files changed, 108 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 395b0a10b661..fc252f90ffe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = dash
pkgdesc = Dash peer-to-peer network based digital currency
- pkgver = 0.12.2.2
+ pkgver = 0.17.0.3
pkgrel = 1
- url = http://www.dashpay.io/
- arch = i686
+ url = http://www.dash.org/
arch = x86_64
license = MIT
makedepends = boost
- makedepends = automoc4
- makedepends = qrencode
- makedepends = miniupnpc
- makedepends = protobuf
- makedepends = zeromq
+ makedepends = dashpay-bls-signatures
+ makedepends = qt5-tools
depends = boost-libs
depends = libevent
- optdepends = zeromq: Optional, allows generating ZMQ notifications
+ depends = libbacktrace-git
optdepends = miniupnpc: Firewall-jumping support
- optdepends = db4.8: Wallet storage
- source = dash-daemon-0.12.2.2.tar.gz::https://github.com/dashpay/dash/archive/v0.12.2.2.tar.gz
+ optdepends = db4.8: Wallet storage and wallet portability
+ source = dash-daemon-0.17.0.3.tar.gz::https://github.com/dashpay/dash/archive/v0.17.0.3.tar.gz
source = dashd@.service
- sha256sums = fd5f1576bc8ef70e5823f665b86a334937813e300f037a03bcd127b83773d771
- sha256sums = 00b656fe05c5b58115d41c20ca7dfba6564eaa5335e3ff5c43c3eb8d9479cab9
+ source = deque.patch
+ source = qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch
+ sha512sums = c7a233f2c90e15a2a1f41fdccc23dd44a8772242a2c4cddd31242acdc8d910f980a39be9971676b08a7abf93604797d51d1109373841024e84cceb73a5fe7df8
+ sha512sums = b5c59efacbe85de0292590af12e35d8c001c2b71eebda9829754be48e61a70ad7e8ed99662ed4e8da53006eb72e1994c435813b35c16a9c566ddf455efe81b5b
+ sha512sums = f558e938285fbf14c2f1773b2b23018e52ee03d4d2c89c2e1c73dc5f84180b77acc229a2c041f2f058e3a0ea329302d3bd9ef683c5c88570f3d2c4ab5a7050a6
+ sha512sums = 6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d
pkgname = dash-daemon
pkgdesc = Dash peer-to-peer network based digital currency (daemon)
@@ -32,9 +32,9 @@ pkgname = dash-qt
pkgdesc = Dash peer-to-peer network based digital currency (Qt)
depends = boost-libs
depends = libevent
+ depends = libbacktrace-git
depends = qt5-base
depends = qt5-tools
depends = miniupnpc
optdepends = protobuf: Data interchange format used for payment protocol
optdepends = qrencode: Optional for generating QR codes
-
diff --git a/PKGBUILD b/PKGBUILD
index 05e3a216d2e7..68642053d1dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,40 @@
-# Maintainer: Marcin (CTRL) Wieczorek <marcin@marcin.co>
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+# Contributor: Marcin (CTRL) Wieczorek <marcin@marcin.co>
# Contributor: Nicolas Doualot <packages@slubman.info>
pkgname=('dash-daemon' 'dash-cli' 'dash-qt')
pkgbase=dash
-pkgver=0.12.2.2
+pkgver=0.17.0.3
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.dashpay.io/"
-depends=('boost-libs' 'libevent')
-makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq')
-optdepends=('zeromq: Optional, allows generating ZMQ notifications'
- 'miniupnpc: Firewall-jumping support'
- 'db4.8: Wallet storage')
+arch=('x86_64')
+url="http://www.dash.org/"
+depends=('boost-libs' 'libevent' 'libbacktrace-git')
+makedepends=('boost' 'dashpay-bls-signatures' 'qt5-tools')
+optdepends=('miniupnpc: Firewall-jumping support'
+ 'db4.8: Wallet storage and wallet portability')
pkgdesc="Dash peer-to-peer network based digital currency "
license=('MIT')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/dashpay/dash/archive/v${pkgver}.tar.gz"
- "dashd@.service")
-sha256sums=('fd5f1576bc8ef70e5823f665b86a334937813e300f037a03bcd127b83773d771'
- '00b656fe05c5b58115d41c20ca7dfba6564eaa5335e3ff5c43c3eb8d9479cab9')
+ 'dashd@.service'
+ 'deque.patch'
+ 'qpainterpath.patch::https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690.patch')
+sha512sums=('c7a233f2c90e15a2a1f41fdccc23dd44a8772242a2c4cddd31242acdc8d910f980a39be9971676b08a7abf93604797d51d1109373841024e84cceb73a5fe7df8'
+ 'b5c59efacbe85de0292590af12e35d8c001c2b71eebda9829754be48e61a70ad7e8ed99662ed4e8da53006eb72e1994c435813b35c16a9c566ddf455efe81b5b'
+ 'f558e938285fbf14c2f1773b2b23018e52ee03d4d2c89c2e1c73dc5f84180b77acc229a2c041f2f058e3a0ea329302d3bd9ef683c5c88570f3d2c4ab5a7050a6'
+ '6c3df861832926e72dfd820af42bb89c1c3bb556c3f8e2fd06544f76bf5369c992a556e717653e230e062e89b8f2ee4f5d02313f35672f8174deae48c3306a0d')
+
+prepare () {
+ cd "$pkgbase-$pkgver"
+ #deque patch 2020-02-12
+ #inlcude deque.h library in httpserver.cpp found in https://github.com/dogecoin/dogecoin/pull/1626
+ #will delete when dash fixes/commits this.
+ patch --forward --strip=1 --input="../../deque.patch"
+
+ #QPainterPath 2020-10-12 == Add missing QPainterPath include
+ #include QPainterPath library in src/qt/trafficgraphwidget.cpp found in https://github.com/bitcoin/bitcoin/commit/79b0a69e09c1a912122e6431ea3c530cc292c690
+ #will delete when dash fixes/commits this. This happens because dash is compiling against older versions of qt5-base
+ patch --forward --strip=1 --input="../../qpainterpath.patch"
+}
build() {
cd "${srcdir}/${pkgbase}-${pkgver}"
@@ -30,12 +47,11 @@ package_dash-daemon() {
pkgdesc+="(daemon)"
cd "${srcdir}/${pkgbase}-${pkgver}"
- install -Dm644 "${srcdir}/dashd@.service" "${pkgdir}/usr/lib/systemd/system/dash@.service"
- install -Dm755 "src/dashd" "${pkgdir}/usr/bin/dashd"
+ install -Dm644 "${srcdir}/dashd@.service" "${pkgdir}/usr/lib/systemd/system/dashd@.service"
+ install -Dm755 "src/dashd" "${pkgdir}/usr/bin/dashd"
install -Dm644 "contrib/debian/examples/dash.conf" "${pkgdir}/usr/share/doc/${pkgname}/examples/dash.conf"
- install -Dm644 "contrib/debian/manpages/dashd.1" "${pkgdir}/usr/share/man/man1/dashd.1"
- install -Dm644 "contrib/debian/manpages/dash.conf.5" "${pkgdir}/usr/share/man/man5/dash.conf.5"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "doc/man/dashd.1" "${pkgdir}/usr/share/man/man1/dashd.1"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
package_dash-cli() {
@@ -44,7 +60,7 @@ package_dash-cli() {
cd "${srcdir}/${pkgbase}-${pkgver}"
install -Dm755 "src/dash-cli" "${pkgdir}/usr/bin/dash-cli"
install -Dm755 "src/dash-tx" "${pkgdir}/usr/bin/dash-tx"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
package_dash-qt() {
@@ -55,8 +71,8 @@ package_dash-qt() {
pkgdesc+="(Qt)"
cd "${srcdir}/${pkgbase}-${pkgver}"
- install -Dm755 "src/qt/dash-qt" "${pkgdir}/usr/bin/dash-qt"
+ install -Dm755 "src/qt/dash-qt" "${pkgdir}/usr/bin/dash-qt"
install -Dm644 "contrib/debian/dash-qt.desktop" "${pkgdir}/usr/share/applications/dash.desktop"
- install -Dm644 "share/pixmaps/dash128.png" "${pkgdir}/usr/share/pixmaps/dash128.png"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 "share/pixmaps/dash128.png" "${pkgdir}/usr/share/pixmaps/dash128.png"
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}
diff --git a/deque.patch b/deque.patch
new file mode 100644
index 000000000000..2c0a4561701e
--- /dev/null
+++ b/deque.patch
@@ -0,0 +1,57 @@
+From d53a3bebee798e54a83fa49e8abd7e0e3f719e03 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Fri, 24 Jan 2020 20:16:27 +0000
+Subject: [PATCH] httpserver: include deque
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+It seems gcc 9.2.0 requires deque to be included:
+
+ x86_64-pc-linux-gnu-g++ -std=c++11 -DHAVE_CONFIG_H -I. -I../src/config -I. -I./obj -I/usr/include/db5.1/ -pthread -I/usr/include -I./leveldb/include -I./leveldb/helpers/memenv -I./secp256k1/include -pthread -I/usr/include/db5.1 -DHAVE_BUILD_INFO -D__STDC_FORMAT_MACROS -march=native -O2 -pipe -fomit-frame-pointer -c -o libdogecoin_server_a-httpserver.o `test -f 'httpserver.cpp' || echo './'`httpserver.cpp
+ httpserver.cpp:71:10: error: ‘deque’ in namespace ‘std’ does not name a template type
+ 71 | std::deque<std::unique_ptr<WorkItem>> queue;
+ | ^~~~~
+ httpserver.cpp:30:1: note: ‘std::deque’ is defined in header ‘<deque>’; did you forget to ‘#include <deque>’?
+ 29 | #include <event2/keyvalq_struct.h>
+ +++ |+#include <deque>
+ 30 |
+ httpserver.cpp: In member function ‘bool WorkQueue<WorkItem>::Enqueue(WorkItem*)’:
+ httpserver.cpp:110:13: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 110 | if (queue.size() >= maxDepth) {
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp:113:9: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 113 | queue.emplace_back(std::unique_ptr<WorkItem>(item));
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp: In member function ‘void WorkQueue<WorkItem>::Run()’:
+ httpserver.cpp:125:35: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 125 | while (running && queue.empty())
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp:129:31: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 129 | i = std::move(queue.front());
+ | ^~~~~
+ | Enqueue
+ httpserver.cpp: In member function ‘size_t WorkQueue<WorkItem>::Depth()’:
+ httpserver.cpp:154:16: error: ‘queue’ was not declared in this scope; did you mean ‘Enqueue’?
+ 154 | return queue.size();
+ | ^~~~~
+ | Enqueue
+---
+ src/httpserver.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/httpserver.cpp b/src/httpserver.cpp
+index dba9527305..5c08e676df 100644
+--- a/src/httpserver.cpp
++++ b/src/httpserver.cpp
+@@ -19,6 +19,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <signal.h>
++#include <deque>
+
+ #include <event2/event.h>
+