summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 687e120993ce..65d20d4622fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dashing
pkgdesc = A Dash Generator Script for Any HTML
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/technosophos/dashing
arch = i686
arch = x86_64
@@ -11,4 +11,3 @@ pkgbase = dashing
sha256sums = 81b21acae83c144f10d9eea05a0b89f0dcdfa694c3760c2a25bd4eab72a2a3b9
pkgname = dashing
-
diff --git a/PKGBUILD b/PKGBUILD
index 08eea14fbba9..15f793c3d928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=dashing
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Dash Generator Script for Any HTML"
url="https://github.com/technosophos/dashing"
license=('MIT')
@@ -18,9 +18,18 @@ prepare() {
build() {
cd "${pkgname}-${pkgver}"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+
go build \
-trimpath \
- -ldflags "-extldflags $LDFLAGS -X main.version=${pkgver}" \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" -X main.version=${pkgver}" \
-o dashing dashing.go
}