summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..501b80e8b858
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dattobd
+ pkgdesc = kernel module for taking block-level snapshots and incremental backups of Linux block devices
+ pkgver = 20150805
+ pkgrel = 1
+ url = https://github.com/datto/dattobd
+ arch = any
+ license = unknown
+ source = git://github.com/datto/dattobd.git
+ source = http://www.imegumii.nl/dattobd.conf
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = dattobd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8a63101bd00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yorick Rommers <yorick-rommers@hotmail.com>
+
+pkgname=dattobd
+pkgver=20150805
+pkgrel=1
+pkgdesc="kernel module for taking block-level snapshots and incremental backups of Linux block devices"
+arch=('any')
+url="https://github.com/datto/dattobd"
+license=('unknown')
+depends=('')
+source=("git://github.com/datto/dattobd.git"
+ "http://www.imegumii.nl/dattobd.conf")
+md5sums=("SKIP"
+ "SKIP")
+build() {
+ cd "$srcdir/$pkgname"
+ sudo make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ sudo make install
+ sudo install -D "src/dattobd.ko" "/usr/lib/modules//$(uname -r)/"
+ sudo install -D "../dattobd.conf" "/etc/modules-load.d/"
+ sudo modprobe dattobd
+}
+