summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..460ce56b5a9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dazzlie-git
+ pkgdesc = a command-line program that lets you convert between various retro tile graphics formats and PNG
+ pkgver = 31.facd1c9
+ pkgrel = 1
+ url = https://github.com/obskyr/dazzlie
+ arch = x86_64
+ license = MIT
+ makedepends = crystal
+ makedepends = git
+ depends = gc
+ depends = pcre
+ depends = libevent
+ source = git+ssh://git@github.com/obskyr/dazzlie.git
+ sha1sums = SKIP
+
+pkgname = dazzlie-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..840fb9ff3618
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jakub Kądziołka <kuba@kadziolka.net>
+
+pkgname=dazzlie-git
+pkgver=31.facd1c9
+pkgrel=1
+pkgdesc="a command-line program that lets you convert between various retro tile graphics formats and PNG"
+arch=(x86_64)
+url="https://github.com/obskyr/dazzlie"
+license=(MIT)
+depends=(gc pcre libevent)
+makedepends=(crystal git)
+source=(git+ssh://git@github.com/obskyr/dazzlie.git)
+sha1sums=(SKIP)
+
+pkgver(){
+ cd dazzlie
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare(){
+ sed -i 's/crystal deps/shards/;s/crystal build/\0 --link-flags -Wl,-z,relro,-z,now,--as-needed/' dazzlie/Makefile
+}
+
+build(){
+ cd dazzlie
+ make
+}
+
+package(){
+ cd dazzlie
+ install -Dm755 bin/dazzlie "$pkgdir/usr/bin/dazzlie"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/dazzlie-git/LICENSE"
+}