summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmksrcinfo6
-rw-r--r--packaging_steps.rst8
2 files changed, 14 insertions, 0 deletions
diff --git a/mksrcinfo b/mksrcinfo
new file mode 100755
index 000000000000..41ce36ccaacc
--- /dev/null
+++ b/mksrcinfo
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ -f .SRCINFO ]]; then
+ makepkg --printsrcinfo > .SRCINFO
+else
+ echo "No .SRCINFO file found."
+fi
diff --git a/packaging_steps.rst b/packaging_steps.rst
new file mode 100644
index 000000000000..1452450985d9
--- /dev/null
+++ b/packaging_steps.rst
@@ -0,0 +1,8 @@
+When new version is available do the following:
+
+#. Update the PKGBUILD file
+#. run ``updpkgsums``
+#. run ``mksrcinfo``
+#. run ``makepkg``
+#. Test the package by installing locally.
+#. If everything works, then commit and push