summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..357531daa169
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = dbuch-zsh-config
+ pkgdesc = dbuch zsh configuration
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/dbuch/
+ arch = x86_64
+ license = GNU
+ license = General
+ license = Public
+ license = License
+ license = v3.0
+ makedepends = git
+ depends = zsh
+ depends = exa
+ depends = bat
+ depends = skim
+ conflicts = grml-zsh-config
+ source = git+https://github.com/dbuch/dbuch-zsh-config.git
+ sha256sums = SKIP
+
+pkgname = dbuch-zsh-config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60efba20fade
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Daniel Buch Hansen (dbuch) <boogiewasthere@gmail.com>
+
+pkgname=dbuch-zsh-config
+pkgver=1
+pkgrel=1
+pkgdesc="dbuch zsh configuration"
+url="https://github.com/dbuch/"
+arch=(x86_64)
+license=(GNU General Public License v3.0)
+depends=(zsh exa bat skim)
+makedepends=(git)
+source=("git+https://github.com/dbuch/dbuch-zsh-config.git")
+conflicts=('grml-zsh-config')
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+
+ git submodule init
+
+ git config --local submodule.subprojects/zsh-async.url "$srcdir/zsh-async"
+
+ git submodule update
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+
+ install -D -m644 zshrc.skel \
+ ${pkgdir}/etc/skel/zshrc
+
+ install -D -m644 zshrc \
+ ${pkgdir}/etc/zsh/zshrc
+
+ install -D -m644 zsh-async/async.zsh \
+ ${pkgdir}/usr/share/zsh/functions/Async/async
+
+ install -D -m644 dbuch-prompt.zsh \
+ ${pkgdir}/usr/share/zsh/functions/Prompts/prompt_dbuch_setup
+}
+
+# vim:set sw=2 et: