summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO29
-rw-r--r--0001-units-Enable-statically.patch60
-rw-r--r--PKGBUILD141
3 files changed, 185 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cc29f5d255b..6a3272886d36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = dbus-broker-git
pkgdesc = Linux D-Bus Message Broker
- pkgver = 31.14.g5d475cf
+ pkgver = 35.0.gb71a541
pkgrel = 1
- url = https://github.com/bus1/dbus-broker
+ url = https://github.com/bus1/dbus-broker/wiki
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = meson>=0.60.0
makedepends = systemd
@@ -14,8 +14,6 @@ pkgbase = dbus-broker-git
depends = libcap-ng>=0.6
depends = linux>=4.17
depends = systemd-libs>=230
- provides = dbus-broker
- conflicts = dbus-broker
source = dbus-broker-git::git+https://github.com/bus1/dbus-broker
source = c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1
source = c-ini-1::git+https://github.com/c-util/c-ini#branch=v1
@@ -24,6 +22,8 @@ pkgbase = dbus-broker-git
source = c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1
source = c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1
source = c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1
+ source = 0001-units-Enable-statically.patch
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -34,3 +34,22 @@ pkgbase = dbus-broker-git
sha256sums = SKIP
pkgname = dbus-broker-git
+ depends = audit>=3.0
+ depends = expat>=2.2
+ depends = libcap-ng>=0.6
+ depends = linux>=4.17
+ depends = systemd-libs>=230
+ depends = libaudit.so
+ depends = libcap-ng.so
+ depends = libexpat.so
+ depends = libsystemd.so
+ provides = dbus-broker
+ conflicts = dbus-broker
+
+pkgname = dbus-broker-units-git
+ pkgdesc = Linux D-Bus Message Broker - Service units
+ depends = dbus-broker
+ provides = dbus-broker-units
+ provides = dbus-units
+ conflicts = dbus-broker-units
+ conflicts = dbus-daemon-units
diff --git a/0001-units-Enable-statically.patch b/0001-units-Enable-statically.patch
new file mode 100644
index 000000000000..1ccaf0ac32e1
--- /dev/null
+++ b/0001-units-Enable-statically.patch
@@ -0,0 +1,60 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
+Date: Fri, 8 Dec 2023 21:28:52 +0100
+Subject: [PATCH] units: Enable statically
+
+---
+ src/units/system/dbus-broker.service.in | 3 ---
+ src/units/system/meson.build | 5 +++++
+ src/units/user/dbus-broker.service.in | 3 ---
+ src/units/user/meson.build | 5 +++++
+ 4 files changed, 10 insertions(+), 6 deletions(-)
+
+diff --git a/src/units/system/dbus-broker.service.in b/src/units/system/dbus-broker.service.in
+index cc5ae3617ea5..2f07a1e7ce77 100644
+--- a/src/units/system/dbus-broker.service.in
++++ b/src/units/system/dbus-broker.service.in
+@@ -17,6 +17,3 @@ PrivateTmp=true
+ PrivateDevices=true
+ ExecStart=@bindir@/dbus-broker-launch --scope system --audit
+ ExecReload=@bindir@/busctl call org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus ReloadConfig
+-
+-[Install]
+-Alias=dbus.service
+diff --git a/src/units/system/meson.build b/src/units/system/meson.build
+index a946b4673130..97f1d46fc5e2 100644
+--- a/src/units/system/meson.build
++++ b/src/units/system/meson.build
+@@ -8,3 +8,8 @@ configure_file(
+ configuration: conf,
+ install_dir: conf.get('systemunitdir'),
+ )
++
++install_symlink('dbus.service',
++ pointing_to: 'dbus-broker.service',
++ install_dir: conf.get('systemunitdir'),
++)
+diff --git a/src/units/user/dbus-broker.service.in b/src/units/user/dbus-broker.service.in
+index 15de0d5b611d..ffcf632e9bbd 100644
+--- a/src/units/user/dbus-broker.service.in
++++ b/src/units/user/dbus-broker.service.in
+@@ -13,6 +13,3 @@ Sockets=dbus.socket
+ ExecStart=@bindir@/dbus-broker-launch --scope user
+ ExecReload=@bindir@/busctl --user call org.freedesktop.DBus /org/freedesktop/DBus org.freedesktop.DBus ReloadConfig
+ Slice=session.slice
+-
+-[Install]
+-Alias=dbus.service
+diff --git a/src/units/user/meson.build b/src/units/user/meson.build
+index 876ff9817bae..b45aee31f205 100644
+--- a/src/units/user/meson.build
++++ b/src/units/user/meson.build
+@@ -8,3 +8,8 @@ configure_file(
+ configuration: conf,
+ install_dir: conf.get('userunitdir'),
+ )
++
++install_symlink('dbus.service',
++ pointing_to: 'dbus-broker.service',
++ install_dir: conf.get('userunitdir'),
++)
diff --git a/PKGBUILD b/PKGBUILD
index 450a556a4467..cc474c2c870f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,127 @@
-# Maintainer: David Herrmann <dh.herrmann@gmail.com>
+# Maintainer: David Rheinsberg <david@readahead.eu>
-_pkgorg=bus1
-_pkgname=dbus-broker
-pkgdesc='Linux D-Bus Message Broker'
-pkgver=31.14.g5d475cf
+pkgbase="dbus-broker-git"
+pkgname=(
+ "dbus-broker-git"
+ "dbus-broker-units-git"
+)
+
+pkgdesc="Linux D-Bus Message Broker"
+pkgver=35.0.gb71a541
pkgrel=1
-pkgname=$_pkgname-git
-arch=('x86_64')
-url="https://github.com/$_pkgorg/$_pkgname"
-license=('Apache')
-depends=('audit>=3.0' 'expat>=2.2' 'libcap-ng>=0.6' 'linux>=4.17' 'systemd-libs>=230')
-makedepends=('git' 'meson>=0.60.0' 'systemd' 'python-docutils')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-
-source=("$pkgname::git+https://github.com/$_pkgorg/$_pkgname"
- "c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1"
- "c-ini-1::git+https://github.com/c-util/c-ini#branch=v1"
- "c-list-3::git+https://github.com/c-util/c-list#branch=v3"
- "c-rbtree-3::git+https://github.com/c-util/c-rbtree#branch=v3"
- "c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1"
- "c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1"
- "c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+arch=("x86_64")
+license=("Apache-2.0")
+url="https://github.com/bus1/dbus-broker/wiki"
+
+depends=(
+ 'audit>=3.0'
+ 'expat>=2.2'
+ 'libcap-ng>=0.6'
+ 'linux>=4.17'
+ 'systemd-libs>=230'
+)
+makedepends=(
+ 'git'
+ 'meson>=0.60.0'
+ 'systemd'
+ 'python-docutils'
+)
+
+source=(
+ "$pkgbase::git+https://github.com/bus1/dbus-broker"
+ "c-dvar-1::git+https://github.com/c-util/c-dvar#branch=v1"
+ "c-ini-1::git+https://github.com/c-util/c-ini#branch=v1"
+ "c-list-3::git+https://github.com/c-util/c-list#branch=v3"
+ "c-rbtree-3::git+https://github.com/c-util/c-rbtree#branch=v3"
+ "c-shquote-1::git+https://github.com/c-util/c-shquote#branch=v1"
+ "c-stdaux-1::git+https://github.com/c-util/c-stdaux#branch=v1"
+ "c-utf8-1::git+https://github.com/c-util/c-utf8#branch=v1"
+ "0001-units-Enable-statically.patch"
+)
+
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
pkgver() {
- cd $pkgname
+ cd "$pkgbase"
git describe --long --tags | sed 's/^v//;s/-/./g'
}
prepare() {
- cd $pkgname
+ cd "$pkgbase"
local sp
for sp in {dvar-1,ini-1,list-3,rbtree-3,shquote-1,stdaux-1,utf8-1}; do
ln -fs "$(realpath --relative-to "subprojects" "$srcdir/c-$sp")" "subprojects/libc$sp"
done
+
+ patch -Np1 -i "../0001-units-Enable-statically.patch"
}
build() {
- arch-meson $pkgname build \
- -D audit=true \
- -D docs=true \
- -D linux-4-17=true \
+ local meson_options=(
+ -D audit=true
+ -D docs=true
+ -D linux-4-17=true
-D system-console-users=gdm,sddm,lightdm,lxdm
- ninja -C build
+ )
+
+ arch-meson "$pkgbase" build "${meson_options[@]}"
+ meson compile -C build
}
check() {
meson test -C build --print-errorlogs
}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+_pick() {
+ local p="$1" f d; shift
+ for f; do
+ d="$srcdir/$p/${f#$pkgdir/}"
+ mkdir -p "$(dirname "$d")"
+ mv "$f" "$d"
+ rmdir -p --ignore-fail-on-non-empty "$(dirname "$f")"
+ done
+}
+
+package_dbus-broker-git() {
+ depends+=(
+ "libaudit.so"
+ "libcap-ng.so"
+ "libexpat.so"
+ "libsystemd.so"
+ )
+ provides=("dbus-broker")
+ conflicts=("dbus-broker")
+
+ meson install -C build --destdir "$pkgdir"
+
+ _pick unit "$pkgdir"/usr/lib/systemd/{system,user}/dbus.service
+}
+
+package_dbus-broker-units-git() {
+ pkgdesc+=" - Service units"
+ depends=("dbus-broker")
+ provides=(
+ "dbus-broker-units"
+ "dbus-units"
+ )
+ conflicts=(
+ "dbus-broker-units"
+ "dbus-daemon-units"
+ )
+
+ mv unit/* "$pkgdir"
}
-# vim:set sw=2 et:
+# vim:set sw=2 sts=-1 et: