summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--30-dbus.sh6
-rw-r--r--PKGBUILD64
-rw-r--r--dbus51
-rw-r--r--dbus-nosystemd.install6
5 files changed, 165 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2133131bffc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = dbus-nosystemd
+ pkgdesc = Freedesktop.org message bus system
+ pkgver = 1.8.18
+ pkgrel = 1
+ url = http://www.freedesktop.org/Software/dbus
+ install = dbus-nosystemd.install
+ arch = i686
+ arch = x86_64
+ groups = eudev-base
+ license = GPL
+ license = custom
+ makedepends = libx11
+ makedepends = xmlto
+ makedepends = docbook-xsl
+ depends = expat
+ depends = coreutils
+ depends = filesystem
+ depends = shadow
+ depends = libdbus>=1.8.18
+ optdepends = libx11: dbus-launch support
+ optdepends = dbus-openrc: dbus openrc initscript
+ provides = dbus-core
+ provides = dbus=1.8.18
+ conflicts = dbus-core
+ conflicts = dbus
+ conflicts = dbus-eudev
+ replaces = dbus-core
+ replaces = dbus
+ replaces = dbus-eudev
+ source = http://dbus.freedesktop.org/releases/dbus/dbus-1.8.18.tar.gz
+ source = 30-dbus.sh
+ source = dbus
+ md5sums = 83e607e9ccb1c921d5b6bbea2376a36c
+ md5sums = 6683a05bd749929ef9442816c22c3268
+ md5sums = 6f116e46adcbe99326ee67e597598d29
+
+pkgname = dbus-nosystemd
+
diff --git a/30-dbus.sh b/30-dbus.sh
new file mode 100644
index 000000000000..96a51828ab9c
--- /dev/null
+++ b/30-dbus.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+# launches a session dbus instance
+if [ -z "${DBUS_SESSION_BUS_ADDRESS-}" ] && type dbus-launch >/dev/null; then
+ eval $(dbus-launch --sh-syntax --exit-with-session)
+fi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a741850e103a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Link Dupont <link@subpop.net>
+#
+pkgname=dbus-nosystemd
+pkgver=1.8.18
+pkgrel=1
+pkgdesc="Freedesktop.org message bus system"
+url="http://www.freedesktop.org/Software/dbus"
+arch=(i686 x86_64)
+license=('GPL' 'custom')
+groups=('eudev-base')
+# dep on shadow for install scriptlet FS#29341
+depends=('expat' 'coreutils' 'filesystem' 'shadow' "libdbus>=${pkgver}")
+makedepends=('libx11' 'xmlto' 'docbook-xsl')
+optdepends=('libx11: dbus-launch support'
+ 'dbus-openrc: dbus openrc initscript')
+provides=('dbus-core' "dbus=${pkgver}")
+conflicts=('dbus-core' 'dbus' 'dbus-eudev')
+replaces=('dbus-core' 'dbus' 'dbus-eudev')
+install=dbus-nosystemd.install
+source=(http://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz #{,.asc}
+ 30-dbus.sh dbus)
+md5sums=('83e607e9ccb1c921d5b6bbea2376a36c'
+ '6683a05bd749929ef9442816c22c3268'
+ '6f116e46adcbe99326ee67e597598d29')
+
+build() {
+ cd dbus-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/dbus-1.0 \
+ --with-dbus-user=dbus \
+ --with-system-pid-file=/run/dbus/pid \
+ --with-system-socket=/run/dbus/system_bus_socket \
+ --with-console-auth-dir=/run/console/ \
+ --enable-inotify \
+ --disable-verbose-mode \
+ --disable-static \
+ --disable-tests \
+ --disable-asserts \
+ --disable-systemd
+
+ make
+}
+
+package(){
+ cd dbus-$pkgver
+
+ # Disable installation of libdbus
+ sed -i -e 's/^SUBDIRS = dbus/SUBDIRS =/' Makefile
+
+ make DESTDIR="$pkgdir" install
+
+ rm -rf "${pkgdir}/var/run"
+ rm -rf "${pkgdir}/usr/lib/pkgconfig"
+
+ install -Dm755 ../dbus "$pkgdir/etc/rc.d/dbus"
+ install -Dm755 ../30-dbus.sh "$pkgdir/etc/X11/xinit/xinitrc.d/30-dbus.sh"
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/dbus/COPYING"
+}
+
diff --git a/dbus b/dbus
new file mode 100644
index 000000000000..a3d874d61e10
--- /dev/null
+++ b/dbus
@@ -0,0 +1,51 @@
+#!/bin/bash
+
+# general config
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+case $1 in
+ start)
+ stat_busy "Starting D-BUS system messagebus"
+ if [[ ! -d /run/dbus ]] ; then
+ install -m755 -g dbus -o dbus -d /run/dbus
+ fi
+
+ if ! dbus-daemon --system; then
+ stat_fail
+ else
+ add_daemon dbus
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping D-BUS system messagebus"
+ if ! { [[ -f /run/dbus/pid ]] && kill $(</run/dbus/pid); }; then
+ stat_fail
+ else
+ rm -f /run/dbus/pid
+ rm_daemon dbus
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ sleep 1
+ $0 start
+ ;;
+ reload)
+ stat_busy "Reloading D-BUS configuration"
+ if ! { [[ -f /run/dbus/pid ]] && dbus-send \
+ --system --type=method_call \
+ --dest=org.freedesktop.DBus \
+ / org.freedesktop.DBus.ReloadConfig; }; then
+ stat_fail
+ else
+ stat_done
+ fi
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart|reload}"
+ ;;
+esac
+exit 0
diff --git a/dbus-nosystemd.install b/dbus-nosystemd.install
new file mode 100644
index 000000000000..01506cf96e8f
--- /dev/null
+++ b/dbus-nosystemd.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ # Make sure new rc script can shutdown running dbus
+ if [ -f run/dbus.pid -a -d run/dbus ]; then
+ mv run/dbus.pid run/dbus/pid
+ fi
+}