aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Dockerfile10
-rw-r--r--PKGBUILD5
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38c43df9ca7d..b1fb08eecc7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddev-edge-bin
pkgdesc = DDEV-Local: a local PHP development environment system (edge channel)
- pkgver = 1.14.0_rc3
+ pkgver = 1.14.0_
pkgrel = 1
url = https://github.com/drud/ddev
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = ddev-edge-bin
depends = docker-compose
optdepends = bash-completion: subcommand completion support
provides = ddev
- source = https://github.com/drud/ddev/releases/download/v1.14.0-rc3/ddev_linux.v1.14.0-rc3.tar.gz
- sha256sums = 5ec3ff33221035f2efc28cf0e031805b0ab4fe005b2b32a9a39a89fb7d0e919c
+ source = https://github.com/drud/ddev/releases/download/v1.14.0/ddev_linux.v1.14.0.tar.gz
+ sha256sums = 4f4288f7467ffa93e31fcccd7df433f662fe1884c642fc4f63b152c9023ab246
pkgname = ddev-edge-bin
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..91f974cf464b
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,10 @@
+# Build this with `docker build -t arch .`
+# Then run it with
+# docker run -it --rm --mount type=bind,source=$(pwd),target=/tmp/ddev-bin --workdir=/tmp/ddev-bin arch
+# su builder
+# makepkg --printsrcinfo > .SRCINFO
+# makepkg -s
+FROM archlinux:latest
+RUN echo | pacman -Sy sudo binutils fakeroot docker docker-compose
+RUN useradd builder
+CMD bash -c "su builder"
diff --git a/PKGBUILD b/PKGBUILD
index 890beebac9a2..3aeab9972732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
_name="ddev"
_version="1.14.0"
-_versionsuffix="rc3"
-_downloadver="$_version"-"$_versionsuffix"
+_downloadver=$_version
pkgname="$_name-edge-bin"
pkgver="$_version"_"$_versionsuffix"
pkgrel=1
@@ -15,7 +14,7 @@ provides=("$_name")
depends=('docker' 'docker-compose')
optdepends=('bash-completion: subcommand completion support')
source=("https://github.com/drud/ddev/releases/download/v$_downloadver/ddev_linux.v$_downloadver.tar.gz")
-sha256sums=("4d87278ddac490af238b45ae2635148d1eb832d560dfbcd51682bc88f4087a6a")
+sha256sums=("4f4288f7467ffa93e31fcccd7df433f662fe1884c642fc4f63b152c9023ab246")
package() {
install -D -m 0755 ddev "$pkgdir/usr/bin/ddev"