summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
-rw-r--r--translation_pt-br.patch261
3 files changed, 91 insertions, 215 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b98246222a9e..af6575fc2c5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = ddutility-bin-pt-br
pkgdesc = Gravar e fazer backup dos arquivos IMG e ISO do sistema operacional no cartão de memória ou no disco
- pkgver = 1.5
+ pkgver = 1.6
pkgrel = 1
url = https://www.thefanclub.co.za/how-to/dd-utility-write-and-backup-operating-system-img-and-iso-files-memory-card-or-disk
arch = any
license = custom
+ depends = bash
+ depends = coreutils
+ depends = gzip
depends = lsof
depends = udevil
- depends = gksu
depends = xz
- depends = coreutils
- depends = bash
- depends = gzip
- depends = zip
depends = zenity
+ depends = zip
provides = ddutility
conflicts = ddutility-bin
- source = https://raw.githubusercontent.com/thefanclub/dd-utility/master/DEB/ddutility_1.5_all.deb
+ options = !strip
+ options = !emptydirs
+ source = https://raw.githubusercontent.com/thefanclub/dd-utility/master/DEB/ddutility_1.6_all.deb
source = translation_pt-br.patch
- sha256sums = 49417d46f41550ef1346670269f7d08be499ef4127fca99d762dfb90942ce445
- sha256sums = 8063e165853a79c342e472e973a25c70a2de82071277f221bc82c0b4f73b06fa
+ sha256sums = bf01d8fc8fafaf76ab751fbcf6b54d75930581e62d602fcaf4cd28fe23579224
+ sha256sums = de5c1fca6693f3b545ea5094a921fe67a3bbc43372f67992fee9bb06a8e26083
pkgname = ddutility-bin-pt-br
diff --git a/PKGBUILD b/PKGBUILD
index 5db0499a646f..23f83a663225 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,27 @@
_pkgname=ddutility
pkgname=ddutility-bin-pt-br
-pkgver=1.5
+pkgver=1.6
pkgrel=1
pkgdesc="Gravar e fazer backup dos arquivos IMG e ISO do sistema operacional no cartão de memória ou no disco"
arch=('any')
license=('custom')
url="https://www.thefanclub.co.za/how-to/dd-utility-write-and-backup-operating-system-img-and-iso-files-memory-card-or-disk"
-depends=('lsof' 'udevil' 'gksu' 'xz' 'coreutils' 'bash' 'gzip' 'zip' 'zenity')
+depends=('bash' 'coreutils' 'gzip' 'lsof' 'udevil' 'xz' 'zenity' 'zip')
conflicts=('ddutility-bin')
provides=('ddutility')
+options=('!strip' '!emptydirs')
source=("https://raw.githubusercontent.com/thefanclub/dd-utility/master/DEB/${_pkgname}_${pkgver}_all.deb"
'translation_pt-br.patch')
-sha256sums=('49417d46f41550ef1346670269f7d08be499ef4127fca99d762dfb90942ce445'
- '8063e165853a79c342e472e973a25c70a2de82071277f221bc82c0b4f73b06fa')
-
-prepare() {
- tar -xJf data.tar.xz
- patch -p1 -i ./translation_pt-br.patch
-}
+sha256sums=('bf01d8fc8fafaf76ab751fbcf6b54d75930581e62d602fcaf4cd28fe23579224'
+ 'de5c1fca6693f3b545ea5094a921fe67a3bbc43372f67992fee9bb06a8e26083')
package_ddutility-bin-pt-br() {
- cd "$srcdir"
- # dump usr files to /usr
- mv usr "$pkgdir"
- # dump opt files to /opt
- mv opt "$pkgdir"
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ cd "${pkgdir}"
+ patch -p1 -i ${srcdir}/translation_pt-br.patch
+
+ install -Dm644 "${pkgdir}/usr/share/doc/ddutility/copyright" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
diff --git a/translation_pt-br.patch b/translation_pt-br.patch
index 07a538889238..554a9d601a96 100644
--- a/translation_pt-br.patch
+++ b/translation_pt-br.patch
@@ -1,57 +1,23 @@
-From dc4ffd7d235c2c0a2055ae29ebb0bce5ef4ec4f5 Mon Sep 17 00:00:00 2001
+From c7374fcfd0accf6415884354b4d4afcfb4a22143 Mon Sep 17 00:00:00 2001
From: tioguda <guda.flavio@gmail.com>
-Date: Tue, 10 Jul 2018 02:27:26 -0300
+Date: Sat, 25 Apr 2020 02:19:14 -0300
Subject: Translation into Portuguese of Brazil
diff --git a/opt/thefanclub/ddutility/ddutility.sh b/opt/thefanclub/ddutility/ddutility.sh
-index 67c5ce6..7693ea8 100755
+index 5301f2a..db76445 100755
--- a/opt/thefanclub/ddutility/ddutility.sh
+++ b/opt/thefanclub/ddutility/ddutility.sh
-@@ -1,6 +1,6 @@
- #!/bin/bash
- #
--# dd Utility version 1.5 - Linux/Ubuntu
-+# dd Utility version 1.5 - Linux/Ubuntu
- #
- # Write and Backup Operating System IMG and ISO files on Memory Card or Disk
- #
-@@ -22,7 +22,7 @@
- # with this program. If not, see <http://www.gnu.org/licenses/>.
- ### END LICENSE
- #
--### NOTES
-+### NOTES
- #
- # Dependencies : zenity zip xz gzip tar dd udevil
- #
-@@ -37,15 +37,15 @@ version="1.5 beta"
- export LC_ALL=en_US.UTF-8
- mountpath="/media/$SUDO_USER"
-
--# Set Icon directory and file
-+# Set Icon directory and file
- iconfile="notification-device"
-
- # Read args
- if [ "$1" == "--Backup" ] ; then
+@@ -45,7 +45,7 @@ if [ "$1" == "--Backup" ] ; then
action="Backup"
fi
--if [ "$1" == "--Restore" ] ; then
+ if [ "$1" == "--Restore" ] ; then
- action="Restore"
-+if [ "$1" == "--Restaurar" ] ; then
+ action="Restaurar"
fi
# Check if Disk Dev was dropped
-@@ -58,13 +58,13 @@ if [ "$(dirname "$1")" == "$mountpath" ] ; then
- fi
- fi
-
--# Check if Restore file was dropped
-+# Check if Restaurar file was dropped
- if [ -f "$1" ] ; then
- # Check extension if file
+@@ -64,7 +64,7 @@ if [ -f "$1" ] ; then
extension=$( echo "${1##*.}" | tr '[:upper:]' '[:lower:]' )
case "$extension" in
img|iso|zip|gz|xz)
@@ -60,25 +26,7 @@ index 67c5ce6..7693ea8 100755
imagepath=$1
;;
esac
-@@ -74,13 +74,13 @@ fi
- function filesizehuman () {
- filesize=$1
- if [ "$filesize" -gt 1000000000000 ] ; then
-- fsize="$( echo "scale=1; $filesize/1000000000000" | bc ) TB"
-+ fsize="$( echo "scale=1; $filesize/1000000000000" | bc ) TB"
- elif [ "$filesize" -gt 1000000000 ] ; then
-- fsize="$( echo "scale=1; $filesize/1000000000" | bc ) GB"
-+ fsize="$( echo "scale=1; $filesize/1000000000" | bc ) GB"
- elif [ "$filesize" -gt 1000000 ] ; then
-- fsize="$( echo "scale=1; $filesize/1000000" | bc ) MB"
-+ fsize="$( echo "scale=1; $filesize/1000000" | bc ) MB"
- elif [ "$filesize" -gt 1000 ] ; then
-- fsize="$( echo "scale=1; $filesize/1000" | bc ) KB"
-+ fsize="$( echo "scale=1; $filesize/1000" | bc ) KB"
- fi
- echo $fsize
- }
-@@ -94,41 +94,41 @@ function progressmonitor () {
+@@ -94,19 +94,19 @@ function progressmonitor () {
# Backup Progress
if [ "$action" == "Backup" ] ; then
# img
@@ -91,41 +39,26 @@ index 67c5ce6..7693ea8 100755
- if [ "$compression" == "Yes" ] ; then
+ if [ "$compression" == "Sim" ] ; then
# Calc progress for compressed backup using read offset on disk device and total size of disk
-- outputfilesize=$( lsof -o0 -o -e /run/user/1000/gvfs | grep "$inputfile" | awk {'print $7'} | cut -d 't' -f2 )
-- fi
-+ outputfilesize=$( lsof -o0 -o -e /run/user/1000/gvfs | grep "$inputfile" | awk {'print $7'} | cut -d 't' -f2 )
-+ fi
+ outputfilesize=$( lsof -o0 -o -e /run/user/"$(ls /run/user | xargs)"/gvfs 2>/dev/null | grep "$inputfile" | awk {'print $7'} | cut -d 't' -f2 )
+ fi
fi
--
-- # Restore Progress
+
+ # Restore Progress
- if [ "$action" == "Restore" ] ; then
-+
-+ # Restaurar Progress
+ if [ "$action" == "Restaurar" ] ; then
# Calc progress by using offset bytes on disk device and uncompressed size pf restore file
- outputfilesize=$( lsof -o0 -o -p $pid -e /run/user/1000/gvfs | grep "$outputfile" | awk {'print $7'} | cut -d 't' -f2 )
+ outputfilesize=$( lsof -o0 -o -p $pid -e /run/user/"$(ls /run/user | xargs)"/gvfs 2>/dev/null | grep "$outputfile" | awk {'print $7'} | cut -d 't' -f2 )
fi
--
-+
- # Calc percentage of progress
- if [ "$outputfilesize" ] ; then
-- percentage=$(printf "%.0f" $( echo "scale=2; ($outputfilesize/$totalbytes)*100" | bc ))
-+ percentage=$(printf "%.0f" $( echo "scale=2; ($outputfilesize/$totalbytes)*100" | bc ))
- fi
--
-+
+@@ -118,7 +118,7 @@ function progressmonitor () {
+
# Wait for buffer to finish
if [ ! "$outputfilesize" ] && [ "$percentage" -gt 90 ] ; then
- echo "# $action almost done..."
+ echo "# $action quase pronto..."
fi
--
-+
+
# Update progress bar
- echo "$percentage"
- sleep 1
--
-+
+@@ -128,7 +128,7 @@ function progressmonitor () {
# Check if process still active
processactive=$( ps -p $pid -o pid= )
done
@@ -141,49 +74,28 @@ index 67c5ce6..7693ea8 100755
- notify-send --icon=$iconfile "$apptitle" "No Volumes Detected"
+ notify-send --icon=$iconfile "$apptitle" "Nenhum volume detectado"
# Ask for redetect
-- zenity --question --title="$apptitle - $action" --text="<big><b>No Volumes Detected</b></big> \n\nInsert a memory card or removable storage and click Retry.\n\nSelect Cancel to Quit" --ok-label=Retry --cancel-label=Cancel
-+ zenity --question --title="$apptitle - $action" --text="<big><b>Nenhum volume detectado</b></big> \n\nInsira um cartão de memória ou armazenamento removível e clique em Repetir.\n\nSelecione Cancelar para Sair" --ok-label=Repetir --cancel-label=Cancelar --width=400 --height=100
+- zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>No Volumes Detected</b></big> \n\nInsert a memory card or removable storage and click Retry.\n\nSelect Cancel to Quit" --ok-label=Retry --cancel-label=Cancel
++ zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>Nenhum volume detectado</b></big> \n\nInsira um cartão de memória ou armazenamento removível e clique em Repetir.\n\nSelecione Cancelar para sair" --ok-label=Repetir --cancel-label=Cancelar
if [ ! $? -eq 0 ] ; then
exit 1
fi
-@@ -162,7 +162,7 @@ function getdevdisk () {
- countdev=$( echo $devdisks | wc -w )
- done
-
-- # Generate Zenity Dialog
-+ # Generate Zenity Dialog
- devdisk=$(
- (
- # Generate list for Zenity
-@@ -170,15 +170,15 @@ function getdevdisk () {
- do
- devitem=$( echo $devdisks | awk -v c=$c '{print $c}')
- drivesize=$( fdisk -l | grep "Disk\ $devitem\:" | cut -d "," -f2 | awk {'print $1'} | xargs )
-- drivesizehuman=$( filesizehuman $drivesize )
-+ drivesizehuman=$( filesizehuman $drivesize )
- devicevendor=$(udevil --show-info $devitem | grep "vendor" | cut -d ":" -f2 | xargs)
- devicemodel=$(udevil --show-info $devitem | grep "model" | cut -d ":" -f2 | xargs)
- # echo output for zenity columns
-- echo "$drivesizehuman" ; echo "$devicevendor $devicemodel " ; echo "$(basename $devitem)"
-+ echo "$drivesizehuman" ; echo "$devicevendor $devicemodel " ; echo "$(basename $devitem)"
+@@ -177,8 +177,8 @@ function getdevdisk () {
+ echo "$drivesizehuman" ; echo "$devicevendor $devicemodel " ; echo "$(basename $devitem)"
done
- ) | zenity --list --title="$apptitle - $action : Select memory card" \
- --column="Volume" --column="Description" --column="Device" --print-column=3 --ok-label=Continue --width=400 --height=200 )
-+ ) | zenity --list --title="$apptitle - $action" \
-+ --text="Selecione o cartão de memória" --column="Volume" --column="Descrição" --column="Dispositivo" --print-column=3 --ok-label=Continue --cancel-label=Cancelar --width=400 --height=200 )
++ ) | zenity --list --title="$apptitle - $action : Selecionar cartão de memória" \
++ --column="Volume" --column="Descrição" --column="Dispositivo" --print-column=3 --ok-label=Continue --width=400 --height=200 )
# Return value if selected
if [ $devdisk ] ; then
-@@ -186,12 +186,12 @@ function getdevdisk () {
- fi
- }
+@@ -188,16 +188,16 @@ function getdevdisk () {
--# Select Backup or Restore if not in args
-+# Select Backup or Restaurar if not in args
+ # Select Backup or Restore if not in args
if [ ! "$action" ] ; then
-- response=$(zenity --question --text "\n<big>Select <b>Backup</b> to create an image file from a memory card or disk.\n\n\nSelect <b>Restore</b> to copy an image file to a memory card or disk.</big>\nSupported formats: img, iso, zip, gzip, xz\n\n\n\nWARNING - Use this program with caution. Data could be lost." --title "$apptitle $version" --ok-label=Restore --cancel-label=Backup )
-+ response=$(zenity --question --text "\n<big>Selecione <b>Backup</b> para criar um arquivo de imagem a partir de um cartão de memória ou disco.\n\n\nSelecione <b>Restaurar</b> para copiar um arquivo de imagem para um cartão de memória ou disco.</big>\nFormatos Suportados: img, iso, zip, gzip, xz\n\n\n\nAVISO - Use este programa com cuidado. Dados podem ser perdidos." --title "$apptitle $version" --ok-label=Restaurar --cancel-label=Backup --width=400 --height=100 )
+- response=$(zenity --question --no-wrap --text "\n<big>Select <b>Backup</b> to create an image file from a memory card or disk.\n\n\nSelect <b>Restore</b> to copy an image file to a memory card or disk.</big>\nSupported formats: img, iso, zip, gzip, xz\n\n\n\nWARNING - Use this program with caution. Data could be lost." --title "$apptitle $version" --ok-label=Restore --cancel-label=Backup )
++ response=$(zenity --question --no-wrap --text "\n<big>Selecione <b>Backup</b> para criar um arquivo de imagem a partir de um cartão de memória ou disco.\n\n\nSelecione <b>Restaurar</b> para copiar um arquivo de imagem para um cartão de memória ou disco.</big>\nFormatos suportados: img, iso, zip, gzip, xz\n\n\n\nATENÇÃO - Use este programa com cuidado. Dados podem ser perdidos." --title "$apptitle $version" --ok-label=Restaurar --cancel-label=Backup )
if [ $? -eq 0 ] ; then
- action="Restore"
@@ -191,19 +103,15 @@ index 67c5ce6..7693ea8 100755
else
action="Backup"
fi
-@@ -199,25 +199,25 @@ fi
+ fi
- ### BACKUP : Select inputfile and outputfile
+-### BACKUP : Select inputfile and outputfile
++### BACKUP : Selecione arquivo de entrada e arquivo de saída
if [ "$action" == "Backup" ] ; then
--
-+
+
# Check if volume was dropped already
- if [ ! "$devdisk" ] ; then
- # Select Disk Volume
- devdisk=$( getdevdisk )
- fi
--
-+
+@@ -208,16 +208,16 @@ if [ "$action" == "Backup" ] ; then
+
# Cancel if user selects Cancel
if [ ! "$devdisk" ] ; then
- notify-send --icon=$iconfile "$apptitle" "No Volumes Selected. $action Cancelled. "
@@ -213,9 +121,8 @@ index 67c5ce6..7693ea8 100755
# Get output filename and folder for backup image
- imagepath=$(zenity --file-selection --filename=/home/$SUDO_USER/Desktop/ --save --confirm-overwrite --title="$apptitle - $action : Select the filename and folder for memory card image file" --file-filter="*.img *.IMG *.gz *.GZ" )
--
-+ imagepath=$(zenity --file-selection --filename=/home/$SUDO_USER/Desktop/ --save --confirm-overwrite --title="$apptitle - $action : Selecione o nome do arquivo e a pasta do arquivo de imagem do cartão de memória" --file-filter="*.img *.IMG *.gz *.GZ" )
-+
++ imagepath=$(zenity --file-selection --filename=/home/$SUDO_USER/Desktop/ --save --confirm-overwrite --title="$apptitle - $action : Selecione o nome do arquivo e a pasta para o arquivo de imagem do cartão de memória" --file-filter="*.img *.IMG *.gz *.GZ" )
+
# Cancel if user selects Cancel
if [ ! $? -eq 0 ] ; then
- echo "$action Cancelled"
@@ -231,8 +138,8 @@ index 67c5ce6..7693ea8 100755
+ compression="Sim"
else
# Ask for compression if not a zip file
-- zenity --question --title="$apptitle - $action" --text="<big><b>Compress the Backup image file?</b></big> \n\nThis can significantly reduce the space used by the backup." --ok-label=Yes --cancel-label=No --width=400
-+ zenity --question --title="$apptitle - $action" --text="<big><b>Comprimir o arquivo de imagem de backup?</b></big> \n\nIsso pode reduzir significativamente o espaço usado pelo backup." --ok-label=Sim --cancel-label=Não --width=400
+- zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>Compress the Backup image file?</b></big> \n\nThis can significantly reduce the space used by the backup." --ok-label=Yes --cancel-label=No --width=400
++ zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>Compactar o arquivo de imagem de backup?</b></big> \n\nIsso pode reduzir significativamente o espaço usado pelo backup." --ok-label=Sim --cancel-label=Não --width=400
if [ $? -eq 0 ] ; then
- compression="Yes"
@@ -248,16 +155,15 @@ index 67c5ce6..7693ea8 100755
fi
# Add zip for compressed backup
- if [ "$compression" == "Yes" ] && [ "$extension" != "gz" ] ; then
-+ if [ "$compression" == "Sim" ] && [ "$extension" != "gz" ] ; then
++ if [ "$compression" == "Sim" ] && [ "$extension" != "gz" ] ; then
outputfile="$outputfile.gz"
fi
# Check if image file exists again
if [ -f "$outputfile" ] && [ "$imagepath" != "$outputfile" ] ; then
-- zenity --question --title="$apptitle - $action" --text="<big><b>The file $(basename $outputfile) already exist.</b></big>\n\nSelect <b>Continue</b> to overwrite the file.\n\nSelect <b>Cancel</b> to Quit" --ok-label=Continue --cancel-label=Cancel --width=500
--
-+ zenity --question --title="$apptitle - $action" --text="<big><b>O arquivo $(basename $outputfile) já existe.</b></big>\n\nSelecione <b>Continue</b> para substituir o arquivo.\n\nSelecione <b>Cancelar</b> para Sair" --ok-label=Continue --cancel-label=Cancelar --width=500
-+
+- zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>The file $(basename $outputfile) already exist.</b></big>\n\nSelect <b>Continue</b> to overwrite the file.\n\nSelect <b>Cancel</b> to Quit" --ok-label=Continue --cancel-label=Cancel --width=500
++ zenity --question --no-wrap --title="$apptitle - $action" --text="<big><b>O arquivo $(basename $outputfile) já existe.</b></big>\n\nSelecione <b>Continue</b> para substituir o arquivo.\n\nSelecione <b>Cancelar</b> para sair" --ok-label=Continue --cancel-label=Cancelar --width=500
+
# Cancel if user selects Cancel
if [ ! $? -eq 0 ] ; then
- echo "$action Cancelled"
@@ -265,11 +171,13 @@ index 67c5ce6..7693ea8 100755
exit 0
fi
-@@ -269,16 +269,16 @@ fi
+@@ -268,17 +268,17 @@ if [ "$action" == "Backup" ] ; then
+ fi
- ### RESTORE : Select image file and memcard location
+-### RESTORE : Select image file and memcard location
-if [ "$action" == "Restore" ] ; then
++### RESTORE : Selecionar arquivo de imagem e localização do cartão de memória
+if [ "$action" == "Restaurar" ] ; then
# Check if restore file was dropped as arg already
@@ -306,12 +214,8 @@ index 67c5ce6..7693ea8 100755
fi
fi
-@@ -317,17 +317,17 @@ if [ "$action" == "Backup" ] ; then
- totalbytes=$drivesize
- # Check available space left for backup
- outputspace=$( df $(dirname "$outputfile") | grep "\/dev\/" | awk {'print $4'} )
-- # Output of df is in 1024 K blocks
-+ # Output of df is in 1024 K blocks
+@@ -320,7 +320,7 @@ if [ "$action" == "Backup" ] ; then
+ # Output of df is in 1024 K blocks
outputspace=$(( $outputspace * 1024 ))
fi
-if [ "$action" == "Restore" ] ; then
@@ -319,26 +223,15 @@ index 67c5ce6..7693ea8 100755
inputfilesize=$( du -b "$inputfile" | awk {'print $1'} )
inputfilesizehuman=$( filesizehuman $inputfilesize )
source="<big><b>$(basename "$inputfile")</b></big>"
- dest="<big><b>$drivesizehuman Volume</b></big>"
- outputfile=$devdisk
- outputspace=$drivesize
-- # Get uncompressed size of image restore files
-+ # Get uncompressed size of image restore files
- case "$extension" in
- img|iso)
- totalbytes=$inputfilesize
-@@ -339,9 +339,9 @@ if [ "$action" == "Restore" ] ; then
+@@ -339,7 +339,7 @@ if [ "$action" == "Restore" ] ; then
totalbytes=$( gzip -l "$inputfile" | tail -1 | awk '{print $2}')
;;
xz)
- totalbytes=$( xz -lv "$inputfile" | grep "Uncompressed" | cut -d "(" -f2 | cut -d "B" -f1 | sed -e 's/[^0-9]*//g')
+ totalbytes=$( xz -lv "$inputfile" | grep "Descomprimido" | cut -d "(" -f2 | cut -d "B" -f1 | sed -e 's/[^0-9]*//g')
;;
-- esac
-+ esac
+ esac
fi
-
- # Check sizes to find out if there is enough space to do backup or restore
@@ -349,20 +349,20 @@ if [ "$totalbytes" -gt "$outputspace" ] ; then
sizedif=$(( $totalbytes - $outputspace ))
sizedifhuman=$( filesizehuman $sizedif )
@@ -348,18 +241,16 @@ index 67c5ce6..7693ea8 100755
+ if [ "$compression" == "Sim" ] && [ "$action" == "Restaurar" ] ; then
+ compressflag=" descomprimido"
fi
-- # Add Warning text
-- warning="<b>WARNING: </b>The$compressflag ${action,,} file is <b>$sizedifhuman</b> too big to fit on the destination storage device. You can click Start to continue anyway, or select Cancel to Quit."
-+ # Add Warning text
-+ warning="<b>ATENÇÃO: </b>O arquivo$compressflag ${action,,} é <b>$sizedifhuman</b> mais grande para caber no dispositivo de armazenamento de destino. Você pode clicar em Iniciar para continuar mesmo assim ou selecionar Cancelar para Sair."
-+
-+fi
+ # Add Warning text
+- warning="<b>WARNING: </b>The$compressflag ${action,,} file is <b>$sizedifhuman</b> too big to fit on the destination storage device.\n\nYou can click Start to continue anyway, or select Cancel to Quit."
++ warning="<b>ATENÇÃO: </b>O$compressflag ${action,,} arquivo é <b>$sizedifhuman</b> grande demais para caber no dispositivo de armazenamento de destino.\n\nVocê pode clicar em Iniciar para continuar assim mesmo ou selecionar Cancelar para sair."
--fi
--
- ### Confirmation Dialog
--zenity --question --text="<big>Please confirm settings and click Start</big>\n\n\nSource \n$source \n\nDestination \n$dest \n\n\n$warning\n\n\n<b>NOTE: </b>All Data on the Destination will be deleted" --title "$apptitle - $action" --ok-label=Start --cancel-label=Cancel --width=580
-+zenity --question --text="<big>Por favor, confirme as configurações e clique em Iniciar</big>\n\n\nFonte \n$source \n\nDestino \n$dest \n\n\n$warning\n\n\n<b>NOTE: </b>Todos os dados no destino serão excluídos" --title "$apptitle - $action" --ok-label=Iniciar --cancel-label=Cancelar --width=580
+ fi
+
+-### Confirmation Dialog
+-zenity --question --no-wrap --text="<big>Please confirm settings and click Start</big>\n\n\nSource \n$source \n\nDestination \n$dest \n\n\n$warning\n\n\n<b>NOTE: </b>All Data on the Destination will be deleted" --title "$apptitle - $action" --ok-label=Start --cancel-label=Cancel --width=580
++### Caixa de diálogo de confirmação
++zenity --question --no-wrap --text="<big>Confirme as configurações e clique em Iniciar</big>\n\n\nFonte \n$source \n\nDestino \n$dest \n\n\n$warning\n\n\n<b>NOTA: </b>Todos os dados no destino serão excluídos" --title "$apptitle - $action" --ok-label=Iniciar --cancel-label=Cancelar --width=580
# Cancel if user selects Cancel
if [ ! $? -eq 0 ] ; then
@@ -368,7 +259,7 @@ index 67c5ce6..7693ea8 100755
exit 0
fi
-@@ -377,26 +377,26 @@ partitions=$( df | grep -c $devdisk )
+@@ -377,16 +377,16 @@ partitions=$( df | grep -c $devdisk )
# Cancel if unable to unmount
if [ ! $partitions -eq 0 ] ; then
@@ -377,9 +268,10 @@ index 67c5ce6..7693ea8 100755
exit 0
fi
- ### Start dd copy
+-### Start dd copy
-notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action Started"
-+notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume de $action Iniciado"
++### Iniciar cópia dd
++notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action Começado"
# Backup
if [ "$action" == "Backup" ] ; then
@@ -388,10 +280,7 @@ index 67c5ce6..7693ea8 100755
# Compressed Backup to GZ file
dd if="$inputfile" bs=1M | gzip > "$outputfile" &
else
- # Normal dd uncompressed Backup
- dd if="$inputfile" of="$outputfile" bs=1M &
-- fi
-+ fi
+@@ -396,7 +396,7 @@ if [ "$action" == "Backup" ] ; then
fi
# Restore
@@ -400,29 +289,20 @@ index 67c5ce6..7693ea8 100755
# IMG files
if [ "$extension" == "img" ] || [ "$extension" == "iso" ] ; then
dd if="$inputfile" of="$outputfile" bs=1M &
-@@ -407,7 +407,7 @@ if [ "$action" == "Restore" ] ; then
- fi
- # ZIP files
- if [ "$extension" == "zip" ] ; then
-- unzip -p "$inputfile" | dd of="$outputfile" bs=1M &
-+ unzip -p "$inputfile" | dd of="$outputfile" bs=1M &
- fi
- # XZ files - OSX 10.10 only I think
- if [ "$extension" == "xz" ] ; then
@@ -421,15 +421,15 @@ fi
pid=$!
# Monitor progress
-progresstext="$action in progress..."
--progressmonitor | zenity --progress --title="$apptitle - $drivesizehuman Volume $action" --width=400 --text="$progresstext" --ok-label=Done --no-cancel --auto-close
+-progressmonitor | zenity --progress --auto-close --title="$apptitle - $drivesizehuman Volume $action" --width=400 --text="$progresstext" --ok-label=Done --no-cancel
+progresstext="$action em progresso..."
-+progressmonitor | zenity --progress --title="$apptitle - $action para Volume de $drivesizehuman" --width=400 --text="$progresstext" --ok-label=Feito --no-cancel --auto-close
++progressmonitor | zenity --progress --auto-close --title="$apptitle - $drivesizehuman Volume $action" --width=400 --text="$progresstext" --ok-label=Feito --no-cancel
# check if job was cancelled
if [ ! $? -eq 0 ] ; then
- notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action Cancelled"
- status="Cancelled"
-+ notify-send --icon=$iconfile "$apptitle" "$action para Volume de $drivesizehuman Cancelado"
++ notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action Cancelado"
+ status="Cancelado"
else
- status="Complete"
@@ -430,15 +310,12 @@ index 67c5ce6..7693ea8 100755
fi
# set permissions
-@@ -439,9 +439,9 @@ fi
-
- # Copy Complete
+@@ -441,7 +441,7 @@ fi
# Display Notifications
--notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action $status"
-+notify-send --icon=$iconfile "$apptitle" "$action para Volume de $drivesizehuman $status"
+ notify-send --icon=$iconfile "$apptitle" "$drivesizehuman Volume $action $status"
--zenity --info --title="$apptitle $version" --text="<big><b>$drivesizehuman Volume $action $status</b></big>" --ok-label=Done
-+zenity --info --title="$apptitle $version" --text="<big><b>$action para Volume de $drivesizehuman $status</b></big>" --ok-label=Feito --width=400 --height=100
+-zenity --info --no-wrap --title="$apptitle $version" --text="<big><b>$drivesizehuman Volume $action $status</b></big>" --ok-label=Done
++zenity --info --no-wrap --title="$apptitle $version" --text="<big><b>$drivesizehuman Volume $action $status</b></big>" --ok-label=Feito
# exit
-exit 0