summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..743b959b3d5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = deadbeef-plugin-headerbar-gtk3-git
+ pkgdesc = Headerbar Plugin for the DeaDBeeF audio player (development version)
+ pkgver = r102
+ pkgrel = 1
+ url = https://github.com/saivert/ddb_misc_headerbar_GTK3
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = git+https://github.com/saivert/ddb_misc_headerbar_GTK3
+ md5sums = SKIP
+
+pkgname = deadbeef-plugin-headerbar-gtk3-git
+ depends = deadbeef
+ depends = gtk3
+ provides = deadbeef-plugin-headerbar-gtk3
+ conflicts = deadbeef-plugin-headerbar-gtk3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18d0ba88b2e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Gennadiy Chernyshyk <genaloner@gmail.com>
+pkgname=deadbeef-plugin-headerbar-gtk3-git
+pkgver=r102
+pkgrel=1
+pkgdesc="Headerbar Plugin for the DeaDBeeF audio player (development version)"
+url="https://github.com/saivert/ddb_misc_headerbar_GTK3"
+arch=("i686" "x86_64")
+license=("GPL2")
+
+_gitname=ddb_misc_headerbar_GTK3
+_gitroot=https://github.com/saivert/${_gitname}
+
+source=("git+$_gitroot")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r""$(git rev-list --count HEAD)"
+}
+
+
+build() {
+ cd $_gitname
+
+ touch AUTHORS
+ touch ChangeLog
+
+ ./autogen.sh
+ ./configure
+ make
+}
+
+package() {
+ depends=("deadbeef" "gtk3")
+ conflicts=("deadbeef-plugin-headerbar-gtk3")
+ provides=("deadbeef-plugin-headerbar-gtk3")
+ install -D -v -c $srcdir/$_gitname/src/.libs/ddb_misc_headerbar_GTK3.so $pkgdir/usr/lib/deadbeef/ddb_misc_headerbar_GTK3.so
+}
+