summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD26
3 files changed, 34 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93ac23d69888..6efa42f12ac5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = debhelper
pkgdesc = A collection of programs that can be used in a debian/rules file to automate common tasks
- pkgver = 13.10.1
+ pkgver = 13.11.4
pkgrel = 1
url = https://salsa.debian.org/debian/debhelper.git/
arch = any
@@ -15,11 +15,16 @@ pkgbase = debhelper
depends = file>=3.23
depends = html2text
depends = man-db>=2.5.1
- depends = perl>=5.6.0
depends = perl-pod-parser
+ depends = perl>=5.6.0
depends = po-debconf
- optdepends = dh-make
- source = git+https://salsa.debian.org/debian//debhelper.git#tag=debian/13.10.1
+ depends = strip-nondeterminism
+ optdepends = dh-make: convert source archives into Debian package source
+ provides = dh-strip-nondeterminism
+ conflicts = dh-strip-nondeterminism
+ source = git+https://salsa.debian.org/debian//debhelper.git#tag=debian/13.11.4
+ source = dh_strip_nondeterminism::https://salsa.debian.org/reproducible-builds/strip-nondeterminism/-/raw/master/bin/dh_strip_nondeterminism?inline=false
+ md5sums = SKIP
md5sums = SKIP
pkgname = debhelper
diff --git a/.gitignore b/.gitignore
index 49a559c865a4..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-debhelper*
-pkg
-src
-*.tar.*
-*.log
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index e62eed5e393d..75b63bc7d630 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,12 @@
# Contributor: Andrei "Garoth" Thorp <garoth "at the nice" gmail "dot" com>
pkgname=debhelper
-pkgver=13.10.1
+pkgver=13.11.4
pkgrel=1
pkgdesc="A collection of programs that can be used in a debian/rules file to automate common tasks"
arch=('any')
url="https://salsa.debian.org/debian/debhelper.git/"
+_url_dh_strip_nondeterminism="https://salsa.debian.org/reproducible-builds/strip-nondeterminism"
license=('GPL2' 'GPL3')
depends=(
'binutils'
@@ -16,9 +17,10 @@ depends=(
'file>=3.23'
'html2text'
'man-db>=2.5.1'
- 'perl>=5.6.0'
'perl-pod-parser'
+ 'perl>=5.6.0'
'po-debconf'
+ 'strip-nondeterminism'
)
makedepends=(
'file>=3.23'
@@ -26,9 +28,21 @@ makedepends=(
'man-db>=2.5.1'
'po4a>=0.24'
)
-optdepends=('dh-make')
-source=("git+https://salsa.debian.org/debian//debhelper.git#tag=debian/$pkgver")
-md5sums=('SKIP')
+optdepends=(
+ 'dh-make: convert source archives into Debian package source'
+)
+
+provides=('dh-strip-nondeterminism')
+conflicts=('dh-strip-nondeterminism')
+
+source=(
+ "git+https://salsa.debian.org/debian//debhelper.git#tag=debian/$pkgver"
+ dh_strip_nondeterminism::"${_url_dh_strip_nondeterminism}/-/raw/master/bin/dh_strip_nondeterminism?inline=false"
+ )
+md5sums=(
+ 'SKIP'
+ 'SKIP'
+)
build() {
cd "$srcdir/$pkgname"
@@ -38,6 +52,8 @@ build() {
package() {
cd "$srcdir/$pkgname"
make DESTDIR="$pkgdir/" install
+
+ install -Dm755 "${srcdir}/dh_strip_nondeterminism" -t "${pkgdir}/usr/bin"
}
# vim:set ts=2 sw=2 et: