summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--makefile_supported.patch11
3 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcddabe96ce1..e56f7ef26236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = debhelper-python2
pkgdesc = debhelper scripts for Python 2: pyversions, python2.pm
- pkgver = 2.7.3
- pkgrel = 2
+ pkgver = 2.7.5
+ pkgrel = 1
url = http://packages.debian.org/sid/python
arch = any
license = custom:MIT
depends = debhelper
depends = python2
- source = http://ftp.debian.org/debian/pool/main/p/python-defaults/python-defaults_2.7.3-4.tar.gz
- md5sums = c64ada8169474b522835fae6885033ee
+ source = http://ftp.debian.org/debian/pool/main/p/python-defaults/python-defaults_2.7.5-5.tar.gz
+ source = makefile_supported.patch
+ md5sums = 066c3b10e9f1ede9187eea6fd1f851d5
+ md5sums = ba61b80b7461b85283b6695e1bf6a768
pkgname = debhelper-python2
diff --git a/PKGBUILD b/PKGBUILD
index fef04c3973e6..c7889e9b40fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Johannes Dewender arch at JonyJD dot net
pkgname=debhelper-python2
_pkgname=python-defaults
-pkgver=2.7.3
-pkgrel=2
-_pkgrel=4
+pkgver=2.7.5
+pkgrel=1
+_pkgrel=5
pkgdesc="debhelper scripts for Python 2: pyversions, python2.pm"
arch=('any')
url="http://packages.debian.org/sid/python"
@@ -19,8 +19,9 @@ replaces=()
backup=()
options=()
install=
-source=(http://ftp.debian.org/debian/pool/main/p/$_pkgname/${_pkgname}_$pkgver-$_pkgrel.tar.gz)
-md5sums=('c64ada8169474b522835fae6885033ee')
+source=(http://ftp.debian.org/debian/pool/main/p/$_pkgname/${_pkgname}_$pkgver-$_pkgrel.tar.gz makefile_supported.patch)
+md5sums=('066c3b10e9f1ede9187eea6fd1f851d5'
+ 'ba61b80b7461b85283b6695e1bf6a768')
build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -28,6 +29,8 @@ build() {
for file in {dh_python2,pyclean,pycompile,debian/pyversions.py}; do
sed -i -e '1s|/usr/bin/python$|/usr/bin/python2|' $file
done
+ sed -i -e 's|>/dev/stderr|>\&2|g' Makefile
+ patch -p1 < ../makefile_supported.patch
}
check() {
diff --git a/makefile_supported.patch b/makefile_supported.patch
new file mode 100644
index 000000000000..7da7134925bb
--- /dev/null
+++ b/makefile_supported.patch
@@ -0,0 +1,11 @@
+--- python-defaults-2.7.5/Makefile 2013-09-27 11:12:20.411871795 +0200
++++ python-defaults-2.7.5/Makefile 2013-09-27 11:22:15.035658573 +0200
+@@ -42,7 +42,7 @@
+ check_versions:
+ @set -e;\
+ DEFAULT=`sed -rn 's,^DEFAULT = \(([0-9]+)\, ([0-9]+)\),\1.\2,p' debpython/version.py`;\
+- SUPPORTED=`sed -rn 's,^SUPPORTED = \[\(([0-9]+)\, ([0-9]+)\)\, \(([0-9]+)\, ([0-9]+)\)\],\1.\2 \3.\4,p' debpython/version.py`;\
++ SUPPORTED=`sed -rn 's,^SUPPORTED = \[\(([0-9]+)\, ([0-9]+)\)\,\],\1.\2,p' debpython/version.py`;\
+ DEB_DEFAULT=`sed -rn 's,^default-version = python([0-9.]*),\1,p' debian/debian_defaults`;\
+ DEB_SUPPORTED=`sed -rn 's|^supported-versions = (.*)|\1|p' debian/debian_defaults | sed 's/python//g;s/,//g'`;\
+ [ "$$DEFAULT" = "$$DEB_DEFAULT" ] || \