summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD1
-rw-r--r--deepin-dock-plugin-arch-update.install27
2 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed6826dce131..a0d7f333f8ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@ arch=('x86_64')
url="https://github.com/CareF/deepin-dock-plugin-arch-update"
depends=('deepin-dock')
makedepends=('git' 'qt5-base' 'dtkcore')
+install=$pkgname.install
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/CareF/deepin-dock-plugin-arch-update/archive/v${pkgver}.tar.gz")
md5sums=('4e41c0886c702dd0284ed0e716f0d791')
diff --git a/deepin-dock-plugin-arch-update.install b/deepin-dock-plugin-arch-update.install
new file mode 100644
index 000000000000..f50e26dcfa0d
--- /dev/null
+++ b/deepin-dock-plugin-arch-update.install
@@ -0,0 +1,27 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ echo
+ note "Restart dde-dock to take effect"
+ echo
+}
+
+post_update() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}