summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--fix.patch61
3 files changed, 4 insertions, 78 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f49dfd61b07a..387587f13520 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deepin-polkit-agent-git
pkgdesc = Deepin Polkit Agent
- pkgver = 5.5.3.r15.g65afa2e
+ pkgver = 5.5.21.r7.g2f9964c
pkgrel = 1
url = https://github.com/linuxdeepin/dde-polkit-agent
arch = x86_64
@@ -20,8 +20,6 @@ pkgbase = deepin-polkit-agent-git
provides = deepin-polkit-agent
conflicts = deepin-polkit-agent
source = deepin-polkit-agent-git::git+https://github.com/linuxdeepin/dde-polkit-agent
- source = fix.patch
sha512sums = SKIP
- sha512sums = b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572
pkgname = deepin-polkit-agent-git
diff --git a/PKGBUILD b/PKGBUILD
index bca67ace3104..853faea7d3c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-polkit-agent-git
-pkgver=5.5.3.r15.g65afa2e
+pkgver=5.5.21.r7.g2f9964c
pkgrel=1
pkgdesc='Deepin Polkit Agent'
arch=('x86_64' 'aarch64')
@@ -12,25 +12,14 @@ makedepends=('git' 'polkit-qt5' 'dtkcommon-git' 'dtkwidget-git' 'cmake' 'ninja')
conflicts=('deepin-polkit-agent')
provides=('deepin-polkit-agent')
groups=('deepin-git')
-source=("$pkgname::git+https://github.com/linuxdeepin/dde-polkit-agent"
- "fix.patch")
-sha512sums=('SKIP'
- 'b02235cece90a01942cd0898cfb85c7eb8fa6f980c4e1d83cfa115baba1599ca878788b5d89338444afe8267c30b11f9279ebda98d3bbc3dd4f3fe03cd1f0572')
+source=("$pkgname::git+https://github.com/linuxdeepin/dde-polkit-agent")
+sha512sums=('SKIP')
pkgver() {
cd $pkgname
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd $pkgname
- if [[ ! -z ${sha} ]];then
- git checkout -b $sha
- fi
-
- patch -p1 -i ../fix.patch
-}
-
build() {
cd $pkgname
cmake . -G Ninja -DCMAKE_INSTALL_PREFIX=/usr
diff --git a/fix.patch b/fix.patch
deleted file mode 100644
index 3cbb63980ae2..000000000000
--- a/fix.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- test/policykitlistener.cpp 2022-02-23 21:39:00.000000000 +0800
-+++ dde-polkit-agent/policykitlistener.cpp 2022-02-23 21:36:43.000000000 +0800
-@@ -203,7 +203,7 @@ void PolicyKitListener::completed(bool g
- m_showInfoSuccess = false;
-
- if (m_exAuth) {
-- m_session.data()->authCtrl(AUTH_CLOSE, -1);
-+ //m_session.data()->authCtrl(AUTH_CLOSE, -1);
- }
- finishObtainPrivilege();
- }
-@@ -243,7 +243,7 @@ void PolicyKitListener::exAuthInfo(bool
- m_isMfa = isMfa;
-
- if (!isMfa) {
-- m_session.data()->authCtrl(AUTH_START, -1);
-+ //m_session.data()->authCtrl(AUTH_START, -1);
- }
- }
-
-@@ -271,7 +271,7 @@ void PolicyKitListener::createSessionFor
- }
- // We will create new session only when some user is selected
- if (m_selectedUser.isValid()) {
-- m_session = new Session(m_selectedUser, m_cookie, m_result, &m_details);
-+ m_session = new Session(m_selectedUser, m_cookie, m_result);
-
- connect(m_session.data(), &Session::request, this,
- &PolicyKitListener::request);
-@@ -281,10 +281,10 @@ void PolicyKitListener::createSessionFor
- &PolicyKitListener::showError);
- connect(m_session.data(), &Session::showInfo, this,
- &PolicyKitListener::showInfo);
-- connect(m_session.data(), &Session::exAuthStatus, this,
-- &PolicyKitListener::exAuthStatus);
-- connect(m_session.data(), &Session::exAuthInfo, this,
-- &PolicyKitListener::exAuthInfo);
-+// connect(m_session.data(), &Session::exAuthStatus, this,
-+// &PolicyKitListener::exAuthStatus);
-+// connect(m_session.data(), &Session::exAuthInfo, this,
-+// &PolicyKitListener::exAuthInfo);
-
- m_session->initiate();
- }
-@@ -294,14 +294,14 @@ void PolicyKitListener::fillResult()
- {
- if (!m_session.isNull()) {
- if (m_wasCancelled) {
-- m_session.data()->result()->setCancel("aciton cancel");
-+ m_session.data()->result()->setError("aciton cancel");
- } else if (!m_gainedAuthorization) {
- m_session.data()->result()->setError("password error");
- }
- m_session.data()->result()->setCompleted();
- } else {
- if (m_wasCancelled) {
-- m_result->setCancel("action cancel");
-+ m_result->setError("action cancel");
- } else if (!m_gainedAuthorization) {
- m_result->setError("password error");
- }