summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore164
-rw-r--r--PKGBUILD16
3 files changed, 142 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12176b84cf1f..a070d37902c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = deepin-pw-check-git
pkgdesc = deepin-pw-check is a tool to verify the validity of the password
- pkgver = 5.1.2.r5.gef201e1
- pkgrel = 6
+ pkgver = 5.1.17.r5.g2b1147e
+ pkgrel = 2
url = https://github.com/linuxdeepin/deepin-pw-check
arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
makedepends = go
makedepends = golang-github-linuxdeepin-go-dbus-factory-git
- makedepends = deepin-gettext-tools
+ makedepends = deepin-gettext-tools-git
depends = cracklib
depends = iniparser
depends = pam
provides = deepin-pw-check
conflicts = deepin-pw-check
- source = deepin-pw-check-git::git://github.com/linuxdeepin/deepin-pw-check
+ source = deepin-pw-check-git::git+https://github.com/linuxdeepin/deepin-pw-check
sha512sums = SKIP
pkgname = deepin-pw-check-git
diff --git a/.gitignore b/.gitignore
index c6007448df06..b6e47617de11 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,37 +1,129 @@
-.*
-/*/*/
-!.travis.yml
-!.git*
-!.github/**
-pkg/
-src/
-*.xz
-*.sig
-*.asc
-*.bz2
-*.gz
-*.zip
+# Byte-compiled / optimized / DLL files
+__pycache__/
+*.py[cod]
+*$py.class
+
+# C extensions
+*.so
+
+# Distribution / packaging
+.Python
+build/
+develop-eggs/
+dist/
+downloads/
+eggs/
+.eggs/
+lib/
+lib64/
+parts/
+sdist/
+var/
+wheels/
+pip-wheel-metadata/
+share/python-wheels/
+*.egg-info/
+.installed.cfg
+*.egg
+MANIFEST
+
+# PyInstaller
+# Usually these files are written by a python script from a template
+# before PyInstaller builds the exe, so as to inject date/other infos into it.
+*.manifest
+*.spec
+
+# Installer logs
+pip-log.txt
+pip-delete-this-directory.txt
+
+# Unit test / coverage reports
+htmlcov/
+.tox/
+.nox/
+.coverage
+.coverage.*
+.cache
+nosetests.xml
+coverage.xml
+*.cover
+*.py,cover
+.hypothesis/
+.pytest_cache/
+
+# Translations
+*.mo
+*.pot
+
+# Django stuff:
*.log
-*.gem
-*.tgz
-*.tar
-*.tar.*
-*.deb
-*.rpm
-*.jar
-*.html
-trunk/
-*~
-*.sw?
-*.kate-swp
-*.orig
-*.run
-old_ver.txt
-new_ver.txt
-linux.install.pkg
-.vscode/
-*.7z
-*.xpi
-*.bin
-*.exe
-*.ttf
+local_settings.py
+db.sqlite3
+db.sqlite3-journal
+
+# Flask stuff:
+instance/
+.webassets-cache
+
+# Scrapy stuff:
+.scrapy
+
+# Sphinx documentation
+docs/_build/
+
+# PyBuilder
+target/
+
+# Jupyter Notebook
+.ipynb_checkpoints
+
+# IPython
+profile_default/
+ipython_config.py
+
+# pyenv
+.python-version
+
+# pipenv
+# According to pypa/pipenv#598, it is recommended to include Pipfile.lock in version control.
+# However, in case of collaboration, if having platform-specific dependencies or dependencies
+# having no cross-platform support, pipenv may install dependencies that don't work, or not
+# install all needed dependencies.
+#Pipfile.lock
+
+# PEP 582; used by e.g. github.com/David-OConnor/pyflow
+__pypackages__/
+
+# Celery stuff
+celerybeat-schedule
+celerybeat.pid
+
+# SageMath parsed files
+*.sage.py
+
+# Environments
+.env
+.venv
+env/
+venv/
+ENV/
+env.bak/
+venv.bak/
+
+# Spyder project settings
+.spyderproject
+.spyproject
+
+# Rope project settings
+.ropeproject
+
+# mkdocs documentation
+/site
+
+# mypy
+.mypy_cache/
+.dmypy.json
+dmypy.json
+
+# Pyre type checker
+.pyre/
diff --git a/PKGBUILD b/PKGBUILD
index aa60d1ccb5ff..2ca63a585c0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-pw-check-git
-pkgver=5.1.2.r5.gef201e1
-pkgrel=6
+pkgver=5.1.17.r5.g2b1147e
+pkgrel=2
pkgdesc='deepin-pw-check is a tool to verify the validity of the password'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/deepin-pw-check"
license=('GPL3')
depends=('cracklib' 'iniparser' 'pam')
-makedepends=('git' 'go' 'golang-github-linuxdeepin-go-dbus-factory-git' 'deepin-gettext-tools')
+makedepends=('git' 'go' 'golang-github-linuxdeepin-go-dbus-factory-git' 'deepin-gettext-tools-git')
groups=('deepin-git')
provides=('deepin-pw-check')
conflicts=('deepin-pw-check')
-source=("$pkgname::git://github.com/linuxdeepin/deepin-pw-check")
+source=("$pkgname::git+https://github.com/linuxdeepin/deepin-pw-check")
sha512sums=('SKIP')
pkgver() {
@@ -21,12 +21,12 @@ pkgver() {
}
prepare() {
- cd $pkgname
+ cd $pkgname
+
export GOPATH="$srcdir/build:/usr/share/gocode"
export GO111MODULE=off
go get -v github.com/godbus/dbus
go get -v github.com/fsnotify/fsnotify
- go get -v gopkg.in/yaml.v3
sed -i 's/<iniparser\//</g' lib/deepin_pw_check.c
sed -i 's/<iniparser\//</g' tool/pwd_conf_update.c
sed -i 's/local\///g' Makefile
@@ -39,6 +39,8 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOPATH="$srcdir/build:/usr/share/gocode"
+ export GO111MODULE=off
make
}