summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD4
2 files changed, 2 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 017f3a17e12a..e71cb44f2b1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,6 @@ pkgbase = deepspeech
makedepends = python-wheel
makedepends = git
makedepends = sox
- makedepends = swig
source = DeepSpeech-0.7.1::git+https://github.com/mozilla/DeepSpeech.git#tag=v0.7.1
source = git+https://github.com/mozilla/tensorflow.git#branch=r1.15
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index dfc2bf81dfc1..9d93e6e7372a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="A TensorFlow implementation of Baidu's DeepSpeech architecture"
arch=('x86_64')
url="https://github.com/mozilla/DeepSpeech"
license=('MPL2')
-makedepends=('bazel=0.24.1' 'python-numpy' 'python-pip' 'python-wheel' 'git' 'sox' 'swig')
+makedepends=('bazel=0.24.1' 'python-numpy' 'python-pip' 'python-wheel' 'git' 'sox')
source=("${_pkgname}-${pkgver}::git+https://github.com/mozilla/DeepSpeech.git#tag=v${pkgver//_/-}"
"git+https://github.com/mozilla/tensorflow.git#branch=r1.15")
sha256sums=('SKIP' 'SKIP')
@@ -35,7 +35,7 @@ build() {
bazel build --workspace_status_command="bash native_client/bazel_workspace_status_cmd.sh" --config=monolithic -c opt --copt=-O3 --copt="-D_GLIBCXX_USE_CXX11_ABI=0" --copt=-fvisibility=hidden //native_client:libdeepspeech.so
cd "${srcdir}/${_pkgname}-${pkgver//_/-}/native_client"
- make deepspeech SOX_LDFLAGS="-lsox -lm"
+ make deepspeech SOX_LDFLAGS="-lsox -Wl,-no-undefined"
make bindings -C python
}