summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rwxr-xr-xPKGBUILD15
-rw-r--r--no-git-checkout.patch52
3 files changed, 69 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e1f53bd948d..3432dd14e40a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deltachat-desktop
pkgdesc = A privacy oriented chat application built on e-mail
- pkgver = 1.3.2
+ pkgver = 1.4.2
pkgrel = 1
url = https://github.com/deltachat/deltachat-desktop
arch = any
@@ -9,15 +9,17 @@ pkgbase = deltachat-desktop
makedepends = nodejs
makedepends = git
makedepends = rustup
- makedepends = python2
+ makedepends = python
depends = electron6
conflicts = deltachat-desktop-git
- source = deltachat-desktop-1.3.2.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.3.2.tar.gz
+ source = deltachat-desktop-1.4.2.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.4.2.tar.gz
source = deltachat-desktop.desktop
source = deltachat-desktop.sh
- sha256sums = 05279fb1bf96ae6a877a47440dff1bc11d3c6369db76063bc0915ba6609927e7
+ source = no-git-checkout.patch
+ sha256sums = 346ed1e0b135bb41b916a422d02a6cd329242cb2ea6085ae1a16f9aa483f9161
sha256sums = 39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1
sha256sums = 5e20ea657599390e317523ae17b17aba0d26c59474a7f80282af5f2668002f59
+ sha256sums = 35461ad7e2db569764866f798481aeef96656c363463fd6f5d8cef6bc29f1d79
pkgname = deltachat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 5851fcfbebed..a21e299f02d2 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,39 @@
# Maintainer: Jikstra <jikstra@disroot.org>
# Maintainer: tercean <cg@zknt.org>
pkgname=deltachat-desktop
-pkgver=1.3.2
+pkgver=1.4.2
pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
depends=('electron6')
-makedepends=('npm' 'nodejs' 'git' 'rustup' 'python2')
+makedepends=('npm' 'nodejs' 'git' 'rustup' 'python')
conflicts=("deltachat-desktop-git")
source=(
"deltachat-desktop-${pkgver}.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v${pkgver}.tar.gz"
"deltachat-desktop.desktop"
"deltachat-desktop.sh"
+ "no-git-checkout.patch"
)
sha256sums=(
- "05279fb1bf96ae6a877a47440dff1bc11d3c6369db76063bc0915ba6609927e7"
+ "346ed1e0b135bb41b916a422d02a6cd329242cb2ea6085ae1a16f9aa483f9161"
"39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1"
"5e20ea657599390e317523ae17b17aba0d26c59474a7f80282af5f2668002f59"
+ "35461ad7e2db569764866f798481aeef96656c363463fd6f5d8cef6bc29f1d79"
)
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/no-git-checkout.patch"
+}
+
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- npm install --verbose
+ npm install
npm run build
# Delete development dependencies, we don't need them anymore
diff --git a/no-git-checkout.patch b/no-git-checkout.patch
new file mode 100644
index 000000000000..a8b0781d2957
--- /dev/null
+++ b/no-git-checkout.patch
@@ -0,0 +1,52 @@
+diff -ruN deltachat-desktop-1.4.2/package.json deltachat-desktop-1.4.2-no-git-patch/package.json
+--- deltachat-desktop-1.4.2/package.json 2020-06-26 12:47:23.000000000 +0000
++++ deltachat-desktop-1.4.2-no-git-patch/package.json 2020-06-26 15:28:02.957637266 +0000
+@@ -15,9 +15,8 @@
+ "start": "electron . --debug --log-debug --log-to-console --disable-http-cache --translation-watch",
+ "clean": "rm -rf ./tsc-dist ./html-dist ./dist",
+ "build": "npm run build:shared && npm run build:backend && npm run build:frontend",
+- "build:shared": "npm run build:shared:translations && npm run build:shared:version",
++ "build:shared": "npm run build:shared:translations",
+ "build:shared:translations": "node ./bin/build-shared-convert-translations.js ./_locales",
+- "build:shared:version": "node ./bin/build-shared-version-info.js",
+ "build:backend": "tsc --build src/main",
+ "build:frontend": "npm run build:frontend:ts && npm run build:frontend:themes && npm run build:frontend:static && npm run build:frontend:scss",
+ "build:frontend:ts": "node ./bin/build-frontend-ts.js",
+diff -ruN deltachat-desktop-1.4.2/src/main/deltachat/controller.ts deltachat-desktop-1.4.2-no-git-patch/src/main/deltachat/controller.ts
+--- deltachat-desktop-1.4.2/src/main/deltachat/controller.ts 2020-06-26 12:47:23.000000000 +0000
++++ deltachat-desktop-1.4.2-no-git-patch/src/main/deltachat/controller.ts 2020-06-26 15:28:28.924663902 +0000
+@@ -21,7 +21,8 @@
+ import Extras from './extras'
+ import { EventId2EventName as eventStrings } from 'deltachat-node/dist/constants'
+
+-import { VERSION, BUILD_TIMESTAMP } from '../../shared/build-info'
++const VERSION = '1.4.2'
++const BUILD_TIMESTAMP = Date.now()
+ import { Timespans, DAYS_UNTIL_UPDATE_SUGGESTION } from '../../shared/constants'
+ import { LocaleData } from '../../shared/localize'
+
+diff -ruN deltachat-desktop-1.4.2/src/renderer/components/CrashScreen.tsx deltachat-desktop-1.4.2-no-git-patch/src/renderer/components/CrashScreen.tsx
+--- deltachat-desktop-1.4.2/src/renderer/components/CrashScreen.tsx 2020-06-26 12:47:23.000000000 +0000
++++ deltachat-desktop-1.4.2-no-git-patch/src/renderer/components/CrashScreen.tsx 2020-06-26 15:29:10.341888558 +0000
+@@ -1,6 +1,7 @@
+ import React from 'react'
+ import { runtime } from '../runtime'
+-import { VERSION, GIT_REF } from '../../shared/build-info'
++const VERSION = "1.4.2"
++const GIT_REF = "None"
+ export class CrashScreen extends React.Component {
+ state = {
+ hasError: false,
+diff -ruN deltachat-desktop-1.4.2/src/renderer/components/dialogs/About.tsx deltachat-desktop-1.4.2-no-git-patch/src/renderer/components/dialogs/About.tsx
+--- deltachat-desktop-1.4.2/src/renderer/components/dialogs/About.tsx 2020-06-26 12:47:23.000000000 +0000
++++ deltachat-desktop-1.4.2-no-git-patch/src/renderer/components/dialogs/About.tsx 2020-06-26 15:28:55.601692171 +0000
+@@ -4,7 +4,8 @@
+ import { getLogger } from '../../../shared/logger'
+ import DeltaDialog, { DeltaDialogBody, DeltaDialogFooter } from './DeltaDialog'
+ import { gitHubUrl, gitHubLicenseUrl } from '../../../shared/constants'
+-import { VERSION, GIT_REF } from '../../../shared/build-info'
++const VERSION = "1.4.2"
++const GIT_REF = "None"
+ import ClickableLink from '../helpers/ClickableLink'
+ import { DeltaBackend } from '../../delta-remote'
+