summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD28
-rw-r--r--deltachat-desktop.sh2
-rw-r--r--remove_git_submodule.patch10
-rw-r--r--static_build_info.patch41
5 files changed, 68 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dd311dd3a83..4de8c5dbbccd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,27 @@
pkgbase = deltachat-desktop
pkgdesc = A privacy oriented chat application built on e-mail
- pkgver = 1.14.1
- pkgrel = 5
+ pkgver = 1.15.5
+ pkgrel = 1
url = https://github.com/deltachat/deltachat-desktop
arch = any
license = GPL
makedepends = npm
makedepends = nodejs
- makedepends = git
makedepends = rustup
makedepends = python
makedepends = unzip
- depends = electron6
+ depends = electron
conflicts = deltachat-desktop-git
- source = deltachat-desktop-1.14.1.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.14.1.tar.gz
+ source = deltachat-desktop-1.15.5.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.15.5.tar.gz
source = deltachat-desktop.desktop
source = deltachat-desktop.sh
- source = basicwebrtc-9385e26bb39e7286fc7c612500c5dd92be445e0b.zip::https://github.com/cracker0dks/basicwebrtc/archive/9385e26bb39e7286fc7c612500c5dd92be445e0b.zip
source = remove_git_submodule.patch
- sha256sums = ea2ef8d50cf02e68a1acf6f3b3f2b18092f715092ea67e42e68dc7b60b6720b6
+ source = static_build_info.patch
+ sha256sums = 3cc693991b9b302402c7657256ba5401c28adb3c831b1c674f15eb362eacd43b
sha256sums = 39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1
- sha256sums = 5e20ea657599390e317523ae17b17aba0d26c59474a7f80282af5f2668002f59
- sha256sums = cddac0c94d78d8265a57064504890f9056a117eaca20054e2893aac83bd53473
- sha256sums = 95371069306c94785802ee1c4fe2cd6a2acb89e9ae085011c3075f73c967db14
+ sha256sums = c7d2c3675faa09bb568b7f7c10779971783b1a4f11a225db8b2846fc1a6b4e14
+ sha256sums = 1cf8e2277482c138439fb355f6b075ce357b893a00493d0393311384d627881a
+ sha256sums = 751767446cc6951c834a2c59a7bf3df9497635cb060845114948ef3edd587f15
pkgname = deltachat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 50c64ce464b3..1cabaf895759 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,39 @@
# Maintainer: Jikstra <jikstra@disroot.org>
# Maintainer: tercean <cg@zknt.org>
pkgname=deltachat-desktop
-pkgver=1.14.1
-pkgrel=5
+pkgver=1.15.5
+pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
-depends=('electron6')
-makedepends=('npm' 'nodejs' 'git' 'rustup' 'python' 'unzip')
+depends=('electron')
+makedepends=('npm' 'nodejs' 'rustup' 'python' 'unzip')
conflicts=("deltachat-desktop-git")
-_basicwebrtc_commit=9385e26bb39e7286fc7c612500c5dd92be445e0b
source=(
"deltachat-desktop-${pkgver}.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v${pkgver}.tar.gz"
"deltachat-desktop.desktop"
"deltachat-desktop.sh"
- "basicwebrtc-$_basicwebrtc_commit.zip::https://github.com/cracker0dks/basicwebrtc/archive/$_basicwebrtc_commit.zip"
"remove_git_submodule.patch"
+ "static_build_info.patch"
)
-sha256sums=('ea2ef8d50cf02e68a1acf6f3b3f2b18092f715092ea67e42e68dc7b60b6720b6'
+sha256sums=('3cc693991b9b302402c7657256ba5401c28adb3c831b1c674f15eb362eacd43b'
'39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1'
- '5e20ea657599390e317523ae17b17aba0d26c59474a7f80282af5f2668002f59'
- 'cddac0c94d78d8265a57064504890f9056a117eaca20054e2893aac83bd53473'
- '95371069306c94785802ee1c4fe2cd6a2acb89e9ae085011c3075f73c967db14')
+ 'c7d2c3675faa09bb568b7f7c10779971783b1a4f11a225db8b2846fc1a6b4e14'
+ '1cf8e2277482c138439fb355f6b075ce357b893a00493d0393311384d627881a'
+ '751767446cc6951c834a2c59a7bf3df9497635cb060845114948ef3edd587f15')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
- unzip $srcdir/basicwebrtc-$_basicwebrtc_commit.zip
- rm -rf basicwebrtc-$_basicwebrtc_commit.zip
- mv basicwebrtc-$_basicwebrtc_commit basicwebrtc
-
patch --forward --strip=1 --input="${srcdir}/remove_git_submodule.patch"
+ patch --forward --strip=1 --input="${srcdir}/static_build_info.patch"
}
build() {
cd "$srcdir/${pkgname}-${pkgver}"
- npm install
+ npm install --verbose
npm run build
# Delete development dependencies, we don't need them anymore
@@ -49,7 +45,7 @@ package() {
cd "$srcdir/${pkgname}-${pkgver}"
install -d "${pkgdir}/opt/DeltaChat/electron_app"
- cp -r node_modules images tsc-dist build html-dist _locales "${pkgdir}/opt/DeltaChat/electron_app"
+ cp -r node_modules images tsc-dist build html-dist _locales themes "${pkgdir}/opt/DeltaChat/electron_app"
rm -rf "${pkgdir}/opt/DeltaChat/electron_app/node_modules/deltachat-node/prebuilds/win32-x64"
rm -rf "${pkgdir}/opt/DeltaChat/electron_app/node_modules/deltachat-node/prebuilds/darwin-x64"
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
index 39b54c155c4a..0bc7f62496a3 100644
--- a/deltachat-desktop.sh
+++ b/deltachat-desktop.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-cd /opt/DeltaChat/electron_app && electron6 . "$@"
+cd /opt/DeltaChat/electron_app && electron . "$@"
diff --git a/remove_git_submodule.patch b/remove_git_submodule.patch
index 5b69fc3bc3cf..e4f83a47f3ba 100644
--- a/remove_git_submodule.patch
+++ b/remove_git_submodule.patch
@@ -1,12 +1,12 @@
-diff --unified --recursive --text orig/package.json patched/package.json
---- orig/package.json 2020-12-15 22:44:24.000000000 +0100
-+++ patched/package.json 2020-12-25 16:07:45.746047461 +0100
+diff --unified --recursive --text orig/package.json deltachat-desktop-1.15.3/package.json
+--- orig/package.json 2021-03-18 13:55:27.000000000 +0100
++++ deltachat-desktop-1.15.3/package.json 2021-03-18 19:48:25.361065415 +0100
@@ -4,8 +4,6 @@
"description": "Desktop Application for delta.chat",
"main": "index.js",
"scripts": {
- "install": "npm run install:submodules",
- "install:submodules": "git submodule update --recursive --init",
- "test": "npm run lint && npm run check-formatting && npm run test-log-conventions && npm run test-unit",
+ "test": "npm run check-types && npm run lint && npm run check-formatting && npm run test-log-conventions && npm run test-unit && npm run test-misc",
+ "test-misc": "node ./bin/test_package_lock_version",
"test-log-conventions": "node ./bin/log-conventions",
- "test-unit": "node test/unit",
diff --git a/static_build_info.patch b/static_build_info.patch
new file mode 100644
index 000000000000..56d6be31d3e5
--- /dev/null
+++ b/static_build_info.patch
@@ -0,0 +1,41 @@
+diff --unified --recursive --text a/bin/build-shared-version-info.js b/bin/build-shared-version-info.js
+--- a/bin/build-shared-version-info.js 2021-02-13 11:36:03.000000000 +0100
++++ b/bin/build-shared-version-info.js 2021-02-15 15:57:08.270159483 +0100
+@@ -2,36 +2,12 @@
+ const fs = require('fs-extra')
+ const { join } = require('path')
+
+-function gatherProcessStdout(cmd, args) {
+- const { status, stdout, stderr } = spawnSync(cmd, args)
+- if (status !== 0) throw new Error(stderr)
+- return stdout.toString().replace(/\n/g, '')
+-}
+-
+ async function gatherBuildInfo() {
+- let git_describe, git_branch;
+- try {
+- git_describe = gatherProcessStdout('git', ['describe'])
+- try {
+- git_symbolic_ref = process.env.GITHUB_HEAD_REF || process.env.GITHUB_REF || gatherProcessStdout('git', ['symbolic-ref', 'HEAD'])
+- git_branch = git_symbolic_ref.split('/').pop()
+- console.log(git_symbolic_ref, git_branch)
+- } catch (err) {
+- console.log(err)
+- git_branch = "master"
+- }
+- } catch (err) {
+- console.log(err)
+- process.exit(1)
+- }
+-
+- const git_ref = git_describe + (git_branch === 'master' ? '' : '-' + git_branch)
+-
+ const package = await fs.readJSON(join(__dirname, '../package.json'))
+ return {
+ VERSION: package.version,
+ BUILD_TIMESTAMP: Date.now(),
+- GIT_REF: git_ref
++ GIT_REF: "NOGIT"
+ }
+ }
+