summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--deltachat-desktop.sh2
-rw-r--r--static_build_info.patch2
4 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a413924bb83..fd832ec3b6bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deltachat-desktop
pkgdesc = A privacy oriented chat application built on e-mail
- pkgver = 1.34.1
+ pkgver = 1.34.2
pkgrel = 1
url = https://github.com/deltachat/deltachat-desktop
arch = any
@@ -10,15 +10,15 @@ pkgbase = deltachat-desktop
makedepends = rustup
makedepends = python
makedepends = unzip
- depends = electron18
+ depends = electron19
conflicts = deltachat-desktop-git
- source = deltachat-desktop-1.34.1.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.34.1.tar.gz
+ source = deltachat-desktop-1.34.2.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.34.2.tar.gz
source = deltachat-desktop.desktop
source = deltachat-desktop.sh
source = static_build_info.patch
- sha256sums = d37dd5785dd634dd6020019da395e75ac017fcfeaf31001ac1a0ec82debb0477
+ sha256sums = 058a58b30e5c52ac31603a5fd9607c7492b3c9c71b5450697f2e2d1521b02577
sha256sums = 39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1
- sha256sums = cd5c0044fe28b31788b9d0efaac94ba6af8baadad6d122ce19c37874905af27b
- sha256sums = 864469bb70c4970333f78d55e8a61ff541ef70c5d701c21fa53041a05d736bf4
+ sha256sums = 9b581cb127a74a7d6bcf67a1f0637dbcd00dca531db890e7a8be99919aaaa04d
+ sha256sums = f28d7783f45e4ddc496029ce961ad2c30a777adbdccd66817599f9d422d24b7d
pkgname = deltachat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 359cff07d315..a9d0e6d7d78a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: tercean <cg@zknt.org>
pkgname=deltachat-desktop
-pkgver=1.34.1
+pkgver=1.34.2
pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
-depends=('electron18')
+depends=('electron19')
makedepends=('npm' 'nodejs>=16' 'rustup' 'python' 'unzip')
conflicts=("deltachat-desktop-git")
source=(
@@ -15,10 +15,10 @@ source=(
"deltachat-desktop.sh"
"static_build_info.patch"
)
-sha256sums=('d37dd5785dd634dd6020019da395e75ac017fcfeaf31001ac1a0ec82debb0477'
+sha256sums=('058a58b30e5c52ac31603a5fd9607c7492b3c9c71b5450697f2e2d1521b02577'
'39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1'
- 'cd5c0044fe28b31788b9d0efaac94ba6af8baadad6d122ce19c37874905af27b'
- '864469bb70c4970333f78d55e8a61ff541ef70c5d701c21fa53041a05d736bf4')
+ '9b581cb127a74a7d6bcf67a1f0637dbcd00dca531db890e7a8be99919aaaa04d'
+ 'f28d7783f45e4ddc496029ce961ad2c30a777adbdccd66817599f9d422d24b7d')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
index 2fc938a1db2e..ec9ae1917090 100644
--- a/deltachat-desktop.sh
+++ b/deltachat-desktop.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-cd /opt/DeltaChat/electron_app && electron18 . "$@"
+cd /opt/DeltaChat/electron_app && electron19 . "$@"
diff --git a/static_build_info.patch b/static_build_info.patch
index 0a5e4fc136c2..f444d8b47513 100644
--- a/static_build_info.patch
+++ b/static_build_info.patch
@@ -39,7 +39,7 @@ diff --unified --recursive --text orig/bin/build-shared-version-info.js patched/
- const git_ref =
- git_describe + (git_branch === 'master' ? '' : '-' + git_branch)
- return git_ref
-+ return "tags/v1.34.1"
++ return "tags/v1.34.2"
}
async function gatherBuildInfo() {