summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE7
-rwxr-xr-xPKGBUILD10
3 files changed, 9 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 603e67ef40c3..eb30736203e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Apr 1 21:07:32 UTC 2018
pkgbase = dephpend
pkgdesc = Detect flaws in your architecture, before they drag you down into the depths of dependency hell ...
- pkgver = 0.5.0
+ pkgver = 0.6.2
pkgrel = 1
url = https://dephpend.com/
arch = any
license = MIT
depends = php
- source = https://github.com/mihaeu/dephpend/releases/download/0.5.0/dephpend.phar
- source = https://raw.githubusercontent.com/mihaeu/dephpend/0.5.0/LICENSE
- sha256sums = cf3dbcec000712246a5395b3562e16f05cffb4c519897d4a9af1bee9439f6703
+ source = https://github.com/mihaeu/dephpend/releases/download/0.6.2/dephpend-0.6.2.phar
+ source = https://raw.githubusercontent.com/mihaeu/dephpend/0.6.2/LICENSE
+ sha256sums = 4ef6e10c52721caf3bad45fe1139a8b786536a73e6c9a71d0133f53a5f509723
sha256sums = 2025717a285cf18f45e9a41ea41971b56f5a1692ce5ee03bb6c862514aadc97d
pkgname = dephpend
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index 27a724e56da2..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,7 +0,0 @@
-Copyright (c) 2016 Michael Haeuslmann <haeuslmann@gmail.com>
-
-Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index a0ff50041e94..17727bd5323b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Sebastian Krebs <sebastian[at]krebs[dot]one>
pkgname=dephpend
-pkgver=0.5.0
+pkgver=0.6.2
pkgrel=1
pkgdesc="Detect flaws in your architecture, before they drag you down into the depths of dependency hell ..."
arch=('any')
url="https://dephpend.com/"
license=('MIT')
depends=('php')
-source=("https://github.com/mihaeu/dephpend/releases/download/${pkgver}/dephpend.phar"
+source=("https://github.com/mihaeu/dephpend/releases/download/${pkgver}/dephpend-${pkgver}.phar"
"https://raw.githubusercontent.com/mihaeu/${pkgname}/${pkgver}/LICENSE")
-sha256sums=('cf3dbcec000712246a5395b3562e16f05cffb4c519897d4a9af1bee9439f6703'
- '2025717a285cf18f45e9a41ea41971b56f5a1692ce5ee03bb6c862514aadc97d')
+sha256sums=('4ef6e10c52721caf3bad45fe1139a8b786536a73e6c9a71d0133f53a5f509723'
+ '2025717a285cf18f45e9a41ea41971b56f5a1692ce5ee03bb6c862514aadc97d')
package() {
install -D -m 644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -D -m 755 "${srcdir}/dephpend.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
+ install -D -m 755 "${srcdir}/dephpend-${pkgver}.phar" "${pkgdir}/usr/share/webapps/bin/${pkgname}.phar"
install -d "${pkgdir}/usr/bin"
ln -s "/usr/share/webapps/bin/${pkgname}.phar" "${pkgdir}/usr/bin/${pkgname}"
}