summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--depot_tools.install15
-rwxr-xr-xdepot_tools.sh1
4 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ecb66e29f30..36adec07e3d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Sep 17 10:50:27 UTC 2016
pkgbase = depot-tools-git
pkgdesc = Build tools for working with Chromium development, include gclient
- pkgver = r3619.7e16cf3
+ pkgver = r4249.57a86929
pkgrel = 1
url = http://dev.chromium.org/developers/how-tos/install-depot-tools
install = depot_tools.install
@@ -19,11 +17,9 @@ pkgbase = depot-tools-git
conflicts = depot_tools-svn
options = !strip
source = depot-tools-git::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git
- source = depot_tools.sh
source = repo_fix.sh
source = fixshebangs.py
sha512sums = SKIP
- sha512sums = dbd6e66dce2b142830c7f22df79f6956f7f2aa762e80c1121f1a12599a8d98230d67404319c86549f52da7e736c56231d857a0f6a2dd5139b94bf70f5d7526fa
sha512sums = bde33ffcad42a4d554d5490b6562981ef4b9f3abebadbed909749ee05ba391da4b5acb31b901e785b6f019b4ed3f9c740ab92623dd6a87e67b4b599a0010374b
sha512sums = 33d772f68deddefce985d2820d3ef60fa730a1f3bc404cef3c8b1b517369501b9c3a07bc7b1b3df4d0589b45cbe4850f935699676c3e10c437bceffb37eb8214
diff --git a/PKGBUILD b/PKGBUILD
index 17ec763d98ea..49b4454a2a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@
# Contributor: Yen Chi Hsuan <yan12125@gmail.com>
pkgname=depot-tools-git
-pkgver=r3619.7e16cf3
+pkgver=r4249.57a86929
pkgrel=1
pkgdesc='Build tools for working with Chromium development, include gclient'
arch=('any')
url='http://dev.chromium.org/developers/how-tos/install-depot-tools'
source=("${pkgname}::git+https://chromium.googlesource.com/chromium/tools/depot_tools.git"
- 'depot_tools.sh' 'repo_fix.sh' 'fixshebangs.py')
+ 'repo_fix.sh' 'fixshebangs.py')
license=('Custom')
depends=('git' 'ninja' 'python2')
optdepends=(
@@ -26,7 +26,6 @@ conflicts=('gclient-svn' 'depot_tools-svn')
options=('!strip')
install="depot_tools.install"
sha512sums=('SKIP'
- 'dbd6e66dce2b142830c7f22df79f6956f7f2aa762e80c1121f1a12599a8d98230d67404319c86549f52da7e736c56231d857a0f6a2dd5139b94bf70f5d7526fa'
'bde33ffcad42a4d554d5490b6562981ef4b9f3abebadbed909749ee05ba391da4b5acb31b901e785b6f019b4ed3f9c740ab92623dd6a87e67b4b599a0010374b'
'33d772f68deddefce985d2820d3ef60fa730a1f3bc404cef3c8b1b517369501b9c3a07bc7b1b3df4d0589b45cbe4850f935699676c3e10c437bceffb37eb8214')
@@ -80,9 +79,6 @@ package()
cp -r "${srcdir}/${pkgname}" "${pkgdir}/opt/depot_tools"
- # Export PATH
- install -Dm755 "${srcdir}/depot_tools.sh" "${pkgdir}/etc/profile.d/depot_tools.sh"
-
# Install repo_fix.sh script
install -Dm 755 "${srcdir}/repo_fix.sh" "${pkgdir}/opt/depot_tools"
diff --git a/depot_tools.install b/depot_tools.install
index 7f8d306c794e..44b37f73ae2f 100644
--- a/depot_tools.install
+++ b/depot_tools.install
@@ -1,19 +1,22 @@
#!/bin/bash
-post_install()
+_prompt_modify_path()
{
- source /etc/profile
+ cat << EOF
+>>>> Add export PATH="\${PATH}:/opt/depot_tools" to .bashrc/.zshrc or setenv PATH "\${PATH}:/opt/depot_tools" to ~/.tcshrc if you don't find any depot_tools related commands."
+EOF
+}
+post_install()
+{
echo ">>>> Please note that this tools and some related projects (for example ChromeOS) use python2."
echo ">>>> They assume that python2 is the default python interpreter. ArchLinux default is python3, so be prepared to fix python references in your works."
echo ">>>> This package contains a repo_fix.sh script. Use it to fix python2 references in python's script created after 'repo init' command"
echo ">>>> For getting started with depot_tools, visit this page: http://dev.chromium.org/developers/how-tos/depottools"
- echo ">>>> Run 'source /etc/profile' if you don't find any depot_tools related commands."
+ _prompt_modify_path
}
post_upgrade()
{
- source /etc/profile
-
- echo ">>>> Run 'source /etc/profile' if you don't find any depot_tools related commands."
+ _prompt_modify_path
}
diff --git a/depot_tools.sh b/depot_tools.sh
deleted file mode 100755
index 5668bc468477..000000000000
--- a/depot_tools.sh
+++ /dev/null
@@ -1 +0,0 @@
-export PATH="${PATH}:/opt/depot_tools"