summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--desktime.install19
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d307b280de6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = desktime
+ pkgdesc = Desktime client for Linux (beta)
+ pkgver = 1.38
+ pkgrel = 1
+ url = http://desktime.com
+ install = desktime.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libxss
+ source = http://desktime.com/updates/linux/beta/desktime-linux_1.38_x64.deb
+ md5sums = 72600c449bddb225cda5deb2867505a0
+
+pkgname = desktime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8655017a7df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+pkgname=desktime
+pkgver=1.38
+pkgrel=1
+pkgdesc="Desktime client for Linux (beta)"
+arch=('i686' 'x86_64')
+url="http://desktime.com"
+license=(custom)
+depends=(desktop-file-utils hicolor-icon-theme libappindicator-gtk2 libxss)
+install=$pkgname.install
+
+if [[ $CARCH == 'i686' ]]; then
+ source=("http://desktime.com/updates/linux/beta/desktime-linux_$pkgver_i386.deb")
+ md5sums=('467340ff81e6c1d12351715c7cafc1ae')
+else
+ source=("http://desktime.com/updates/linux/beta/desktime-linux_1.38_x64.deb")
+ md5sums=('72600c449bddb225cda5deb2867505a0')
+fi
+
+prepare()
+{
+ echo
+}
+
+package()
+{
+ cd "$srcdir"
+ bsdtar -xf data.tar.xz -C "$srcdir/"
+ #install -d "$pkgdir/"usr/bin
+ #install -d "$pkgdir/"usr/share/applications
+ #install -d "$pkgdir/"usr/share/doc/desktime-linux
+ #install -d "$pkgdir/"usr/share/icons
+
+ install -Dm755 "$srcdir/"usr/bin/desktime-linux "$pkgdir/"usr/bin/desktime-linux
+ install -Dm644 "$srcdir/"usr/share/applications/desktime.desktop "$pkgdir/"usr/share/applications/desktime.desktop
+ install -Dm644 "$srcdir/"usr/share/doc/desktime-linux/changelog.gz "$pkgdir/"usr/share/doc/desktime-linux/changelog.gz
+ install -Dm644 "$srcdir/"usr/share/doc/desktime-linux/copyright "$pkgdir/"usr/share/doc/desktime-linux/copyright
+ install -Dm644 "$srcdir/"usr/share/icons/desktime.png "$pkgdir/"usr/share/icons/desktime.png
+
+}
+
+# vim:et:sw=4:sts=4
diff --git a/desktime.install b/desktime.install
new file mode 100644
index 000000000000..3eaf04c1d548
--- /dev/null
+++ b/desktime.install
@@ -0,0 +1,19 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ if which update-icon-caches >/dev/null 2>&1 ; then
+ update-icon-caches /usr/share/icons/desktime.png
+ fi
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ if which update-icon-caches >/dev/null 2>&1 ; then
+ update-icon-caches /usr/share/icons/desktime.png
+ fi
+ update-desktop-database -q
+}