summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..51a9b5f9d188
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = desq-apps-docs
+ pkgdesc = A simple Document Viewer for DesQ
+ pkgver = 0.0.7
+ pkgrel = 1
+ url = https://gitlab.com/DesQ/DesQApps/DesQDocs
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ depends = qt5-base
+ depends = poppler-qt5
+ depends = qdocumentview
+ depends = libdesqui
+ depends = dfl-applications
+ depends = dfl-settings
+ depends = dfl-utils
+ source = https://gitlab.com/DesQ/DesQApps/DesQDocs/-/archive/v0.0.7/DesQDocs-v0.0.7.tar.gz
+ md5sums = cd332b360457dcb81e33272b684560a8
+
+pkgname = desq-apps-docs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f28d54a8bd5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+_pkgname=DesQDocs
+pkgname=desq-apps-docs
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="A simple Document Viewer for DesQ"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/DesQ/DesQApps/${_pkgname}"
+license=('GPL3')
+depends=('qt5-base' 'poppler-qt5' 'qdocumentview' 'libdesqui' 'dfl-applications' 'dfl-settings' 'dfl-utils')
+makedepends=('meson' 'ninja')
+source=("https://gitlab.com/DesQ/DesQApps/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
+md5sums=('cd332b360457dcb81e33272b684560a8')
+
+build() {
+ cd "${_pkgname}-v${pkgver}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${_pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}