summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD74
2 files changed, 75 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84d58e18fbd4..cfb5b23f19ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,30 @@
pkgbase = devhelp-git
pkgdesc = API documentation browser for GNOME
- pkgver = 3.38.0+4+g5eb0b92c
+ pkgver = 43.0+9+g4d15da51
pkgrel = 1
url = https://wiki.gnome.org/Apps/Devhelp
arch = x86_64
+ arch = i686
+ arch = pentium4
+ arch = aarch64
+ arch = armv7h
license = GPL
- makedepends = gtk-doc
- makedepends = git
makedepends = appstream-glib
+ makedepends = git
+ makedepends = gi-docgen
makedepends = gobject-introspection
makedepends = meson
makedepends = yelp-tools
- depends = webkit2gtk
- depends = amtk
- provides = devhelp
+ depends = webkit2gtk-4.1
+ provides = devhelp=43.0+9+g4d15da51
conflicts = devhelp
source = git+https://gitlab.gnome.org/GNOME/devhelp.git
sha512sums = SKIP
pkgname = devhelp-git
+ groups = gnome-extra
+ groups = gnome-extra-git
+pkgname = devhelp-docs-git
+ pkgdesc = API documentation browser for GNOME (documentation)
+ depends =
diff --git a/PKGBUILD b/PKGBUILD
index 264d693d8057..8b20726bb0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,56 @@
-pkgname=devhelp-git
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
_pkgname=devhelp
-pkgver=3.38.0+4+g5eb0b92c
+pkgbase="${_pkgname}-git"
+pkgname=(
+ "${pkgbase}"
+ "${_pkgname}-docs-git"
+)
+pkgver=43.0+9+g4d15da51
pkgrel=1
pkgdesc="API documentation browser for GNOME"
-arch=(x86_64)
-license=(GPL)
url="https://wiki.gnome.org/Apps/Devhelp"
-depends=('webkit2gtk' 'amtk')
-makedepends=('gtk-doc' 'git' 'appstream-glib' 'gobject-introspection' 'meson' 'yelp-tools')
-provides=('devhelp')
-conflicts=('devhelp')
-source=("git+https://gitlab.gnome.org/GNOME/devhelp.git")
+arch=(
+ x86_64
+ i686
+ pentium4
+ aarch64
+ armv7h
+)
+license=(GPL)
+depends=(
+ webkit2gtk-4.1
+)
+makedepends=(
+ appstream-glib
+ git
+ gi-docgen
+ gobject-introspection
+ meson
+ yelp-tools
+)
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd "${_pkgname}"
+}
+
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ local meson_options=(
+ -D gtk_doc=true
+ -D plugin_emacs=true
+ -D plugin_gedit=true
+ -D plugin_vim=true
+ )
+ arch-meson "${_pkgname}" build "${meson_options[@]}"
meson compile -C build
}
@@ -27,6 +58,23 @@ check() {
meson test -C build --print-errorlogs
}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+package_devhelp-git() {
+ groups=(
+ gnome-extra
+ gnome-extra-git
+ )
+ meson install -C build --destdir "${pkgdir}"
+
+ # Split -docs
+ mkdir -p docs/usr/share
+ mv -t docs/usr/share "$pkgdir"/usr/share/doc
}
+
+package_devhelp-docs-git() {
+ pkgdesc+=" (documentation)"
+ depends=()
+
+ mv -t "$pkgdir" docs/*
+}
+
+# vim:set sw=2 sts=-1 et: