summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5e74cfbb516
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = deviced-git
+ pkgdesc = Daemon that can be run on a development device that will allow IDEs and other tooling to interact with the device
+ pkgver = r283.fdb99b5
+ pkgrel = 1
+ url = https://gitlab.gnome.org/chergert/deviced
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = libnm
+ depends = jsonrpc-glib
+ depends = flatpak
+ provides = deviced
+ provides = libdeviced
+ conflicts = deviced
+ source = deviced-git::git+https://gitlab.gnome.org/chergert/deviced.git
+ sha256sums = SKIP
+
+pkgname = deviced-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9947b6a4d9d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: tytan652 <tytan652@tytanium.xyz>
+
+pkgname=deviced-git
+pkgver=r283.fdb99b5
+pkgrel=1
+pkgdesc="Daemon that can be run on a development device that will allow IDEs and other tooling to interact with the device"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.gnome.org/chergert/deviced"
+license=('GPL3')
+depends=('libnm' 'jsonrpc-glib' 'flatpak')
+makedepends=('git' 'meson' 'ninja')
+provides=('deviced' 'libdeviced')
+conflicts=('deviced')
+source=("$pkgname::git+https://gitlab.gnome.org/chergert/deviced.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}