summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD75
-rw-r--r--devilutionx.install23
3 files changed, 54 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f434a028098..1c8074577c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,10 +15,9 @@ pkgbase = devilutionx-git
makedepends = lib32-sdl2_ttf
makedepends = lib32-libsodium
makedepends = libsodium
+ optdepends = ttf-charis-sil: CharisSILB.ttf
source = devilutionx::git+https://github.com/diasurgical/devilutionX.git
- source = LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
sha256sums = SKIP
- sha256sums = 88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd
pkgname = devilutionx-git
pkgdesc = Diablo devolved for linux (native build)
@@ -30,6 +29,7 @@ pkgname = devilutionx-git
pkgname = devilutionx-multilib-git
pkgdesc = Diablo devolved for linux (multilib build)
depends = lib32-gcc-libs
+ depends = lib32-dbus
depends = lib32-sdl2_mixer
depends = sdl2_ttf
depends = lib32-sdl2_ttf
diff --git a/PKGBUILD b/PKGBUILD
index 7569ef2f87e3..19a373d55189 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,53 +10,54 @@ arch=('x86_64')
url="https://github.com/diasurgical/devilutionX"
license=('custom:unlicense')
makedepends=('git' 'cmake' 'lib32-gcc-libs' 'lib32-sdl2_mixer'
-'sdl2_ttf' 'sdl2_ttf' 'lib32-sdl2_ttf' 'lib32-libsodium' 'libsodium')
-#provides=("${pkgname}"="${pkgver}")
+ 'sdl2_ttf' 'sdl2_ttf' 'lib32-sdl2_ttf' 'lib32-libsodium'
+ 'libsodium')
+optdepends=('ttf-charis-sil: CharisSILB.ttf')
install="${_pkgname}".install
source=(
- "${_pkgname}::git+https://github.com/diasurgical/devilutionX.git"
- LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
+ "${_pkgname}::git+https://github.com/diasurgical/devilutionX.git"
)
-sha256sums=('SKIP'
- '88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
+sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "${_pkgname}"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "${_pkgname}"
- rm -rf build32 build64
- mkdir -p build64 && cd build64
- cmake ..
- make
- cd "${srcdir}/${_pkgname}"
- mkdir -p build32 && cd build32
- export CC="gcc -m32"
- export CXX="g++ -m32"
- cmake ..
-## -DCMAKE_TOOLCHAIN_FILE=../CMake/32bit.cmake
- make
+ cd "${_pkgname}"
+ rm -rf build32 build64
+ mkdir -p build64 && cd build64
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+ make
+ cd "${srcdir}/${_pkgname}"
+ mkdir -p build32 && cd build32
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ cmake .. \
+ -DCMAKE_TOOLCHAIN_FILE="../CMake/32bit.cmake" \
+ -DCMAKE_BUILD_TYPE=Release
+ make
}
package_devilutionx-git() {
- pkgdesc="Diablo devolved for linux (native build)"
- provides=("${_pkgname}"="${pkgver}")
- depends=('sdl2_mixer' 'sdl2_ttf' 'libsodium')
- makedepends=('git' 'cmake')
- cd "${_pkgname}"
- install -vDm755 build64/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}_native"
- install -vDm644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ pkgdesc="Diablo devolved for linux (native build)"
+ provides=("${_pkgname}"="${pkgver}")
+ depends=('sdl2_mixer' 'sdl2_ttf' 'libsodium')
+
+ cd "${_pkgname}"
+ install -vDm755 build64/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}_native"
+ install -vDm644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"
}
package_devilutionx-multilib-git() {
- pkgdesc="Diablo devolved for linux (multilib build)"
- provides=("${_pkgname}"="${pkgver}")
- depends=('lib32-gcc-libs' 'lib32-sdl2_mixer' 'sdl2_ttf' 'lib32-sdl2_ttf' 'lib32-libsodium' 'libsodium')
- makedepends=('git' 'cmake')
+ pkgdesc="Diablo devolved for linux (multilib build)"
+ provides=("${_pkgname}"="${pkgver}")
+ depends=('lib32-gcc-libs' 'lib32-dbus' 'lib32-sdl2_mixer'
+ 'sdl2_ttf' 'lib32-sdl2_ttf' 'lib32-libsodium'
+ 'libsodium')
- cd "${_pkgname}"
- install -vDm755 build32/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}_multilib"
- install -vDm644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"
+ cd "${_pkgname}"
+ install -vDm755 build32/"${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}_multilib"
+ install -vDm644 LICENSE -t "${pkgdir}"/usr/share/licenses/"${pkgname}"
}
diff --git a/devilutionx.install b/devilutionx.install
index c12b1650ebfe..2aee073ff0be 100644
--- a/devilutionx.install
+++ b/devilutionx.install
@@ -1,17 +1,22 @@
post_install(){
cat << EOF
->>> Copy required files(e.g. diablodat.mpq) to your Diablo directory
->>> (default is ~/.local/share/diasurgical/devilution) or move the
->>> devilution executable in the same directory as "diablodat.mpq".
->>> NOTE: There are two versions of build(native and multilib).
->>> 64bit native Linux build are currently not in a playable state.
->>> Please keep in mind that this is still being worked on and is
->>> missing parts of UI and SoundEffects are not properly playing
->>> now. It is advised to build a 32-bit build on a multilib system
+
+Copy required files(e.g. diablodat.mpq) to your Diablo directory
+(default is ~/.local/share/diasurgical/devilution) or move the
+devilution executable in the same directory as "diablodat.mpq".
+
+NOTE: There are two versions of build(native and multilib).
+
+Please keep in mind that this is still being worked on and is missing
+parts of UI and SoundEffects are not properly playing now.
+
+see https://github.com/diasurgical/devilutionX/milestone/1 for a full
+list of known issues.
+
EOF
}
post_upgrade() {
- post_install
+post_install
}