summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO47
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD126
-rw-r--r--devscripts-git.install13
-rw-r--r--fixes.patch47
5 files changed, 134 insertions, 103 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe2890f9e9b2..f5d42f0ee1fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,46 @@
pkgbase = devscripts-git
pkgdesc = Scripts to make the life of a Debian Package maintainer easier (git-latest)
- pkgver = 2.16.12.r0.g2343096
+ pkgver = 2.23.4.r0.g5d69fc20
pkgrel = 1
url = https://anonscm.debian.org/git/collab-maint/devscripts.git
- install = devscripts-git.install
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL2
- makedepends = git
- makedepends = po4a
- makedepends = perl-timedate
- makedepends = perl-libwww
+ makedepends = bash-completion
makedepends = docbook-xsl
- makedepends = perl-file-desktopentry
+ makedepends = git
+ makedepends = help2man
makedepends = perl-file-basedir
- makedepends = perl-parse-debcontrol
+ makedepends = perl-file-desktopentry
+ makedepends = perl-libwww
+ makedepends = perl-list-compare
+ makedepends = perl-pod-parser
+ makedepends = po4a
makedepends = python-setuptools
+ makedepends = perl-git-wrapper
+ makedepends = perl-parse-debcontrol
depends = dpkg
- depends = wget
- depends = sed
depends = perl
- depends = debianutils
- depends = debhelper
+ depends = perl-file-homedir
depends = perl-timedate
- optdepends = sensible-utils: for sensible alternative selection
+ depends = sed
+ depends = wget
+ depends = debhelper
+ depends = debianutils
+ optdepends = debian-keyring: Required for commands interacting with the system / user keyring
+ optdepends = perl-file-dirlist: Required for uscan
+ optdepends = perl-file-touch: Required for uscan
+ optdepends = perl-ipc-run: Required for uscan
+ optdepends = perl-lwp-protocol-https: Required for uscan
+ optdepends = perl-moo: Required for uscan
provides = devscripts
+ provides = checkbashisms
conflicts = devscripts
+ conflicts = checkbashisms
options = !makeflags
- source = git+https://anonscm.debian.org/git/collab-maint/devscripts.git
+ source = devscripts::git+https://anonscm.debian.org/git/collab-maint/devscripts.git
source = fixes.patch
- md5sums = SKIP
- md5sums = 110857b0eb4a9dbf57a8b562d992ab33
+ sha256sums = SKIP
+ sha256sums = f8e7ce50c0d008c5d38c94b93c9fc560e5dd2cc8f06eeb2909b0b1784911b768
pkgname = devscripts-git
-
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
*
-!.gitignore
-!.SRCINFO
!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 5ed0a2de6413..5883acb84a78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,99 @@
-# Maintainer: Michael DeGuzis
-# <mdeguzis@gmail.com> Git package
-# to stay up to date always If
-# there is not update to the AUR
-# package, remember to pass --devel
-# to your AUR helper (common flag).
-
-pkgname=devscripts-git
-_gitname=devscripts
-pkgver=2.16.12.r0.g2343096
-pkgrel=1 pkgdesc="Scripts to make the life of a Debian Package maintainer easier (git-latest)"
-arch=('any')
-url="https://anonscm.debian.org/git/collab-maint/devscripts.git"
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
+
+_pkgname="devscripts"
+pkgname="$_pkgname-git"
+pkgver=2.23.4.r0.g5d69fc20
+pkgrel=1
+pkgdesc="Scripts to make the life of a Debian Package maintainer easier (git-latest)"
+arch=('i686' 'x86_64')
+url="https://anonscm.debian.org/git/collab-maint/devscripts.git"
license=('GPL2')
-depends=('dpkg' 'wget' 'sed' 'perl' 'debianutils'
- 'debhelper' 'perl-timedate')
-optdepends=('sensible-utils: for sensible alternative selection')
-makedepends=('git' 'po4a' 'perl-timedate' 'perl-libwww' 'docbook-xsl'
- 'perl-file-desktopentry' 'perl-file-basedir'
- 'perl-parse-debcontrol' 'python-setuptools')
-conflicts=('devscripts')
-provides=('devscripts')
-options=('!makeflags')
-source=('git+https://anonscm.debian.org/git/collab-maint/devscripts.git'
- 'fixes.patch')
-install='devscripts-git.install'
-md5sums=('SKIP'
- '110857b0eb4a9dbf57a8b562d992ab33')
+depends=(
+ 'dpkg'
+ 'perl'
+ 'perl-file-homedir'
+ 'perl-timedate'
+ 'sed'
+ 'wget'
+
+ # AUR
+ 'debhelper'
+ 'debianutils'
+ # 'po-debconf' # for debhelper
+ #'sensible-utils'
+)
+makedepends=(
+ 'bash-completion'
+ 'docbook-xsl'
+ 'git'
+ 'help2man'
+ 'perl-file-basedir'
+ 'perl-file-desktopentry'
+ 'perl-libwww'
+ 'perl-list-compare'
+ 'perl-pod-parser'
+ 'po4a'
+ 'python-setuptools'
+
+ # AUR
+ 'perl-git-wrapper'
+ 'perl-parse-debcontrol'
+)
+optdepends=(
+ 'debian-keyring: Required for commands interacting with the system / user keyring'
+ 'perl-file-dirlist: Required for uscan'
+ 'perl-file-touch: Required for uscan'
+ 'perl-ipc-run: Required for uscan'
+ 'perl-lwp-protocol-https: Required for uscan'
+ 'perl-moo: Required for uscan'
+)
+provides=(
+ "$_pkgname"
+ 'checkbashisms'
+)
+conflicts=(${provides[@]})
+options=('!makeflags')
+source=(
+ "$_pkgname"::"git+https://anonscm.debian.org/git/collab-maint/devscripts.git"
+ 'fixes.patch'
+)
+
+sha256sums=(
+ 'SKIP'
+ 'f8e7ce50c0d008c5d38c94b93c9fc560e5dd2cc8f06eeb2909b0b1784911b768'
+)
pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/debian\///;s/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+}
- cd "$_gitname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//'
+prepare(){
+ cd "$srcdir/$_pkgname"
+ patch -p1 -i "$srcdir/fixes.patch"
+ # Ensure the local folder is recognized as a package and used appropriately.
+ touch "$srcdir/devscripts/scripts/devscripts/__init__.py"
}
build() {
-
- cd $srcdir/$_gitname
- patch -p0 -i ../fixes.patch
+ cd "$srcdir/$_pkgname"
make
-
}
package() {
+ cd "$srcdir/$_pkgname"
+ make DESTDIR="$pkgdir" install
- mkdir -p $pkgdir/etc/bash_completion.d
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/lib/devscripts
- mkdir -p $pkgdir/usr/share/devscripts
-
- cd $srcdir/$_gitname
- make DESTDIR=$pkgdir install
+ # Install the script manpages appropriately
+ for script_manpage in scripts/*.1
+ do
+ cp -v $script_manpage "$pkgdir/usr/share/man/man1"
+ done
- # remove conflicting file provided by bash-completion in the community repo
- msg "Removing conflicting file already provided by package 'bash-completion'"
- rm -v $pkgdir/usr/share/bash-completion/completions/bts
+ # Create dch symlink to debchange
+ ln -s /usr/bin/debchange "$pkgdir/usr/bin/dch"
+ # bts completion is present already in the official package
+ rm "$pkgdir/usr/share/bash-completion/completions/bts"
}
diff --git a/devscripts-git.install b/devscripts-git.install
deleted file mode 100644
index cca372ce09f2..000000000000
--- a/devscripts-git.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- ln -s /usr/bin/debchange /usr/bin/dch
-}
-
-
-post_remove() {
- rm /usr/bin/dch
-}
-
-op=$1
-shift
-
-$op $*
diff --git a/fixes.patch b/fixes.patch
index a34f63a13cea..b31508fb9012 100644
--- a/fixes.patch
+++ b/fixes.patch
@@ -1,36 +1,29 @@
---- po4a/Makefile 2013-09-17 11:58:14.177059023 +0100
-+++ po4a/Makefile 2013-09-17 11:57:31.943725986 +0100
-@@ -25,7 +25,7 @@
- pod2man --utf8 --center=" " --release="Debian-Hilfswerkzeuge" $< > $@
- de/%.de.1: de/%.de.dbk translate
- xsltproc --nonet -o $@ \
-- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
- # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
- # to rename the file after it's generated
- mv de/$*.1 $@
-@@ -35,7 +35,7 @@
- pod2man --utf8 --center=" " --release="Utilitaires Debian" $< > $@
- fr/%.fr.1: fr/%.fr.dbk translate
- xsltproc --nonet -o $@ \
+diff -urN devscripts-2.21.2/po4a/Makefile devscripts-2.21.2_patched/po4a/Makefile
+--- devscripts-2.21.2/po4a/Makefile 2021-03-16 14:16:39.000000000 +0100
++++ devscripts-2.21.2_patched/po4a/Makefile 2021-06-10 12:31:21.021880200 +0200
+@@ -34,7 +34,7 @@
+ pod2man --utf8 --center=" " --release="$(DESC_$(dir $@))" $< > $@
+ %.1:: %.dbk translate
+ xsltproc --nonet \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
- # xsltproc writes out to foo.1 even if you tell it to do otherwise, so we have
- # to rename the file after it's generated
- mv fr/$*.1 $@
---- scripts/Makefile 2011-02-09 08:39:18.000000000 +0100
-+++ scripts/Makefile 2011-02-13 17:50:50.393333338 +0100
-@@ -61,7 +61,7 @@
++ /usr/share/xml/docbook/xsl-stylesheets-$(shell pacman -Q docbook-xsl | sed -E 's|.* ([0-9.]+)-.*|\1|')/manpages/docbook.xsl $<
+ # /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/other.xsl
+ # (which is imported by the above stylesheet) insists in writing the output
+ # to where it wants to. we can only move the file ourselves.
+diff -urN devscripts-2.21.2/scripts/Makefile devscripts-2.21.2_patched/scripts/Makefile
+--- devscripts-2.21.2/scripts/Makefile 2021-03-16 14:16:39.000000000 +0100
++++ devscripts-2.21.2_patched/scripts/Makefile 2021-06-10 12:35:12.481880200 +0200
+@@ -87,7 +87,7 @@
pod2man --utf8 --center=" " --release="Debian Utilities" $< > $@
%.1: %.dbk
xsltproc --nonet -o $@ \
- /usr/share/sgml/docbook/stylesheet/xsl/nwalsh/manpages/docbook.xsl $<
-+ /usr/share/xml/docbook/xsl-stylesheets-1.79.1/manpages/docbook.xsl $<
++ /usr/share/xml/docbook/xsl-stylesheets-$(shell pacman -Q docbook-xsl | sed -E 's|.* ([0-9.]+)-.*|\1|')/manpages/docbook.xsl $<
- # There is a slight chance this gets called twice, once here from here and once
- # from ../po4a/Makefile. Treat files with care.
-@@ -89,7 +89,7 @@
- $(foreach python,$(shell py3versions -r ../debian/control),$(python) setup.py test$(\n))
+ # Syntax checker
+ test_sh: $(SH_CHECKS)
+@@ -142,7 +142,7 @@
+ test: test_pl test_sh test_py
install: all
- python3 setup.py install --root="$(DESTDIR)" --no-compile --install-layout=deb