summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--0001-game_data_location.patch12
-rw-r--r--PKGBUILD50
-rw-r--r--dhewm3.desktop2
-rw-r--r--dhewm3.pngbin0 -> 136469 bytes
5 files changed, 41 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c6775a18ca1..a8eff320fc63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Jun 20 09:22:19 UTC 2016
pkgbase = dhewm3
pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
- pkgver = 1.4.1
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/dhewm/dhewm3
arch = i686
@@ -15,12 +13,14 @@ pkgbase = dhewm3
depends = libvorbis
depends = openal
depends = sdl2
- source = https://github.com/dhewm/dhewm3/archive/1.4.1.tar.gz
+ source = https://github.com/dhewm/dhewm3/archive/1.5.0.tar.gz
source = dhewm3.desktop
+ source = dhewm3.png
source = 0001-game_data_location.patch
- sha256sums = 587586142d863ff98051619f0d49c056c5302e919c655a50af69a8293bc3ae08
- sha256sums = 7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287
- sha256sums = dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9
+ md5sums = cc770a4e454704405a83d8ea170706e8
+ md5sums = 300636e2e3ac0566dc6ceb63f121850e
+ md5sums = 8b834c4c1cd5ccb25b1afe6cb47941a8
+ md5sums = 27ac81efff2c25cd672979ea931c2cce
pkgname = dhewm3
diff --git a/0001-game_data_location.patch b/0001-game_data_location.patch
index 60966c259624..fd8e18361285 100644
--- a/0001-game_data_location.patch
+++ b/0001-game_data_location.patch
@@ -1,13 +1,11 @@
-diff --git a/neo/framework/Licensee.h b/neo/framework/Licensee.h
-index 9cc20fb..fb1c882 100644
---- a/neo/framework/Licensee.h
-+++ b/neo/framework/Licensee.h
-@@ -90,7 +90,7 @@ If you have questions concerning this license or the applicable additional terms
- #define WIN32_CONSOLE_CLASS "dhewm 3 WinConsole"
+--- a/neo/framework/Licensee.h 2018-12-15 05:49:59.000000000 +0100
++++ b/neo/framework/Licensee.h 2019-02-27 14:11:12.516544799 +0100
+@@ -98,7 +98,7 @@
// Linux info
+ #ifndef LINUX_DEFAULT_PATH // allow overriding it from the build system with -DLINUX_DEFAULT_PATH="/bla/foo/whatever"
-#define LINUX_DEFAULT_PATH "/usr/local/games/doom3"
+#define LINUX_DEFAULT_PATH "/usr/share/games/doom3"
+ #endif
// CD Key file info
- // goes into BASE_GAMEDIR whatever the fs_game is set to
diff --git a/PKGBUILD b/PKGBUILD
index 56d4b22f0ca9..5e16bd8baa37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,8 @@
-# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+# Maintainer: robertfoster
+# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
+
pkgname=dhewm3
-pkgver=1.4.1
+pkgver=1.5.0
pkgrel=1
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
arch=('i686' 'x86_64')
@@ -9,34 +11,38 @@ license=('GPL3')
depends=('curl' 'doom3-data' 'libjpeg' 'libvorbis' 'openal' 'sdl2')
makedepends=('cmake')
source=("$url/archive/$pkgver.tar.gz"
- 'dhewm3.desktop'
- '0001-game_data_location.patch')
-sha256sums=('587586142d863ff98051619f0d49c056c5302e919c655a50af69a8293bc3ae08'
- '7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287'
- 'dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9')
+ "$pkgname.desktop"
+ "$pkgname.png"
+'0001-game_data_location.patch')
prepare() {
- cd "$pkgname-$pkgver"
-
- for patch in ../*.patch; do
- if [ ! -f "$patch" ]; then
- break;
- else
- patch -p1 -i "$patch"
- fi
- done
+ cd "$pkgname-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
}
build() {
- cd "$pkgname-$pkgver/neo"
+ cd "$pkgname-$pkgver/neo"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DD3XP=1 -DDEDICATED=1 .
- make
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DD3XP=1 -DDEDICATED=1 .
+ make
}
package() {
- cd "$pkgname-$pkgver/neo"
+ cd "$pkgname-$pkgver/neo"
- make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
- install -Dm644 ../../dhewm3.desktop "$pkgdir/usr/share/applications/dhewm3.desktop"
+ make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ install -Dm644 ../../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 ../../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
}
+
+md5sums=('cc770a4e454704405a83d8ea170706e8'
+ '300636e2e3ac0566dc6ceb63f121850e'
+ '8b834c4c1cd5ccb25b1afe6cb47941a8'
+'27ac81efff2c25cd672979ea931c2cce')
diff --git a/dhewm3.desktop b/dhewm3.desktop
index 15f0be3eb663..dfcc2319a8b2 100644
--- a/dhewm3.desktop
+++ b/dhewm3.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=Dhewm3
Exec=dhewm3
-Icon=doom3
+Icon=dhewm3
Type=Application
Comment=A Doom 3 port
Categories=Game;ActionGame;
diff --git a/dhewm3.png b/dhewm3.png
new file mode 100644
index 000000000000..1769ddbdd05b
--- /dev/null
+++ b/dhewm3.png
Binary files differ