summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore5
-rw-r--r--0001-game_data_location.patch13
-rw-r--r--PKGBUILD43
-rw-r--r--dhewm3.desktop7
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b67aeaed5b0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = dhewm3
+ pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/dhewm/dhewm3
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = doom3-data
+ depends = libjpeg
+ depends = libogg
+ depends = libvorbis
+ depends = openal
+ depends = sdl
+ optdepends = curl: download support
+ source = https://github.com/dhewm/dhewm3/archive/1.4.0.tar.gz
+ source = dhewm3.desktop
+ source = 0001-game_data_location.patch
+ sha256sums = b579cd2d07d4efc0ebb536c933857ee28a302d9e9484ebd5bda9b40f8da17f88
+ sha256sums = 7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287
+ sha256sums = dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9
+
+pkgname = dhewm3
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..665307854be8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg.tar*
+*.src.tar*
+*.gz
+src
+pkg
diff --git a/0001-game_data_location.patch b/0001-game_data_location.patch
new file mode 100644
index 000000000000..60966c259624
--- /dev/null
+++ b/0001-game_data_location.patch
@@ -0,0 +1,13 @@
+diff --git a/neo/framework/Licensee.h b/neo/framework/Licensee.h
+index 9cc20fb..fb1c882 100644
+--- a/neo/framework/Licensee.h
++++ b/neo/framework/Licensee.h
+@@ -90,7 +90,7 @@ If you have questions concerning this license or the applicable additional terms
+ #define WIN32_CONSOLE_CLASS "dhewm 3 WinConsole"
+
+ // Linux info
+-#define LINUX_DEFAULT_PATH "/usr/local/games/doom3"
++#define LINUX_DEFAULT_PATH "/usr/share/games/doom3"
+
+ // CD Key file info
+ // goes into BASE_GAMEDIR whatever the fs_game is set to
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11ebb5f7d98b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Mike Swanson <mikeonthecomputer@gmail.com>
+pkgname=dhewm3
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
+arch=('i686' 'x86_64')
+url="https://github.com/dhewm/dhewm3"
+license=('GPL3')
+depends=('doom3-data' 'libjpeg' 'libogg' 'libvorbis' 'openal' 'sdl')
+makedepends=('cmake')
+optdepends=('curl: download support')
+source=("$url/archive/$pkgver.tar.gz"
+ 'dhewm3.desktop'
+ '0001-game_data_location.patch')
+sha256sums=('b579cd2d07d4efc0ebb536c933857ee28a302d9e9484ebd5bda9b40f8da17f88'
+ '7c9ae892c6cf0453fcd57731689ccedac8f8ce10f33043f7dd5fb66bd73d1287'
+ 'dbbb0607a92482a1b753cf9cac97dcc57345b92ee43449c9826f5b23af7624f9')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
+
+build() {
+ cd "$pkgname-$pkgver/neo"
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -DD3XP=1 -DDEDICATED=1 .
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/neo"
+
+ make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ install -Dm644 "$srcdir"/dhewm3.desktop "$pkgdir/usr/share/applications/dhewm3.desktop"
+}
diff --git a/dhewm3.desktop b/dhewm3.desktop
new file mode 100644
index 000000000000..15f0be3eb663
--- /dev/null
+++ b/dhewm3.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Dhewm3
+Exec=dhewm3
+Icon=doom3
+Type=Application
+Comment=A Doom 3 port
+Categories=Game;ActionGame;