summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD41
-rw-r--r--dhewm3.install2
3 files changed, 28 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0b0840c3935..2abd395fedda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = dhewm3
pkgdesc = Doom 3 engine with native 64-bit support, SDL, and OpenAL
- pkgver = 1.5.0
- pkgrel = 2
+ pkgver = 1.5.1_RC2
+ pkgrel = 1
url = https://github.com/dhewm/dhewm3
install = dhewm3.install
arch = i686
@@ -14,10 +14,10 @@ pkgbase = dhewm3
depends = openal
depends = sdl2
optdepends = doom3-data
- source = https://github.com/dhewm/dhewm3/archive/1.5.0.tar.gz
+ source = https://github.com/dhewm/dhewm3/archive/1.5.1_RC2.tar.gz
source = dhewm3.desktop
source = dhewm3.png
- md5sums = cc770a4e454704405a83d8ea170706e8
+ md5sums = d67408a2a34e3a8b9a960b1df00ebaf0
md5sums = 300636e2e3ac0566dc6ceb63f121850e
md5sums = 8b834c4c1cd5ccb25b1afe6cb47941a8
diff --git a/PKGBUILD b/PKGBUILD
index 4e3ac09486e2..afe600fb9180 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: robertfoster
# Contributor: Mike Swanson <mikeonthecomputer@gmail.com>
-# Contributor:
+# Contributor:
pkgname=dhewm3
-pkgver=1.5.0
-pkgrel=2
+pkgver=1.5.1_RC2
+pkgrel=1
pkgdesc="Doom 3 engine with native 64-bit support, SDL, and OpenAL"
arch=('i686' 'x86_64')
url="https://github.com/dhewm/dhewm3"
@@ -13,28 +13,33 @@ depends=('curl' 'libjpeg' 'libvorbis' 'openal' 'sdl2')
optdepends=('doom3-data')
makedepends=('cmake')
source=("$url/archive/$pkgver.tar.gz"
- "$pkgname.desktop"
- "$pkgname.png"
+ "$pkgname.desktop"
+ "$pkgname.png"
)
install=$pkgname.install
build() {
- cd "$pkgname-$pkgver/neo"
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DD3XP=1 \
+ cd "$pkgname-$pkgver/neo"
+ cmake -Wno-dev \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DREPRODUCIBLE_BUILD=1 \
+ -DD3XP=1 \
-DDEDICATED=1 .
- make
+ cmake --build .
}
package() {
- cd "$pkgname-$pkgver/neo"
-
- make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
- install -Dm644 ../../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 ../../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ cd "$pkgname-$pkgver/neo"
+ DESTDIR="$pkgdir" \
+ cmake --install .
+ # make DESTDIR="$pkgdir" libdir="$pkgdir/usr/lib" install
+ install -Dm644 ../../$pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 ../../$pkgname.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 ../base/default.cfg "$pkgdir/usr/share/dhewm3/base/default.cfg"
+ install -dm755 "$pkgdir/usr/share/dhewm3/d3xp"
}
-md5sums=('cc770a4e454704405a83d8ea170706e8'
- '300636e2e3ac0566dc6ceb63f121850e'
-'8b834c4c1cd5ccb25b1afe6cb47941a8')
+md5sums=('d67408a2a34e3a8b9a960b1df00ebaf0'
+ '300636e2e3ac0566dc6ceb63f121850e'
+ '8b834c4c1cd5ccb25b1afe6cb47941a8')
diff --git a/dhewm3.install b/dhewm3.install
index 32d1f2e7930e..ce9a19a7c535 100644
--- a/dhewm3.install
+++ b/dhewm3.install
@@ -1,6 +1,6 @@
post_install() {
cat <<MSG
-You have to copy the Doom 3 *.pk4 files to /usr/share/dhewm3.
+You have to copy the Doom 3 *.pk4 files to /usr/share/dhewm3/base.
If you have Doom 3: Resurrection of Evil, you may also copy its
*.pk4 files into the d3xp directory.