summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e4c16acaddb..7ae75f1c268e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = diakonos-git
pkgdesc = A Linux console text editor for the masses.
- pkgver = 0.9.1.r61.gc0eadfe
+ pkgver = 0.9.9.r38.g9d923f7
pkgrel = 1
url = http://diakonos.pist0s.ca/
- arch = i686
- arch = x86_64
+ arch = any
license = MIT
makedepends = git
- depends = ruby
depends = ruby-curses
provides = diakonos
conflicts = diakonos
@@ -15,4 +13,3 @@ pkgbase = diakonos-git
md5sums = SKIP
pkgname = diakonos-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 193a8be351d8..d58304399e36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,23 @@
# Maintainer: aksr <aksr at t-com dot me>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=diakonos-git
-pkgver=0.9.1.r61.gc0eadfe
+pkgver=0.9.9.r38.g9d923f7
pkgrel=1
pkgdesc="A Linux console text editor for the masses."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://diakonos.pist0s.ca/"
license=('MIT')
-groups=()
-depends=('ruby' 'ruby-curses')
+depends=('ruby-curses')
makedepends=('git')
-optdepends=()
provides=('diakonos')
conflicts=('diakonos')
-replaces=()
-backup=()
-options=()
-install=
source=("$pkgname::git+https://github.com/Pistos/diakonos.git")
-noextract=()
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^v//g'
+ printf %s.r%s $(head -4 CHANGELOG|tail -1) $(git describe --tags | cut -c8- | tr - .)
}
package() {