summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD65
-rw-r--r--diamond-4.0.41.tar.gzbin193663 -> 0 bytes
-rw-r--r--diamond.service10
4 files changed, 47 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fca2c3f5a275..93312bfdf029 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,17 @@
pkgbase = diamond
- pkgdesc = Diamond is daemon that collects system metrics and publishes them to graphite and others
- pkgver = 4.0.41
- pkgrel = 3
- url = https://github.com/python-diamond/Diamond
- arch = any
- license = mit
- makedepends = unzip
- depends = python2
- depends = python2-configobj
- optdepends = python2-psycopg2: Postgresql collector
- optdepends = python2-pysensors: LMSensors collector
- optdepends = libvirt-python: LibvirtKVM collector
- optdepends = python2-yaml: PuppetAgent collector
- backup = etc/diamond/diamond.conf
- source = https://pypi.python.org/packages/source/d/diamond/diamond-4.0.41.tar.gz
- source = diamond.service
- md5sums = 063ee62fc30a678260df582335a583c3
- md5sums = 4294f34a8a4644c28788b997dcb4ba22
+ pkgdesc = High performance sequence aligner for protein and translated DNA searches with big sequence data. https://doi.org/10.1038/s41592-021-01101-x
+ pkgver = 2.1.9
+ pkgrel = 1
+ url = https://github.com/bbuchfink/diamond
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = gcc-libs
+ depends = zlib
+ depends = zstd
+ depends = blast+
+ depends = glibc
+ source = diamond-2.1.9.tar.gz::https://github.com/bbuchfink/diamond/archive/v2.1.9.tar.gz
+ sha256sums = 4cde9df78c63e8aef9df1e3265cd06a93ce1b047d6dba513a1437719b70e9d88
pkgname = diamond
-
diff --git a/PKGBUILD b/PKGBUILD
index 14070e1a58b5..084d823a386b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,40 @@
-# Maintainer: Uzerus < szymonscholz at gmail.com >
-# Contributor: Justin Dray <justin@dray.be>
-# Contributor: Augusto F. Hack <hack.augusto@gmail.com>
+# Maintainer: Bipin Kumar <kbipinkumar@pm.me>
+# shellcheck disable=2034
+# shellcheck disable=2148
pkgname=diamond
-pkgver=4.0.515
-pkgrel=3
-pkgdesc="Daemon that collects system metrics and publishes
-them to graphite and others"
-arch=('any')
-url="https://github.com/python-diamond/Diamond"
-license=('mit')
-depends=('python2' 'python')
-makedepends=('')
-optdepends=('python2-psycopg2: Postgresql collector'
- 'python2-pysensors: LMSensors collector'
- 'libvirt-python: LibvirtKVM collector'
- 'python2-yaml: PuppetAgent collector')
-backup=(etc/diamond/diamond.conf)
-source=("https://pypi.python.org/packages/0c/b6/4c58a8a1111c138fbed9e65dd918be706af8abd07bb5e8fe3ddfb453d899/${pkgname}-${pkgver}.tar.gz"
- "https://archive.org/download/${pkgname}_201801/${pkgname}.service")
-md5sums=('9ef6c5203e098da10aa0d90b344a49da'
- '4294f34a8a4644c28788b997dcb4ba22')
+pkgver=2.1.9
+pkgrel=1
+pkgdesc="High performance sequence aligner for protein and translated DNA searches with big sequence data. https://doi.org/10.1038/s41592-021-01101-x"
+arch=('x86_64')
+url="https://github.com/bbuchfink/diamond"
+license=('GPL3')
+depends=('gcc-libs' 'zlib' 'zstd' 'blast+' 'glibc')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bbuchfink/diamond/archive/v$pkgver.tar.gz")
+sha256sums=('4cde9df78c63e8aef9df1e3265cd06a93ce1b047d6dba513a1437719b70e9d88')
+build() {
+ cd $pkgname-$pkgver
+ cmake -B build \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DWITH_ZSTD=ON \
+ -DBLAST_INCLUDE_DIR=/usr/include/ncbi-tools++ \
+ -DBLAST_LIBRARY_DIR=/usr/lib/ \
+ -DZSTD_LIBRARY=/usr/lib/libzstd.so \
+ -DZLIB_INCLUDE_DIR=/usr/include \
+ -Wno-dev
-package() {
- cd "$srcdir/diamond-${pkgver}"
-
- install -D -m644 "$srcdir/diamond.service" "$pkgdir/usr/lib/systemd/system/diamond.service"
- python2 setup.py install --root="$pkgdir/" --optimize=1
- rm "$pkgdir/etc/diamond/diamond.conf.example.windows"
- rm -rf "$pkgdir/etc/diamond/collectors"
- rm -rf "$pkgdir/etc/diamond/handlers"
- rm -rf "$pkgdir/usr/share/diamond/user_scripts"
- mv "$pkgdir/etc/diamond/diamond.conf.example" "$pkgdir/etc/diamond/diamond.conf"
+ cmake --build build
+}
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+check() {
+ cd $pkgname-$pkgver
+ ctest --test-dir build --output-on-failure
}
+package() {
+ cd $pkgname-$pkgver
+ DESTDIR="$pkgdir" cmake --install build
+}
diff --git a/diamond-4.0.41.tar.gz b/diamond-4.0.41.tar.gz
deleted file mode 100644
index 37f0d14e4ea4..000000000000
--- a/diamond-4.0.41.tar.gz
+++ /dev/null
Binary files differ
diff --git a/diamond.service b/diamond.service
deleted file mode 100644
index 144d7bcc909b..000000000000
--- a/diamond.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Diamond daemon
-After=network.target
-
-[Service]
-ExecStart=/usr/bin/diamond --foreground
-TimeoutStopSec=2
-
-[Install]
-WantedBy=multi-user.target