summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c841fb6186fe..782869d23dac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,9 @@ pkgbase = diaspora-postgresql-git
arch = x86_64
license = AGPL3
makedepends = nodejs
- depends = ruby2.3
- depends = ruby2.3-bundler
+ makedepends = git
+ depends = ruby2.4
+ depends = ruby2.4-bundler
depends = redis
depends = imagemagick
depends = libxslt
diff --git a/PKGBUILD b/PKGBUILD
index 0ab07acb3a75..005cde7957d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@ pkgdesc="A distributed privacy aware social network (development head) (PostgreS
arch=('i686' 'x86_64')
url="https://diasporafoundation.org"
license=('AGPL3')
-depends=('ruby2.3' 'ruby2.3-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
+depends=('ruby2.4' 'ruby2.4-bundler' 'redis' 'imagemagick' 'libxslt' 'net-tools' 'gsfonts' 'libtirpc' 'postgresql-libs')
optdepends=('jemalloc: lower memory consumption' 'postgresql: Database server')
-makedepends=('nodejs')
+makedepends=('nodejs' 'git')
conflicts=('diaspora-mysql' 'diaspora-postgresql' 'diaspora-mysql-git')
options=(!strip)
backup=("etc/webapps/diaspora/diaspora.yml"
@@ -50,9 +50,9 @@ _reset_ruby() {
}
build() {
- _bundle=bundle-2.3
- _ruby=ruby-2.3
- _rake=rake-2.3
+ _bundle=bundle-2.4
+ _ruby=ruby-2.4
+ _rake=rake-2.4
_builddir=$srcdir/build
_reset_ruby
@@ -95,8 +95,8 @@ build() {
}
package() {
- _bundle=bundle-2.3
- _ruby=ruby-2.3
+ _bundle=bundle-2.4
+ _ruby=ruby-2.4
_builddir=$srcdir/build
msg "Copy contents to package directory"