summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--Fix-compilation-with-python-38-newer.patch24
-rw-r--r--PKGBUILD8
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69d55f0ace76..b2a198ba6e95 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dico
pkgdesc = GNU Dictionary Server
- pkgver = 2.9
+ pkgver = 2.11
pkgrel = 1
url = http://puszcza.gnu.org.ua/software/dico
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = dico
depends = wordnet-common
depends = guile
depends = pam
- source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.9.tar.xz
- source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.9.tar.xz.sig
+ depends = pcre
+ source = https://ftp.gnu.org/gnu/dico/dico-2.11.tar.xz
+ source = https://ftp.gnu.org/gnu/dico/dico-2.11.tar.xz.sig
validpgpkeys = 325F650C4C2B6AD58807327A3602B07F55D0C732
- sha1sums = 17551191f83350e5ca7f2272ac791a3da13bbc0a
+ sha1sums = f545452d1ecaf3e07780cf9324082c7a788e4afa
sha1sums = SKIP
pkgname = dico
diff --git a/Fix-compilation-with-python-38-newer.patch b/Fix-compilation-with-python-38-newer.patch
new file mode 100644
index 000000000000..0a9950eb75f4
--- /dev/null
+++ b/Fix-compilation-with-python-38-newer.patch
@@ -0,0 +1,24 @@
+From a8720e5606ae0e9a44958024c51c4f0d6232befc Mon Sep 17 00:00:00 2001
+From: Sergey Poznyakoff <gray@gnu.org>
+Date: Mon, 07 Sep 2020 20:37:26 +0000
+Subject: Fix compilation with python >=3.8
+
+* modules/python/module.ac: Try python-config --libs --embed first.
+---
+diff --git a/modules/python/module.ac b/modules/python/module.ac
+index 35993b8..418caef 100644
+--- a/modules/python/module.ac
++++ b/modules/python/module.ac
+@@ -32,7 +32,9 @@ if test "$status_python" = yes; then
+ AC_ARG_VAR([PYTHON_CONFIG], [The name of python-config binary])
+ AC_PATH_PROG([PYTHON_CONFIG], python-config)
+ if test -n "$PYTHON_CONFIG"; then
+- AC_SUBST(PYTHON_LIBS,`$PYTHON_CONFIG --libs`)
++ AC_SUBST(PYTHON_LIBS)
++ PYTHON_LIBS=`$PYTHON_CONFIG --libs --embed 2>/dev/null` || \
++ PYTHON_LIBS=`$PYTHON_CONFIG --libs`
+ AC_SUBST(PYTHON_INCLUDES,`$PYTHON_CONFIG --includes`)
+ $PYTHON <<EOT
+ import sys
+--
+cgit v0.9.0.3
diff --git a/PKGBUILD b/PKGBUILD
index e52b4b40393e..aaf150093cdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=dico
-pkgver=2.9
+pkgver=2.11
pkgrel=1
pkgdesc="GNU Dictionary Server"
arch=('x86_64')
url="http://puszcza.gnu.org.ua/software/$pkgname"
license=(GPL3)
-depends=(python gsasl wordnet-common guile pam)
-source=("ftp://download.gnu.org.ua/pub/release/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
-sha1sums=('17551191f83350e5ca7f2272ac791a3da13bbc0a'
+depends=(python gsasl wordnet-common guile pam pcre)
+source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
+sha1sums=('f545452d1ecaf3e07780cf9324082c7a788e4afa'
'SKIP')
validpgpkeys=('325F650C4C2B6AD58807327A3602B07F55D0C732')
# Sergey Poznyakoff <gray@gnu.org>