summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
-rw-r--r--stdio.patch12
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bee3894ba38e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dico
+ pkgdesc = GNU Dico is a flexible modular implementation of DICT server (RFC 2229).
+ pkgver = 2.2
+ pkgrel = 1
+ url = ftp://download.gnu.org.ua/pub/release/dico
+ arch = any
+ license = GPLv3
+ source = ftp://download.gnu.org.ua/pub/release/dico/dico-2.2.tar.gz
+ md5sums = 45145e4790ce64332b2d8e842ce5f957
+
+pkgname = dico
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..698952e5fe77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=dico
+pkgver=2.2
+pkgrel=1
+pkgdesc="GNU Dico is a flexible modular implementation of DICT server (RFC 2229)."
+arch=('any')
+url="ftp://download.gnu.org.ua/pub/release/$pkgname"
+license=(GPLv3)
+depends=()
+source=("$url/$pkgname-$pkgver.tar.gz")
+md5sums=('45145e4790ce64332b2d8e842ce5f957')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ patch -p1 < ../../stdio.patch
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
diff --git a/stdio.patch b/stdio.patch
new file mode 100644
index 000000000000..a35a4f72dcc3
--- /dev/null
+++ b/stdio.patch
@@ -0,0 +1,12 @@
+diff -Naur dico-2.2/gnu/stdio.in.h dico-2.2.1/gnu/stdio.in.h
+--- dico-2.2/gnu/stdio.in.h 2012-01-09 12:39:33.000000000 +0100
++++ dico-2.2.1/gnu/stdio.in.h 2016-06-22 05:02:58.420791647 +0200
+@@ -163,8 +163,6 @@
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@