summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
-rw-r--r--dict-freedict-eng-fra.install72
3 files changed, 76 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfbbeb82182f..74209385bed5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = dict-freedict-eng-fra
pkgdesc = English -> French dictionary for dictd from Freedict.org
pkgver = 0.1.4
- pkgrel = 1
+ pkgrel = 2
url = http://www.freedict.org/
install = dict-freedict-eng-fra.install
arch = any
license = GPL
- depends = dictd
+ makedepends = dictd
+ optdepends = dictd: dict client and server
source = http://sourceforge.net/projects/freedict/files/English%20-%20French/0.1.4/freedict-eng-fra-0.1.4.tar.bz2
md5sums = b0ac25998cdebefc897cb2c20374a7f2
diff --git a/PKGBUILD b/PKGBUILD
index e3bca36436d0..299b4ea3c43f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
-# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info
# Maintainer: respiranto <respiranto@icloud.com>
+# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info
pkgname=dict-freedict-eng-fra
pkgver=0.1.4
-pkgrel=1
+pkgrel=2
pkgdesc="English -> French dictionary for dictd from Freedict.org"
arch=('any')
url="http://www.freedict.org/"
license=('GPL')
-depends=(dictd)
-install=dict-freedict-eng-fra.install
+optdepends=('dictd: dict client and server')
+makedepends=('dictd')
+install=$pkgname.install
source=("http://sourceforge.net/projects/freedict/files/English%20-%20French/$pkgver/freedict-eng-fra-$pkgver.tar.bz2")
md5sums=('b0ac25998cdebefc897cb2c20374a7f2')
diff --git a/dict-freedict-eng-fra.install b/dict-freedict-eng-fra.install
index cf923dd12079..1c88991b4ca2 100644
--- a/dict-freedict-eng-fra.install
+++ b/dict-freedict-eng-fra.install
@@ -1,7 +1,71 @@
+pkgname=dict-freedict-eng-fra
+basename=eng-fra
+dictd_conf=/etc/dict/dictd.conf
+datadir=/usr/share/dictd
+conf="database $basename {
+ data $datadir/$basename.dict.dz
+ index $datadir/$basename.index
+}"
+
post_install()
{
- echo -e "\nYou have to configure dictd to use the new dictionary" \
- "database located in /usr/share/dictd/ manually" \
- "and restart the dictd service afterwards.\n\n" \
- "See also dictd(8).\n"
+ echo
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ if grep -q "^database *$basename" "$dictd_conf"
+ then
+ echo "$pkgname already configured in $dictd_conf"
+ else
+ echo "Adding configuration for $pkgname to $dictd_conf"
+ echo -e "$conf" >> "$dictd_conf"
+ fi
+
+ if systemctl -q is-active dictd.service
+ then
+ echo "Restarting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl restart dictd.service
+ else
+ echo "Starting dictd service in order to" \
+ "use the new dictionary database"
+ systemctl start dictd.service
+ fi
+ else
+ echo "dictd does not appear to be installed."
+ echo "In order to use this database you should either" \
+ "install dictd or alternatively" \
+ "another dict server and configure it on your own."
+ fi
+ echo
+}
+
+post_upgrade()
+{
+ if pacman -Qq dictd > /dev/null 2>&1 && \
+ systemctl -q is-active dictd.service
+ then
+ echo -e "\nRestarting dictd service in order to" \
+ "use the updated dictionary database"
+ systemctl restart dictd.service
+ fi
+}
+
+post_remove()
+{
+ if pacman -Qq dictd > /dev/null 2>&1
+ then
+ current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
+ if test -n "$current_conf"
+ then
+ echo
+ if test "$current_conf" = "$conf"
+ then
+ echo "Removing configuration for $pkgname from $dictd_conf"
+ sed -i "/database $basename {/,/}/d" "$dictd_conf"
+ else
+ echo "User created / modified configuration" \
+ "for $pkgname in $dictd_conf is left untouched."
+ fi
+ fi
+ fi
}