summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
-rw-r--r--dict-freedict-fra-deu-bin.install30
3 files changed, 41 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ccdf56d87e6..c6d29db9b4f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = dict-freedict-fra-deu-bin
- pkgdesc = French -> German dictionary for dictd et al. from Freedict.org
- pkgver = 2018.09.13
+ pkgdesc = French -> German dictionary for dictd et al. from FreeDict.org
+ pkgver = 2023.05.29
pkgrel = 1
url = https://freedict.org/
install = dict-freedict-fra-deu-bin.install
arch = any
- license = GPL
+ license = CCPL:by-sa
+ license = FDL
optdepends = dictd: dict client and server
- provides = dict-freedict-fra-deu
+ provides = dict-freedict-fra-deu=2023.05.29
conflicts = dict-freedict-fra-deu
- source = https://download.freedict.org/dictionaries/fra-deu/2018.09.13/freedict-fra-deu-2018.09.13.dictd.tar.xz
- sha512sums = 42abd772036050cbaa27710e113c32b3a8dd78aec4fc0688ea1b0eefdcb31531859b2177ad90ceece2168b6ac914a191f0bb9633c8f734f28f39410ddf05be3c
+ source = https://download.freedict.org/dictionaries/fra-deu/2023.05.29/freedict-fra-deu-2023.05.29.dictd.tar.xz
+ sha512sums = 325850ffe2a42f835b60ecbf1c7954972477cd4cf05ace64485c77ca9d3713b208561b35356d817ff289f35bae27522c25e8244315c9338164bfebc870ce1429
pkgname = dict-freedict-fra-deu-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index b4bb32338771..0e6da20f6e97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,35 @@
# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
+#
+# Generated by aur-fd-scripts - https://git.respiranto.de/aur-fd-scripts.git/
+
_lang=fra-deu
-_pkgname=dict-freedict-${_lang}
-pkgname=${_pkgname}-bin
-pkgver=2018.09.13
+_pkgname="dict-freedict-${_lang}"
+pkgname="${_pkgname}-bin"
+_pkgver=2023.05.29
+pkgver="${_pkgver//-/_}"
pkgrel=1
-pkgdesc="French -> German dictionary for dictd et al. from Freedict.org"
+pkgdesc="French -> German dictionary for dictd et al. from FreeDict.org"
arch=('any')
url="https://freedict.org/"
-license=('GPL')
+license=('CCPL:by-sa' 'FDL')
optdepends=('dictd: dict client and server')
-provides=(${_pkgname})
-conflicts=(${_pkgname})
-install=${pkgname}.install
-source=("https://download.freedict.org/dictionaries/${_lang}/${pkgver}/freedict-${_lang}-${pkgver}.dictd.tar.xz")
-sha512sums=('42abd772036050cbaa27710e113c32b3a8dd78aec4fc0688ea1b0eefdcb31531859b2177ad90ceece2168b6ac914a191f0bb9633c8f734f28f39410ddf05be3c')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("$_pkgname")
+install="${pkgname}.install"
+source=("https://download.freedict.org/dictionaries/${_lang}/${_pkgver}/freedict-${_lang}-${_pkgver}.dictd.tar.xz")
+sha512sums=('325850ffe2a42f835b60ecbf1c7954972477cd4cf05ace64485c77ca9d3713b208561b35356d817ff289f35bae27522c25e8244315c9338164bfebc870ce1429')
package()
{
install -m 755 -d "${pkgdir}/usr/share/dictd"
install -m 644 -t "${pkgdir}/usr/share/dictd/" \
- ${_lang}/${_lang}.{dict.dz,index}
+ "${_lang}/${_lang}".{dict.dz,index}
- for file in ${_lang}/{AUTHORS,README,NEWS,ChangeLog}
+ for file in "$_lang"/{AUTHORS,README,NEWS,ChangeLog}
do
- if test -f ${file}
+ if test -f "$file"
then
- install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" ${file}
+ install -m 644 -Dt "${pkgdir}/usr/share/doc/freedict/${_lang}/" "$file"
fi
done
}
diff --git a/dict-freedict-fra-deu-bin.install b/dict-freedict-fra-deu-bin.install
index d17b1bddcdb9..b515a627f2f1 100644
--- a/dict-freedict-fra-deu-bin.install
+++ b/dict-freedict-fra-deu-bin.install
@@ -1,10 +1,12 @@
+# Generated by aur-fd-scripts - https://git.respiranto.de/aur-fd-scripts.git/
+
basename=fra-deu
-pkgname=dict-freedict-$basename-bin
+pkgname="dict-freedict-${basename}-bin"
dictd_conf=/etc/dict/dictd.conf
datadir=/usr/share/dictd
-conf="database $basename {
- data $datadir/$basename.dict.dz
- index $datadir/$basename.index
+conf="database ${basename} {
+ data ${datadir}/${basename}.dict.dz
+ index ${datadir}/${basename}.index
}"
post_install()
@@ -12,12 +14,12 @@ post_install()
echo
if pacman -Qq dictd > /dev/null 2>&1
then
- if grep -q "^database *$basename" "$dictd_conf"
+ if grep -q "^database *${basename}" "${dictd_conf}"
then
- echo "$pkgname already configured in $dictd_conf"
+ echo "${pkgname} already configured in ${dictd_conf}"
else
- echo "Adding configuration for $pkgname to $dictd_conf"
- echo "$conf" >> "$dictd_conf"
+ echo "Adding configuration for ${pkgname} to ${dictd_conf}"
+ echo "${conf}" >> "${dictd_conf}"
fi
if systemctl -q is-active dictd.service
@@ -54,17 +56,17 @@ post_remove()
{
if pacman -Qq dictd > /dev/null 2>&1
then
- current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
- if test -n "$current_conf"
+ current_conf="$(grep -A 3 "^database *${basename}" "${dictd_conf}")"
+ if test -n "${current_conf}"
then
echo
- if test "$current_conf" = "$conf"
+ if test "${current_conf}" = "${conf}"
then
- echo "Removing configuration for $pkgname from $dictd_conf"
- sed -i "/database $basename {/,/}/d" "$dictd_conf"
+ echo "Removing configuration for ${pkgname} from ${dictd_conf}"
+ sed -i "/database ${basename} {/,/}/d" "${dictd_conf}"
else
echo "User created / modified configuration" \
- "for $pkgname in $dictd_conf is left untouched."
+ "for ${pkgname} in ${dictd_conf} is left untouched."
fi
fi