summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26ada9dda3d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dictionaryreader.app
+ pkgdesc = Dictionary application that queries Dict servers in the internet to let you look up words
+ pkgver = 20160621
+ pkgrel = 1
+ url = https://www.unix-ag.uni-kl.de/~guenther/gnustep/dictionaryreader.html
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ groups = gnustep-apps
+ license = GPL
+ makedepends = gcc-objc
+ makedepends = gnustep-make
+ depends = gnustep-base
+ depends = gnustep-gui
+ depends = gnustep-back
+ source = https://www.unix-ag.uni-kl.de/~guenther/gnustep/downloads/dictionaryreader/DictionaryReader-STABLE.tar.gz
+ sha256sums = 6b19834e0eaf1aac58af638d0ba44a32c8251234bc83abcf9e43d13aa72439d8
+
+pkgname = dictionaryreader.app
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99ea44006f4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Icarus Mitchellson <mumei AT airmail DOT cc>
+
+_pkgname=DictionaryReader
+pkgname=dictionaryreader.app
+pkgrel=1
+pkgver=20160621
+pkgdesc='Dictionary application that queries Dict servers in the internet to let you look up words'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://www.unix-ag.uni-kl.de/~guenther/gnustep/dictionaryreader.html'
+license=('GPL')
+groups=('gnustep-apps')
+depends=('gnustep-base' 'gnustep-gui' 'gnustep-back')
+makedepends=('gcc-objc' 'gnustep-make')
+source=("https://www.unix-ag.uni-kl.de/~guenther/gnustep/downloads/dictionaryreader/DictionaryReader-STABLE.tar.gz")
+sha256sums=('6b19834e0eaf1aac58af638d0ba44a32c8251234bc83abcf9e43d13aa72439d8')
+
+build() {
+ cd $_pkgname
+ export GNUSTEP_MAKEFILES="$(gnustep-config --variable=GNUSTEP_MAKEFILES)"
+ make
+}
+
+package() {
+ cd $_pkgname
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "$pkgdir/usr/lib/GNUstep/Applications/$_pkgname.app/Resources/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file