summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD38
-rw-r--r--remove-cairo.patch24
4 files changed, 31 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd49947d617d..a57e29970c75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = diff-pdf
pkgdesc = A simple tool for visually comparing two PDF files
- pkgver = 0.4.1
+ pkgver = 0.5.2
pkgrel = 1
url = http://vslavik.github.io/diff-pdf
arch = x86_64
license = GPL
+ makedepends = wxwidgets-common
depends = poppler-glib
- depends = wxgtk2
- source = https://github.com/vslavik/diff-pdf/releases/download/v0.4.1/diff-pdf-0.4.1.tar.gz
- source = remove-cairo.patch
- sha256sums = 0eb81af6b06593488acdc5924a199f74fe3df6ecf2a0f1be208823c021682686
- sha256sums = 26027109e4e685d5ecf3d733e9b8ab334c54720056a5bcaebd6b1d2e5f6ef65a
+ depends = wxwidgets-gtk3
+ source = https://github.com/vslavik/diff-pdf/releases/download/v0.5.2/diff-pdf-0.5.2.tar.gz
+ sha256sums = 7d018f05e30050a2b49dee137f084584b43aec87c7f5ee9c3bbd14c333cbfd54
pkgname = diff-pdf
-
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..6c704e4f40b2
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[diff-pdf]
+source = "github"
+github = "vslavik/diff-pdf"
+prefix = "v"
+use_max_tag = true
diff --git a/PKGBUILD b/PKGBUILD
index 51d876a3c100..a802c74c1d53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
pkgname=diff-pdf
-pkgver=0.4.1
+pkgver=0.5.2
pkgrel=1
pkgdesc='A simple tool for visually comparing two PDF files'
-arch=('x86_64')
+arch=(x86_64)
url="http://vslavik.github.io/$pkgname"
-license=('GPL')
-depends=('poppler-glib' 'wxgtk2')
-source=("https://github.com/vslavik/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
- remove-cairo.patch)
-sha256sums=('0eb81af6b06593488acdc5924a199f74fe3df6ecf2a0f1be208823c021682686'
- '26027109e4e685d5ecf3d733e9b8ab334c54720056a5bcaebd6b1d2e5f6ef65a')
+_url="https://github.com/vslavik/$pkgname"
+license=(GPL)
+depends=(poppler-glib
+ wxwidgets-gtk3)
+makedepends=(wxwidgets-common)
+_archive="$pkgname-$pkgver"
+source=("$_url/releases/download/v$pkgver/$_archive.tar.gz")
+sha256sums=('7d018f05e30050a2b49dee137f084584b43aec87c7f5ee9c3bbd14c333cbfd54')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 < ../remove-cairo.patch
- aclocal
- autoconf
- automake --add-missing --copy --foreign
+ cd "$_archive"
+ ./bootstrap
+ # Use /usr/share/aclocal/wxwin.m4 from wxwidgets-common
+ rm -f admin/wxwin.m4
+ cp /usr/share/aclocal/wxwin.m4 admin
}
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr
+ cd "$_archive"
+ ./configure --prefix /usr \
+ --with-wx-config=wx-config
make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "$_archive"
+ make DESTDIR="$pkgdir" install
}
diff --git a/remove-cairo.patch b/remove-cairo.patch
deleted file mode 100644
index ecef020a998a..000000000000
--- a/remove-cairo.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 00fd9ab8bf435658616f3f25b18d51b0a7ee5769 Mon Sep 17 00:00:00 2001
-From: FX Coudert <fxcoudert@gmail.com>
-Date: Sat, 12 Dec 2020 16:18:59 +0100
-Subject: [PATCH] Remove legacy poppler-cairo dependency (#69)
-
-poppler-glib already depended on it, so this is non-breaking,
-and it is removed in poppler 0.18.1.
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 382e220..2e9b6e5 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -41,7 +41,7 @@ AC_LANG(C++)
- dnl === Library checks ===
-
- PKG_CHECK_MODULES(POPPLER,
-- [poppler-cairo >= 0.10 poppler-glib >= 0.10 cairo-pdf])
-+ [poppler-glib >= 0.10 cairo-pdf])
-
- AM_OPTIONS_WXCONFIG
- AM_PATH_WXCONFIG([3.0.0], [wxfound=1], [wxfound=0], [core,base])