summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--digitalocean-synchronize.sh20
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18d9b5cd1eb9..43ab1b86edcc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = digitalocean-synchronize
pkgdesc = DigitalOcean Synchronization (passwords, keys, networks)
pkgver = 2.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gh2o/digitalocean-debian-to-arch
arch = any
license = GPL
@@ -10,7 +10,7 @@ pkgbase = digitalocean-synchronize
source = digitalocean-synchronize.sh
source = digitalocean-synchronize.service
source = 90-dosync-virtio-no-rename.link
- sha256sums = 37261e4f5a79a5308e8e94925a037cc2e3d13fa5a473f6fc9b57bed07c06ed5d
+ sha256sums = 521e9ec8c6382151313b8bd936450d8a3bc56c052f1bad4b74777ebc4900af53
sha256sums = 25e28f7b3351662b8e2da71aee38a1131df2568177e676e49f47a75d33894d64
sha256sums = d85cde96e602a4ff296d18a7769c683a66feffe5db35a03cdeab651922681f85
diff --git a/PKGBUILD b/PKGBUILD
index 85b25226d33a..df58b4c599d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=digitalocean-synchronize
pkgver=2.6
-pkgrel=2
+pkgrel=3
pkgdesc='DigitalOcean Synchronization (passwords, keys, networks)'
url='https://github.com/gh2o/digitalocean-debian-to-arch'
@@ -17,7 +17,7 @@ source=(digitalocean-synchronize.sh
digitalocean-synchronize.service
90-dosync-virtio-no-rename.link)
-sha256sums=('37261e4f5a79a5308e8e94925a037cc2e3d13fa5a473f6fc9b57bed07c06ed5d'
+sha256sums=('521e9ec8c6382151313b8bd936450d8a3bc56c052f1bad4b74777ebc4900af53'
'25e28f7b3351662b8e2da71aee38a1131df2568177e676e49f47a75d33894d64'
'd85cde96e602a4ff296d18a7769c683a66feffe5db35a03cdeab651922681f85')
diff --git a/digitalocean-synchronize.sh b/digitalocean-synchronize.sh
index bf6827baceb5..5de4bca8744f 100644
--- a/digitalocean-synchronize.sh
+++ b/digitalocean-synchronize.sh
@@ -1,5 +1,25 @@
#!/bin/bash
+# Copyright (c) 2017 Gavin Li.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a copy of
+# this software and associated documentation files (the "Software"), to deal in
+# the Software without restriction, including without limitation the rights to
+# use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies
+# of the Software, and to permit persons to whom the Software is furnished to do
+# so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in all
+# copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
meta_base=http://169.254.169.254/metadata/v1/
set -eu