summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--din.patch22
3 files changed, 7 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5f5e410b4cf..4741e07ca9cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = din
pkgdesc = A sound synthesizer and musical instrument.
- pkgver = 26
+ pkgver = 27a
pkgrel = 1
url = http://dinisnoise.org/
install = din.install
@@ -13,12 +13,10 @@ pkgbase = din
depends = libgl
depends = sdl
depends = tcl
- source = svn+svn://jagernot.xyz/home/svn/din/trunk
- source = din.patch
+ source = svn+svn://jagernot.xyz/home/svn/din/tags/27a
source = din.png
source = din.desktop
md5sums = SKIP
- md5sums = 1135196ec010ddcb26b4539d19ae26e8
md5sums = 50ca4dc107eaa0d5b6a1efe21c469bd7
md5sums = e38840354b0f197079e6bbeda03c8613
diff --git a/PKGBUILD b/PKGBUILD
index 90eabe01a307..5da1094a3f08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: muzhed <chustokes@126.com>
pkgname=din
-pkgver=26
+pkgver=27a
pkgrel=1
pkgdesc="A sound synthesizer and musical instrument."
arch=("i686" "x86_64")
@@ -10,26 +10,24 @@ license=('GPL2')
depends=('jack' 'libgl' 'sdl' 'tcl')
makedepends=('boost' 'subversion')
install=$pkgname.install
-source=('svn+svn://jagernot.xyz/home/svn/din/trunk'
- din.patch
+source=('svn+svn://jagernot.xyz/home/svn/din/tags/27a'
din.png
din.desktop)
md5sums=('SKIP'
- '1135196ec010ddcb26b4539d19ae26e8'
'50ca4dc107eaa0d5b6a1efe21c469bd7'
'e38840354b0f197079e6bbeda03c8613')
build() {
- cd "$srcdir"/trunk
+ cd "$srcdir"/27a
- patch -p1 < ../din.patch
+ autoreconf -fvi
./configure CXXFLAGS=-O3 CFLAGS=-O3
make
}
package() {
- cd "$srcdir"/trunk
+ cd "$srcdir"/27a
install -Dm755 src/din "$pkgdir/usr/lib/din/din"
cp -r "src/factory" "$pkgdir/usr/lib/din"
ln -s "/usr/lib/din/factory" "$pkgdir/usr/lib/din/user"
diff --git a/din.patch b/din.patch
deleted file mode 100644
index ca9a26a68570..000000000000
--- a/din.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -u trunk/src/Makefile.am patched-trunk/src/Makefile.am
---- trunk/src/Makefile.am 2017-01-09 12:15:26.299591047 +0800
-+++ patched-trunk/src/Makefile.am 2017-01-09 12:40:56.929641301 +0800
-@@ -1,5 +1,5 @@
- AM_CXXFLAGS = -I ../include -I /usr/include/tcl -I /usr/include/tcl8.5 -Wall -D_GNU_SOURCE=1 -D_THREAD_SAFE -DHAVE_OPENGL -D__UNIX_JACK__ -D__LICENSED__ -fpermissive
--LIBS += -ltcl8.5 -lSDL -lGL -lpthread -ljack
-+LIBS += -ltcl8.6 -lSDL -lGL -lpthread -ljack
-
- bin_PROGRAMS = din
- din_SOURCES = arrow_button.cc audio.cc authors_note.cc basic_editor.cc beat2value.cc bit_display.cc button.cc checkbutton.cc chrono.cc circler.cc command.cc compressor.cc console.cc console_iterator.cc countries.cc cross_button.cc curve.cc curve_display.cc curve_editor.cc curve_library.cc curve_mixer.cc curve_picker.cc custom_periodic.cc delay.cc din.cc drone.cc fader.cc fft.cc field.cc filled_button.cc font.cc font_editor.cc fractaliser.cc globals.cc glyph.cc gravity.cc help.cc item_list.cc keyboard_keyboard.cc label.cc levels.cc line.cc lissajous.cc listeners.cc main.cc menu.cc mesh.cc midi_in.cc minus_button.cc mocap.cc mondrian.cc morpher.cc morse_code.cc multi_curve.cc note.cc number.cc oscilloscope.cc phrasor.cc play.cc plugin.cc plugin_browser.cc plus_button.cc range.cc recorder.cc rose_milker.cc scale_info.cc scale_notes.cc scalelist.cc separator.cc settings.cc sine_mixer.cc solver.cc sounder.cc sounding_board.cc spiraler.cc starrer.cc superformula.cc tap_bpm.cc tcl_interp.cc textboard.cc tokenizer.cc trail.cc triggered_note.cc ui.cc ui_sin_cos_radius.cc viewwin.cc warper.cc widget.cc kiss_fft.c RtAudio.cpp RtMidi.cpp
-diff -u trunk/src/Makefile.in patched-trunk/src/Makefile.in
---- trunk/src/Makefile.in 2017-01-09 12:15:26.302924380 +0800
-+++ patched-trunk/src/Makefile.in 2017-01-09 12:40:42.306307494 +0800
-@@ -124,7 +124,7 @@
- INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
- LDFLAGS = @LDFLAGS@
- LIBOBJS = @LIBOBJS@
--LIBS = @LIBS@ -ltcl8.5 -lSDL -lGL -lpthread -ljack
-+LIBS = @LIBS@ -ltcl8.6 -lSDL -lGL -lpthread -ljack
- LTLIBOBJS = @LTLIBOBJS@
- MAKEINFO = @MAKEINFO@
- MKDIR_P = @MKDIR_P@