summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21936d2ce74f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = diorite
+ pkgdesc = Utility and widget library based on Glib and GTK3.
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://tiliado.eu/diorite
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python
+ depends = vala
+ depends = glib2
+ depends = gtk3
+ provides = diorite
+ source = https://github.com/tiliado/diorite/archive/0.2.0.tar.gz
+ sha256sums = f4517f148b8296f6c72146769f8537c1348ee9e87eb0171e0213858a0d0aae8d
+
+pkgname = diorite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3d8ce0e94c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: petRUShka <petrushkin@yandex.ru>
+
+pkgname=diorite
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Utility and widget library based on Glib and GTK3."
+arch=('i686' 'x86_64')
+url="https://tiliado.eu/diorite"
+license=('GPL')
+provides=('diorite')
+depends=('python' 'vala' 'glib2' 'gtk3')
+source=(https://github.com/tiliado/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('f4517f148b8296f6c72146769f8537c1348ee9e87eb0171e0213858a0d0aae8d')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./waf configure --prefix=/usr
+ ./waf build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ ./waf install --destdir="${pkgdir}"
+}