summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40d5a79e21a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dirindex
+ pkgdesc = Create an HTML index starting from a directory using templates for the resulting pages
+ pkgver = 0.3.1
+ pkgrel = 3
+ url = https://github.com/muflone/dirindex
+ arch = any
+ license = GPL3
+ depends = python2
+ depends = python-magic
+ noextract = dirindex-0.3.1.tar.gz
+ source = dirindex-0.3.1.tar.gz::https://github.com/muflone/dirindex/tarball/0.3.1
+ md5sums = b7d0621d034e3988940f79ff157f34cb
+
+pkgname = dirindex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90761c02cfe6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Muflone <webreg@vbsimple.net>
+
+pkgname=dirindex
+pkgver=0.3.1
+pkgrel=3
+pkgdesc="Create an HTML index starting from a directory using templates for the resulting pages"
+arch=(any)
+url="https://github.com/muflone/dirindex"
+license=(GPL3)
+depends=('python2' 'python-magic')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/muflone/$pkgname/tarball/$pkgver")
+md5sums=('b7d0621d034e3988940f79ff157f34cb')
+noextract=("$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir"
+ [ -d "$pkgname-$pkgver" ] && rm -rf "$pkgname-$pkgver"
+ mkdir "$pkgname-$pkgver"
+ tar xzf "$pkgname-$pkgver.tar.gz" -C "$pkgname-$pkgver/" --strip-components=1
+ find "$pkgname-$pkgver/templates/" -type f -print0 | xargs --null chmod 644
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/$pkgname"
+ install -m 755 "dirindex.py" "$pkgdir/usr/bin/dirindex"
+ cp -r templates "$pkgdir/usr/share/$pkgname/templates"
+}
+