summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cbcf6bf7383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dirstalk-git
+ pkgdesc = Multi threaded application designed to brute force paths on web servers, modern alternative to dirb and dirbuster
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://github.com/stefanoj3/dirstalk
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ makedepends = dep
+ provides = dirstalk
+ conflicts = dirstalk
+ source = dirstalk-git::git+https://github.com/stefanoj3/dirstalk
+ sha512sums = SKIP
+
+pkgname = dirstalk-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..96eb0f2ac51b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f612a0426d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Stefano Gabryel <esse[dot]gab2[at]gmail[dot]com>
+
+pkgname=dirstalk
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Multi threaded application designed to brute force paths on web servers, modern alternative to dirb and dirbuster'
+url='https://github.com/stefanoj3/dirstalk'
+arch=('x86_64')
+license=('MIT')
+makedepends=('go' 'git')
+options=('!emptydirs')
+source=(https://github.com/stefanoj3/dirstalk/archive/${pkgver}.tar.gz)
+sha512sums=('01da285dfe2b586773b954da897982870e6ef3fc9daa604dd1d6c5febb0473a14f71743485ed762a859e0337e25b47c4b425c0819366f905bc3d04f0d8e4de8e')
+
+prepare() {
+ export GOPATH="${srcdir}/go"
+ mkdir -p go/src/github.com/stefanoj3
+ ln -rTsf ${pkgname}-${pkgver} go/src/github.com/stefanoj3/dirstalk
+}
+
+build() {
+ cd go/src/github.com/stefanoj3/dirstalk
+ export GOPATH="${srcdir}/go"
+ dep ensure
+ make build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ install -Dm 755 dist/dirstalk -t "${pkgdir}/usr/bin"
+}