summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--Discord.desktop8
-rw-r--r--PKGBUILD35
3 files changed, 39 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ffc376c3a92..6c4a58d9741e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
+# Generated by mksrcinfo v8
+# mar oct 20 12:01:02 UTC 2015
pkgbase = discord
pkgdesc = Discord linux App
pkgver = 0.1.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/XNBlank/discord-linux
arch = i686
arch = x86_64
license = MIT
+ source = Discord.desktop
+ sha256sums = 6b0faff2ddd149a8c9b9b5ca66d9117a6388c3a2e720d3d3f971ae97b2670bee
+ source_i686 = https://github.com/XNBlank/discord-linux/archive/x86-0.1.1.tar.gz
+ sha256sums_i686 = 9bd4b4a57baf2f87f33f5e61b772f5c51c314f2874f30ec710620106a95a47fa
source_x86_64 = https://github.com/XNBlank/discord-linux/archive/x64-0.1.1.tar.gz
sha256sums_x86_64 = e5c1c9599ddf708570baa1a3103600211d14ca6d69dbcb5b0fc471aec0c30cb0
- source_i386 = https://github.com/XNBlank/discord-linux/archive/x86-0.1.1.tar.gz
- sha256sums_i386 = 9bd4b4a57baf2f87f33f5e61b772f5c51c314f2874f30ec710620106a95a47fa
pkgname = discord
+
diff --git a/Discord.desktop b/Discord.desktop
new file mode 100644
index 000000000000..ac24f0e6ed35
--- /dev/null
+++ b/Discord.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Discord
+Comment=Discord App
+Exec=discord
+Icon=/opt/discord/resources/app/icon.png
+StartupNotify=false
+Categories=Network;Chat;InstantMessaging
+Type=Application \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d3ff09b18f03..6b305d7deaa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,46 @@
pkgname=discord
pkgver=0.1.1
-pkgrel=2
+pkgrel=3
pkgdesc='Discord linux App'
arch=('i686' 'x86_64')
url='https://github.com/XNBlank/discord-linux'
license=('MIT')
+source=('Discord.desktop')
+sha256sums=('6b0faff2ddd149a8c9b9b5ca66d9117a6388c3a2e720d3d3f971ae97b2670bee')
+
+source_i686=("https://github.com/XNBlank/discord-linux/archive/x86-${pkgver}.tar.gz")
+sha256sums_i686=('9bd4b4a57baf2f87f33f5e61b772f5c51c314f2874f30ec710620106a95a47fa')
+
source_x86_64=("https://github.com/XNBlank/discord-linux/archive/x64-${pkgver}.tar.gz")
sha256sums_x86_64=('e5c1c9599ddf708570baa1a3103600211d14ca6d69dbcb5b0fc471aec0c30cb0')
-source_i386=("https://github.com/XNBlank/discord-linux/archive/x86-${pkgver}.tar.gz")
-sha256sums_i386=('9bd4b4a57baf2f87f33f5e61b772f5c51c314f2874f30ec710620106a95a47fa')
-
package() {
case $CARCH in
'i686') _arch='x86';;
'x86_64') _arch='x64';;
esac
- install -d "${pkgdir}/usr/share/discord"
- cp -a "${srcdir}/${pkgname}-linux-${_arch}-${pkgver}/." "${pkgdir}/usr/share/discord/"
+ # Install files
+ install -d "${pkgdir}/opt/discord"
+ cp -a "${srcdir}/${pkgname}-linux-${_arch}-${pkgver}/." "${pkgdir}/opt/discord/"
- install -d "${pkgdir}/usr/bin"
- ln -s "/usr/share/discord/discord" "${pkgdir}/usr/bin/discord"
+ # Make binary executable
+ chmod 755 "${pkgdir}/opt/discord/discord"
+
+ # Install desktop entry
+ install -d "${pkgdir}/usr/share/applications"
+ install "${srcdir}/Discord.desktop" "${pkgdir}/usr/share/applications"
- install -Dm644 "${pkgdir}/usr/share/discord/LICENSE" "${pkgdir}/usr/share/licenses/discord/LICENSE"
- rm "${pkgdir}/usr/share/discord/LICENSE"
+ # Create symbolic link to the main binary
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/discord/discord" "${pkgdir}/usr/bin/discord"
- chmod 755 "${pkgdir}/usr/share/discord/discord"
+ # Install license file
+ install -Dm644 "${pkgdir}/opt/discord/LICENSE" "${pkgdir}/usr/share/licenses/discord/LICENSE"
+ rm "${pkgdir}/opt/discord/LICENSE"
# Dirty hack... we should tell the developer to store settings in user home...
- chmod 666 "${pkgdir}/usr/share/discord/resources/app/init.json"
+ chmod 666 "${pkgdir}/opt/discord/resources/app/init.json"
}