summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--Discord.desktop12
-rw-r--r--Discord.install6
-rwxr-xr-xDiscord.sh2
-rw-r--r--LICENSE1
-rw-r--r--PKGBUILD59
6 files changed, 55 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 430e8178f88c..fe47496451ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
-# Generated by mksrcinfo v8
-# Tue Sep 6 07:01:17 UTC 2016
pkgbase = discord
- pkgdesc = Discord linux App
- pkgver = 0.0.8
+ pkgdesc = Discord Stable linux release
+ pkgver = 0.0.1
pkgrel = 1
url = https://discordapp.com/
+ install = Discord.install
arch = x86_64
- license = MIT
+ license = custom
depends = gtk2
depends = gconf
depends = libnotify
@@ -18,11 +17,14 @@ pkgbase = discord
optdepends = freetype2-infinality: If you have black screens with emojis install this.
optdepends = libpulse: For pulseaudio support
provides = discord
- conflicts = discord
source = Discord.desktop
- sha256sums = 0826f0a07a567d3d966563151329e3e155bf47da528f0698bd677cb46cc468de
- source_x86_64 = https://dl-canary.discordapp.net/apps/linux/0.0.8/discord-canary-0.0.8.tar.gz
- sha256sums_x86_64 = 7362afababed47a6c6ec114a755fdeccce247fe5de37a2e55bdb5dae639788bc
+ source = LICENSE
+ source = Discord.sh
+ md5sums = fdc9784f37b28178b2e9c498e4eebed9
+ md5sums = 86acf3328debd24b95cdd037a276e059
+ md5sums = 0dd3e753e0a96ad20de6b307bcd20b23
+ source_x86_64 = https://dl.discordapp.net/apps/linux/0.0.1/discord-0.0.1.tar.gz
+ md5sums_x86_64 = 8356283b4e72d36955fa2589d4dd321a
pkgname = discord
diff --git a/Discord.desktop b/Discord.desktop
index c2c2539d068f..813c857dd65e 100644
--- a/Discord.desktop
+++ b/Discord.desktop
@@ -1,8 +1,10 @@
[Desktop Entry]
Name=Discord
-Comment=Discord App
-Exec=discord
-Icon=discord
-StartupNotify=false
-Categories=Network;Chat;InstantMessaging
+Comment=All-in-one voice and text chat for gamers that's free, secure, and works on both your desktop and phone.
+GenericName=Internet Messenger
+Exec=/usr/bin/discord
+Icon=/usr/share/pixmaps/discord.png
Type=Application
+StartupNotify=true
+Categories=Network;InstantMessaging;
+StartupWMClass=discord
diff --git a/Discord.install b/Discord.install
new file mode 100644
index 000000000000..e7d9b8e3511a
--- /dev/null
+++ b/Discord.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ echo ">>> You may need to delete discord's cache directory ~/.cache/discord"
+ echo ">>> try this if discord is stuck on the updating screen or if nothing displays but a gray box"
+ echo ">>> if this doesn't work ask for help in #linux in the Discord Developers server https://discord.gg/UT7AMAP"
+ echo ">>> You may also want to check out the linux server for help as well https://discord.gg/e7GX27C"
+}
diff --git a/Discord.sh b/Discord.sh
new file mode 100755
index 000000000000..db443d0757ca
--- /dev/null
+++ b/Discord.sh
@@ -0,0 +1,2 @@
+#!/bin/bash
+PULSE_LATENCY_MSEC=30 /opt/discord/Discord
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..afdc5112be2a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1 @@
+Copyright (c) 2016 Hammer & Chisel
diff --git a/PKGBUILD b/PKGBUILD
index 10e903b0fbb9..451179e32925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,52 @@
-# Maintainer: Rock Neurotiko <miguelglafuente@gmail.com>
-# Contributor: Sergio Conde <skgsergio@gmail.com>
+# Maintainer: Cayde Dixon <me@cazzar.net>
+# Contributor: Anthony Anderson <aantony4122@gmail.com>
pkgname=discord
-pkgver=0.0.8
+pkgver=0.0.1
pkgrel=1
-pkgdesc='Discord linux App'
+pkgdesc='Discord Stable linux release'
arch=('x86_64')
url='https://discordapp.com/'
provides=('discord')
-conflicts=('discord')
-license=('MIT')
+license=('custom')
depends=('gtk2' 'gconf' 'libnotify' 'libxss' 'glibc' 'alsa-lib' 'nspr' 'nss')
-optdepends=('freetype2-infinality: If you have black screens with emojis install this.' 'libpulse: For pulseaudio support')
+optdepends=('freetype2-infinality: If you have black screens with emojis install this.' 'libpulse: For pulseaudio support' )
+install="Discord.install"
+source=(Discord.desktop LICENSE Discord.sh)
+source_x86_64=("https://dl.discordapp.net/apps/linux/${pkgver}/discord-${pkgver}.tar.gz")
+md5sums=('fdc9784f37b28178b2e9c498e4eebed9'
+ '86acf3328debd24b95cdd037a276e059'
+ '0dd3e753e0a96ad20de6b307bcd20b23')
+md5sums_x86_64=('8356283b4e72d36955fa2589d4dd321a')
-source=('Discord.desktop')
-source_x86_64=("https://dl-canary.discordapp.net/apps/linux/${pkgver}/discord-canary-${pkgver}.tar.gz")
-sha256sums=('0826f0a07a567d3d966563151329e3e155bf47da528f0698bd677cb46cc468de')
-sha256sums_x86_64=('7362afababed47a6c6ec114a755fdeccce247fe5de37a2e55bdb5dae639788bc')
-package() {
- case $CARCH in
- 'x86_64') _arch='x64';;
- esac
+#This is always latest build, right now I do not know of a version param.
- # Install files
- install -d "${pkgdir}/opt/discord"
- cp -a "${srcdir}/DiscordCanary/." "${pkgdir}/opt/discord/"
+package() {
+ # Install the main files.
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a "${srcdir}/DiscordPTB/." "${pkgdir}/opt/${pkgname}"
- mv "${pkgdir}/opt/discord/DiscordCanary" "${pkgdir}/opt/discord/discord"
+ # Exec bit
+ chmod 755 "${pkgdir}/opt/${pkgname}/Discord"
- # Make binary executable
- chmod 755 "${pkgdir}/opt/discord/discord"
- # Install desktop entry
+ # Desktop Entry
install -d "${pkgdir}/usr/share/applications"
install "${srcdir}/Discord.desktop" "${pkgdir}/usr/share/applications"
- # Create symbolic link to the main binary
+ # Main binary
install -d "${pkgdir}/usr/bin"
- ln -s "/opt/discord/discord" "${pkgdir}/usr/bin/discord"
+ #ln -s "/opt/${pkgname}/DiscordCanary" "${pkgdir}/usr/bin/DiscordCanary"
+ #installing from .sh due to how the tar extracts.
+ install "${srcdir}/Discord.sh" "${pkgdir}/usr/bin/discord"
# Create symbolic link to the icon
install -d "${pkgdir}/usr/share/pixmaps"
- ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/discord.png"
-
- # Install license file
- # install -Dm644 "${pkgdir}/opt/discord/LICENSE" "${pkgdir}/usr/share/licenses/discord/LICENSE"
- # rm "${pkgdir}/opt/discord/LICENSE"
+ ln -s "/opt/${pkgname}/discord.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
- # Dirty hack... we should tell the developer to store settings in user home...
- # chmod 666 "${pkgdir}/opt/discord/resources/app/init.json"
+ # License
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}