summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
-rw-r--r--discord-chat-exporter-plus-cli2
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30d449981ea1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = discord-chat-exporter-plus-cli
+ pkgdesc = Exports Discord chat logs to a file (without the political bloat)
+ pkgver = 2.42.7
+ pkgrel = 1
+ url = https://github.com/nulldg/DiscordChatExporterPlus
+ arch = any
+ license = MIT
+ makedepends = dotnet-sdk-8.0
+ depends = dotnet-runtime-8.0
+ conflicts = discord-chat-exporter-cli
+ options = !strip
+ source = discord-chat-exporter-plus-cli-2.42.7.tar.gz::https://github.com/nulldg/DiscordChatExporterPlus/archive/refs/tags/2.42.7.tar.gz
+ source = discord-chat-exporter-plus-cli
+ b2sums = d0b770dbd7b1d434642370ec748009cd0c2046c71e3b6ad41184bdafab099b035c7294161a6ff7728856081c1fa14e15bf76bb2154b8f17e9464d6315826cf17
+ b2sums = 315f8043cd13d1b8173531db1be93a842a11d8b2a12defc6ed07701ae56871cff5c99ff69d7a757fa1ccc821ce2f2652a5e0ee1160bdca2b6cab75eaa4ef6e8e
+
+pkgname = discord-chat-exporter-plus-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60fc437c3b1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: cgar <notify-cgar -AT- outlook -DOT- com>
+
+pkgname='discord-chat-exporter-plus-cli'
+_apkgname='DiscordChatExporter'
+_gpkgname='DiscordChatExporterPlus'
+pkgver=2.42.7
+pkgrel=1
+
+pkgdesc='Exports Discord chat logs to a file (without the political bloat)'
+url="https://github.com/nulldg/$_gpkgname"
+license=(MIT)
+arch=(any)
+conflicts=('discord-chat-exporter-cli')
+
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+ "$pkgname"
+)
+b2sums=(
+ d0b770dbd7b1d434642370ec748009cd0c2046c71e3b6ad41184bdafab099b035c7294161a6ff7728856081c1fa14e15bf76bb2154b8f17e9464d6315826cf17
+ 315f8043cd13d1b8173531db1be93a842a11d8b2a12defc6ed07701ae56871cff5c99ff69d7a757fa1ccc821ce2f2652a5e0ee1160bdca2b6cab75eaa4ef6e8e
+)
+
+options=('!strip')
+
+depends=('dotnet-runtime-8.0')
+makedepends=('dotnet-sdk-8.0')
+
+build() {
+ cd "$_gpkgname-$pkgver"
+ dotnet publish "$_apkgname.Cli" --configuration "Release"
+}
+
+package() {
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ cd "$_gpkgname-$pkgver/$_apkgname.Cli/bin/Release/net8.0/publish"
+ find . -type f -exec install -Dm644 "{}" "$pkgdir/usr/lib/$pkgname/{}" \;
+}
diff --git a/discord-chat-exporter-plus-cli b/discord-chat-exporter-plus-cli
new file mode 100644
index 000000000000..0737f782296b
--- /dev/null
+++ b/discord-chat-exporter-plus-cli
@@ -0,0 +1,2 @@
+#!/usr/bin/env sh
+exec dotnet /usr/lib/discord-chat-exporter-plus-cli/DiscordChatExporterPlus.CLI.dll "${@}"