summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bac9821e149..60b836a98227 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = disman-kwinft
pkgdesc = Qt/C++ display management library
- pkgver = 5.26.0
+ pkgver = 5.26.5.r1847.g8f7345c
pkgrel = 1
url = https://gitlab.com/kwinft/disman
arch = x86_64
+ arch = aarch64
license = LGPL
makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = kdoctools
+ makedepends = qt5-tools
+ depends = kcoreaddons
depends = qt5-x11extras
- depends = libxrandr
- depends = plasma-framework
depends = wrapland
provides = disman
conflicts = disman
- source = https://gitlab.com/kwinft/disman/-/archive/disman@0.526.0/disman-disman@0.526.0.tar.gz
- md5sums = a582100359e2d28f3eaf72d2f0413d21
+ source = git+https://gitlab.com/kwinft/disman.git
+ sha256sums = SKIP
pkgname = disman-kwinft
diff --git a/PKGBUILD b/PKGBUILD
index 0f37e57fa6d6..3481e6016fa0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
# Author: Roman Gilg <subdiff@gmail.com>
pkgname=disman-kwinft
-pkgver=5.26.0
-_pkgver=0.526.0
+pkgver=5.26.5.r1847.g8f7345c
pkgrel=1
pkgdesc='Qt/C++ display management library'
-arch=(x86_64)
+arch=(x86_64 aarch64)
url="https://gitlab.com/kwinft/disman"
license=(LGPL)
-depends=(qt5-x11extras libxrandr plasma-framework wrapland)
+depends=(kcoreaddons qt5-x11extras wrapland)
provides=("disman")
conflicts=("disman")
-makedepends=(extra-cmake-modules)
-source=("https://gitlab.com/kwinft/disman/-/archive/disman@$_pkgver/disman-disman@$_pkgver.tar.gz")
-md5sums=('a582100359e2d28f3eaf72d2f0413d21')
+makedepends=(extra-cmake-modules git kdoctools qt5-tools)
+source=("git+https://gitlab.com/kwinft/disman.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ _ver=5.26.5
+ cd disman
+ echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
prepare() {
- tar -xvf disman-disman@$_pkgver.tar.gz
- mkdir -p "$srcdir"/build/make
+ mkdir -p build
}
build() {
- cd "$srcdir"/build
- cmake "$srcdir/disman-disman@$_pkgver" \
+ cd build
+ cmake ../disman \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_LIBEXECDIR=lib \
- -DCMAKE_INSTALL_USE_QT_SYS_PATHS=ON \
-DBUILD_TESTING=OFF
make
}
package() {
- cd "$srcdir"/build
+ cd build
make DESTDIR="$pkgdir" install
}